Regression: Gimp has no progressbar

Bug #537275 reported by John Doe on 2010-03-11
154
This bug affects 29 people
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
Medium
gimp (Ubuntu)
Low
Ubuntu Desktop Bugs
Lucid
Low
Ubuntu Desktop Bugs

Bug Description

-- Lucid SRU report follows --

Impact: A common and visible part of GIMP's UI has disappeared due to Lucid's switch to gtk 2.19. This will cause confusion for new GIMP users (the UI won't match tutorials) as well as existing users.

The bug has been fixed upstream, with new code for the gtk 2.19 case.

Patch: http://launchpadlibrarian.net/45887889/gimp_2.6.8-2ubuntu1.1.debdiff

To reproduce: open any image and look at the bottom of the image window. If there's nothing there, you're seeing the bug. There should be a units menu (e.g. px), a zoom menu (e.g. 100%) and the regular progress area (probably showing the name of the current layer). See http://docs.gimp.org/2.6/en/images/using/imagewindow-description.png

Regression potential: should be low risk, since the code has been in the gimp trunk for a few weeks, and the alternative is the current broken status bar.

====================
Binary package hint: gimp

Gimp has lost his Progressbar within the Statusfield that showed the progress of filters or saving files. This is extremly nasty, the reasons are obvious.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 11 12:19:15 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100307)
Package: gimp 2.6.8-2ubuntu1
ProcEnviron:
 LANGUAGE=C
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: gimp
Uname: Linux 2.6.32-16-generic i686

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Changed in gimp (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Angel Abad (angelabad) on 2010-03-15
Changed in gimp:
importance: Undecided → Unknown
status: New → Unknown

Ok, then. The Guys from Gnome are thinking it's Ubuntu-related ans I should report this against Ubuntu. So, what to do now?

Also, I've uploaded a Video in the Gnome Report that is showing the Problem in "action".

See:

http://www.file-upload.net/download-2350409/out.ogv.html

I ran some tests. First, with Karmic Koala Live-CD and Gimp 2.6.7. I've attached a screenshot. I noticed that Gimp in Lucid has not only lost his Progressbar in the Statusbar but also the two Dropdownfields. Have look on the attached Karmic-Screenshot and you will see.

And the very same Image, here with Lucid and Gimp 2.6.8. As you can see, dropdownfields are gone.

Changed in gimp (Ubuntu):
status: New → Triaged
Ricardo Pérez López (ricardo) wrote :

Seems to be fixed upstream. From https://bugzilla.gnome.org/show_bug.cgi?id=612956:

Backported Mitch's fix from master to gimp-2-6:

commit 501c4f65f08c111df0654cb887d95c2c06e82710
Author: Nils Philippsen <email address hidden>
Date: Wed Mar 24 18:08:01 2010 +0100

    backport statusbar code needed for GTK+ >= 2.19.1

    Use the hbox that is provided via gtk_statusbar_get_message_area()
    since GTK+ 2.19.1.

 app/display/gimpstatusbar.c | 32 +++++++++++++++++++++++++-------
 1 files changed, 25 insertions(+), 7 deletions(-)

Could this patch be applied against the Ubuntu package? That will be great!

Bhaskar Kandiyal (bkandiyal) wrote :

I've generated a debdiff for the developers review so they can patch the Ubuntu package with it. I've tested it and it's working. I have also uploaded the patched version to my ppa for those who don't wish to wait :) My ppa is at: ppa:gastly/gastly-main

My Hero. ;) Tested the packages from yout PPA and what should I say: works like a charm!

Tested gimp_2.6.8-2ubuntu2~ppa1_i386.deb package from gastly's PPA. Works here, too. Thanks!

Changed in gimp:
status: Unknown → Fix Released

May the Bhaskar's debdiff be applied to the official Ubuntu gimp packages before Lucid release?

Bhaskar Kandiyal (bkandiyal) wrote :

I've subscribed the Ubuntu Sponsors team, maybe they will look into it and update the package.

otzenpunk (reisswolf-nospam) wrote :

Anybody willing (and able) to raise the importance of this bug? I really miss the zoom and length unit widgets.

Akkana Peck (akkzilla) wrote :

Here's a slightly updated version of Bhaskar Kandiyal's debdiff (changing the version number and mentioning the upstream commit) for use in an SRU request.

description: updated
Daniel T Chen (crimsun) on 2010-04-28
Changed in gimp (Ubuntu):
milestone: none → lucid-updates
Akkana Peck (akkzilla) on 2010-04-28
description: updated
Martin Pitt (pitti) wrote :

Thanks! Committed to packaging bzr, I'll sponsor.

tags: added: regression-release
Daniel T Chen (crimsun) wrote :

Please note that I uploaded the source about eleven hours ago (but failed to push to bzr, sorry).

Hello Daniel,

Daniel T Chen [2010-04-28 17:04 -0000]:
> Please note that I uploaded the source about eleven hours ago (but
> failed to push to bzr, sorry).

Ah, thanks. I rejected my upload.

Accepted gimp into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gimp (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

I tested the package from lucid-proposed and confirm that the status bar is back, and working well. Thanks!

tags: added: verification-done
removed: verification-needed

Confirming. Many thanks!

timosha (timosha) wrote :

Works with lucid-proposed update. Thanks a lot.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.8-2ubuntu1.1

---------------
gimp (2.6.8-2ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/04_gimp-statusbar.patch:
    + Fixes bug where some elements are not shown in the statusbar (LP: #537275)
      Origin: upstream commit 501c4f65f08c111df0654cb887d95c2c06e82710
 -- Bhaskar Kandiyal <email address hidden> Tue, 13 Apr 2010 17:09:23 +0530

Changed in gimp (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied lucid-proposed to maverick.

Changed in gimp (Ubuntu):
status: Fix Committed → Fix Released
Changed in gimp (Ubuntu Lucid):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.8-2ubuntu1.1

---------------
gimp (2.6.8-2ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/04_gimp-statusbar.patch:
    + Fixes bug where some elements are not shown in the statusbar (LP: #537275)
      Origin: upstream commit 501c4f65f08c111df0654cb887d95c2c06e82710
 -- Bhaskar Kandiyal <email address hidden> Tue, 13 Apr 2010 17:09:23 +0530

Changed in gimp (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in gimp:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.