Ubuntu

Gimp does not start since last Jauty updates

Reported by Gustavo A. Díaz on 2009-04-04
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by JK

Bug Description

Binary package hint: gimp

Hi,

Since today last updates, Gimp stopped to work. I was using it before issuing and dist-upgrade with apt.
I am using Kubuntu Jaunty. When I launch Gimp (from kde menu or a terminal/konsole) it does not show its window... but the process runs:

gustavo 8014 3.6 0.2 39472 6676 pts/1 Sl+ 02:35 0:00 gimp

Under the console, i have the follows msgs:

(gimp-2.6:8019): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp-2.6:8019): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp-2.6:8019): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp-2.6:8019): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp-2.6:8019): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'

And I have to kill the process. Since if i launch Gimp again, will start a new one:

gustavo 8023 1.7 0.2 39472 6676 pts/1 Sl+ 02:36 0:00 gimp
gustavo 8026 2.2 0.2 39472 6676 pts/2 Sl+ 02:36 0:00 gimp

Thank you for taking time to report this issue, it helps make Ubuntu better. Confirmed.

Changed in gimp (Ubuntu):
status: New → Confirmed

This will be fixed Guys? Since I really need Gimp to work...

--
Gustavo A. Díaz
GDNet Projects
www.gdnet.com.ar

Gustavo A. Díaz (gdiaz) wrote :

As today jaunty was released and still i am not available to use Gimp...
What is the status of this?

Thanks.

Montblanc (montblanc) wrote :

I can confirm this: after upgrading to Jaunty everything is as described in this bug report. I really need gimp to work, I'm not asking that much. Is there anything else we can do to help you fix this bug?

Nikola Yanev (gericom) wrote :

the same here!!!
how to work without gimp, hey guys, i need it, since i am involved in a project and i can't do anything :(
here is the terminal output to me:

gericom@hummer:~$ gimp-2.6 %U

(gimp-2.6:13145): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp-2.6:13145): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp-2.6:13145): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp-2.6:13145): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp-2.6:13145): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'

Montblanc (montblanc) wrote :

The problem is with libgegl-0.0-0 version 0.0.23-5pre~SVN20090330, you
have to downgrade it to 0.0.22-0ubuntu3 and prevent apt from upgrading
it.

sudo apt-get install --reinstall libgegl-0.0-0=0.0.22-0ubuntu3
sudo -s
echo libgegl-0.0-0 hold | dpkg --set-selections

(To unhold it:)
sudo dpkg --clear-selections

2009/4/27 Nikola Yanev <email address hidden>:
> the same here!!!
> how to work without gimp, hey guys, i need it, since i am involved in a project and i can't do anything :(
> here is the terminal output to me:
>
> gericom@hummer:~$ gimp-2.6 %U
>
> (gimp-2.6:13145): GLib-GObject-WARNING **: specified class size for type
> `GimpOperationPointFilter' is smaller than the parent type's
> `GeglOperationPointFilter' class size
>
> (gimp-2.6:13145): GLib-CRITICAL **: g_once_init_leave: assertion
> `initialization_value != 0' failed
>
> (gimp-2.6:13145): GLib-GObject-CRITICAL **: g_type_register_static:
> assertion `parent_type > 0' failed
>
> (gimp-2.6:13145): GLib-CRITICAL **: g_once_init_leave: assertion
> `initialization_value != 0' failed
>
> (gimp-2.6:13145): GLib-GObject-WARNING **: cannot retrieve class for
> invalid (unclassed) type `<invalid>'
>
> --
> Gimp does not start since last Jauty updates
> https://bugs.launchpad.net/bugs/354962
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nikola Yanev (gericom) wrote :

thanx, i downgraded & held the package as a temporary decision and it works ;)
thanx

Savvas Radevic (medigeek) wrote :

This was fixed:

$ apt-cache policy libgegl-0.0-0
libgegl-0.0-0:
  Installed: 0.0.22-0ubuntu3
  Candidate: 0.0.22-0ubuntu3
  Version table:
 *** 0.0.22-0ubuntu3 0
        500 http://rs.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

In the future, if anyone's gimp is not running, be sure to kill all instances and try again:

killall -9 -r gimp
gimp --verbose

Changed in gimp (Ubuntu):
status: Confirmed → Fix Released

So today is October 23rd, six days before the official Karmic Koala, and this bug is affecting me. I’m using ubuntu karmic, beta. I’ve tried what Montblanc suggested above, but it didn’t work. Any suggestions?

Thanks.

The same here for me: I am experiencing this bugs since a few days but wasn't sure, if it is a karmic or a pebkac-problem.

The verbose-output does not print out any usefull data:

me@my-pc:~$ gimp --verbose
INIT: gimp_load_config
Parsing '/home/barabbas/.gimp-2.6/unitrc'
Parsing '/etc/gimp/2.0/gimprc'
Parsing '/home/barabbas/.gimp-2.6/gimprc'
gimp_composite: use=yes, verbose=no
Processor instruction sets: +mmx +sse +sse2 -3dnow -altivec -vis

(gimp:20628): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp:20628): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:20628): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp:20628): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:20628): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'

As gdb told me, that there is no "stack" and "the program has no registers now", I run strace. Output appended.

sake12 (sake12) wrote :

GIMP 2.6.10... and I still have this bug... ??
How to fix it??

Changed in gimp (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Released
WebNuLL (babciastefa) wrote :

I have the same problem on Maverick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments