Gimp: toolbox windows can't be minimized

Bug #283115 reported by Michael Kofler on 2008-10-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
Low
gimp (Ubuntu)
Low
Unassigned

Bug Description

gimp 2.6 in intrepid:
it is impossible to minimize toolbar windows; they have only a x-Button to close

ideally, these windows should be minimized automatically when the (last) Gimp image window is minimized

Update
While waiting, I designed some sort of workaround :
Gnome>System>Preferences>Windows>Double-click titlebar>Roll up

Philip Wyett (philwyett) wrote :

See linked to upstream bug.

Using TAB will minimize and maximize the two dialogs.

Changed in gimp:
status: Unknown → Confirmed
André Pirard (a.pirard) wrote :

This bug is NOT a duplicate of bug #288461.
Bug #288461 says that GIMP images are below GIMP dialogs when GIMP is used.
Bug #283115 says that when GIMP is not in use, its dialogs clutter the screen because they can't be minimized.

André Pirard (a.pirard) wrote :

While waiting, I put up a sort-of workaround :
Gnome>System>Preferences>Windows>Double-click titlebar>Roll up

description: updated
Changed in gimp:
importance: Unknown → Low

This ain't no bug, just discovered it recently

http://docs.gimp.org/2.6/en/gimp-pimping.html#gimp-prefs-window-management

See figure 11.23 Hint for other docks - select "normal window" means you get back the little "x"

bug solved - pls confirm !

> bug solved - pls confirm !
Indeed for me (GIMP 2.6.8, Lucid, Metacity). However...
- I'm surprised that "Normal" is not the default option, be it only to
do without 2-year bugs like this.
- The upstream discussion is surprising (including not knowing the
versions they speak of)
- Shouldn't upstream bug be closed first?
- The windows buttons are on the left (doc error) or should be on the
right (Ubuntu error).
  By Jove make up your mind.

Changed in gimp (Ubuntu):
status: New → Confirmed

Far too many people closed these two windows and didn't realize how to get them back. That needed a decision then, not to state these Windows as "normal" in the Standard-Configuration. Fine 4 me.

Window Buttos to the left or to the right, doesn't matter you can influence this yourself as a user with the right commands. (one of the first things I did, after fresh-install of Lucid- I'll always do a fresh-install) 4 the fine old habbits. Buttons to the left starts making sense with Unity-Windows-Manager in Natty Narwhale...

Since I know Bug-Tracking Upstream works by now, I am confident this solution will arrive. And yes you are right, it should get closed upstream first...

 It's not me and you but the kind of people I help, their amazement and
subsequent literature.
52000 hits, they say: http://www.google.be/search?&q="maximize minimize
close"

These docks definetly have a close-button. I think everybody can agree on that. Let's pick another example the graphical window of su is called gksu. There ain't no "max-min-close"-buttons at all, once the window appears, just "cancel" and "esc".

The big thing here is really, that all three windows are to be treated separately. Whatever philosophy is behind this design idea. So somehow or another I think this is, were design comes to battle between philosophy in usage against usability. There will may be always a bit of overlapping, most politely expressed.

As said before for me it works and I'm happy with my discovery. And I'm happy I can move them to another workspace, and furthermore I'm happy there is enough space 4 my graphics . But I were looking for a solution since quite a bit of time. So this one has found an entry into our local Ubuntu-Wiki.

Don't ask me how to I struggled to understand everything I can adjust in VLC (probably i'm not around all yet)

Cheers

For the fix read comment # 4 here, pls.

Changed in gimp (Ubuntu):
status: Confirmed → Fix Committed
André Pirard (a.pirard) wrote :

Does the fix make "Normal" the default option so that people don't look for those buttons during two years?
Read comment # 5 here, pls.

Changed in gimp (Ubuntu):
status: Fix Committed → In Progress
status: In Progress → New

Must apologize, commiting a fix is something else, than what I did. It was just a description of programm handling, within the given measures a described in the online documention.

Therefor I changed the status back to "new" because it won't change the programm, neither is it a patch to it.

Users may try to use it, or revert it back to the "standard" it. It's at least changeable within the given pattern

Changed in gimp (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in gimp:
status: Confirmed → Fix Released

Found a little "gem" in the documentation:

>> Press TAB in an Image window to toggle the visibility of the docks. This is useful if the docks hide a portion of the image Window. You can quickly hide all the docks, do your work, then display all the docs again. Pressing TAB inside a dock to navigate through the dock. <<

above point 2.3.2 -> http://docs.gimp.org/en/gimp-concepts-docks.html

AND this still works in GIMP 2.8.2 === seems Wilbur is a little genie ===

This information was added to our local ubuntu-wiki by myself in order to encourage anyone to write & read documentation. Test it + spread the word.

byebye

Thomas Hotz (thotz) on 2013-06-18
summary: - gimp 2.6: toolbox windows can't be minimized
+ Gimp: toolbox windows can't be minimized
Thomas Hotz (thotz) on 2013-08-01
Changed in gimp (Ubuntu):
status: Triaged → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.