Please merge gimp 2.4.3-1 (main) from Debian unstable

Bug #177821 reported by Pedro Fragoso on 2007-12-21
4
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gimp

gimp (2.4.3-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable, Ubuntu remaining changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch: Distro changes.
    - Weave i18n magic in the rules file.
    - Remove the doc directory symlink in the preinst, and replace it with a
      directory.
    - Conflicts and Replaces against gimp-print and stop building with --withou$
    - Added NEWS, README and README.Debian to gimp.docs.
   * Modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Pedro Fragoso <email address hidden> Tue, 18 Dec 2007 10:44:11 +0000

Related branches

Pedro Fragoso (ember) wrote :
Changed in gimp:
importance: Undecided → Wishlist
Daniel Holbach (dholbach) wrote :

Steve: can you take a look at this?

Steve Kowalik (stevenk) wrote :

Okay, a few things.

- Conflicts and Replaces against gimp-print and stop building with --without-print
That isn't an Ubuntu change, since it's exactly what Debian are doing, and I believe it was marked as dropped in 2.4.2-1ubuntu1.

* Modify Maintainer value to match Debian-Maintainer-Field Spec
That's an existing Ubuntu changes, and should listed under the remaining Ubuntu changes

Personally, I'd prefer the first two lines to be:
 * Merge from Debian unstable. (LP: #177821)
 * Remaining Ubuntu changes:
   ....

Other than that, the merge looks good, keep me posted.

Pedro Fragoso (ember) wrote :

Thanks, fixed will all your suggestions.

Pedro Fragoso (ember) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.4.3-1ubuntu1

---------------
gimp (2.4.3-1ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. (LP: #177821)
  * Ubuntu remaining changes:
    - 02_help-message.patch, 03_gimp.desktop.in.in.patch: Distro changes.
    - Weave i18n magic in the rules file.
    - Remove the doc directory symlink in the preinst, and replace it with a
      directory.
    - Added NEWS, README and README.Debian to gimp.docs.
    - Modify Maintainer value to match Debian-Maintainer-Field Spec

gimp (2.4.3-1) unstable; urgency=low

  * New upstream version
  * Start using symbol versioning in libgimp2.0

gimp (2.4.2-2) unstable; urgency=low

  * Create custom libgimp2.0 depends for the gimp package since the two
    versions need to be consistent (Closes: #452755)
  * Conflict with older versions of gimp-help since they no longer work
    with the new gimp. (Closes: #454109)
  * Merge -helpbrowser back into gimp package; add Provides: gimp-helpbrowser
    for compatibility with existing gimp-help packages

 -- Pedro Fragoso <email address hidden> Tue, 18 Dec 2007 10:44:11 +0000

Changed in gimp:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers