FFe: Sync gimp 2.10.0~RC2-1 (universe) from Debian experimental (main)

Bug #1759625 reported by Jeremy Bicha on 2018-03-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MyPaint
New
Unknown
gimp (Ubuntu)
Wishlist
Unassigned
Bionic
Wishlist
Unassigned

Bug Description

Feature Freeze Justification
============================
gimp's last new stable series, 2.8, was released 6 years ago. The new series has years of work porting gimp to use gegl more completely, an integrated crash report tool, and many more improvements.

The Gimp development team is so small that I do not expect there to be much support at all for gimp 2.8 any more.

Future
======
If the final gimp 2.10 is not released before Ubuntu 18.04 LTS is, then we should do an SRU to update it then.

The Gimp developers have announced that they will add features to future 2.10 releases so that users won't have to wait several years like this again.

Gimp 3.0 will switch to gtk3 (or gtk4).

Affected Flavors
================
Ubuntu Studio is the only flavor to include gimp by default.

Changes
=======
This entire file!
https://git.gnome.org/browse/gimp/tree/NEWS

Features are described in several blog posts documenting the 2.9 development releases at https://www.gimp.org/news/

Changes in the new Debian version
=================================
Uploaded to experimental on request of the Debian maintainer Ari Pollack.

 gimp (2.10.0~RC1-1) experimental; urgency=medium
 .
   * New upstream release candidate (LP: #1759625)
     - Fixes screenshots in GNOME and KDE on Wayland (Closes: #880186)
       (LP: #1739684)
   * Bump dependencies per configure.ac
   * Add new Build-Depends: gegl, glib-networking, libgexiv2-dev,
     libmypaint-dev, libopenjp2-7-dev (Closes: #827083), libopenexr-dev,
     libwebp-dev, mypaint-brushes, python-cairo-dev
   * Depend on xdg-utils for email feature
   * Update debian/libgimp2.0.symbols
   * Drop all patches (except 01_hurd_ftbfs.patch) since they are obsolete
     with the new release

Jeremy Bicha (jbicha) on 2018-04-02
description: updated
summary: - Update gimp to 2.10
+ FFe: Sync gimp 2.10.0~RC1-1 (universe) from Debian experimental (main)
description: updated
description: updated
tags: added: bionic

Unfortunately updating gimp to 2.10 breaks mypaint. Until mypaint is updated to a version that uses the newer version of libmypaint, we will be unable to include gimp at this time as it will cause workflow difficulties with some of our userbase. Releasing gimp 2.10 as an SRU (so long as mypaint can be updated to 1.3 after its release) would be the best route. Another option is to encourage the snap version of gimp 2.10 once released for those who want/need it.

At this time, on behalf of the Ubuntu Studio team, we recommend no FFe for this case as it will break mypaint.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
summary: - FFe: Sync gimp 2.10.0~RC1-1 (universe) from Debian experimental (main)
+ FFe: Sync gimp 2.10.0~RC2-1 (universe) from Debian experimental (main)
affects: gimp → mypaint
Changed in mypaint:
status: Unknown → New
Jeremy Bicha (jbicha) wrote :

I'm closing this bug. We're not going to include gimp 2.10 in Ubuntu 18.04 LTS so it's probably better to close this bug so that we don't confuse people.

gimp 2.10 will be autosynced to Ubuntu 18.10 when autosync is turned on (maybe in a week or two).

Changed in gimp (Ubuntu):
status: Confirmed → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

If you don't plan to include GIMP 2.10 into bionic then please set status of this bug to Wontfix

Jeremy Bicha (jbicha) wrote :

The bug didn't say it needed to happen in bionic, but ok…

no longer affects: gimp (Ubuntu Bionic)
Jeremy Bicha (jbicha) wrote :

Because of how Launchpad works, I need to wait until 18.10 development opens to mark this wontfix for bionic.

Jeremy Bicha (jbicha) on 2018-05-02
Changed in gimp (Ubuntu Bionic):
importance: Undecided → Wishlist
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.