gimp screenshots are broken

Bug #1739684 reported by Michael Leibowitz on 2017-12-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Undecided
Unassigned

Bug Description

Upon taking a screenshot in gimp, the resulting image is all black pixels.

To replicate, File->Create->Screenshot. Any combination of options results in black image.

$ cat /etc/os-release
NAME="Ubuntu"
VERSION="17.10 (Artful Aardvark)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 17.10"
VERSION_ID="17.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=artful
UBUNTU_CODENAME=artful

$ dpkg -l gimp gimp-data gnome-session
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii gimp 2.8.20-1 amd64 GNU Image Manipulation Program
ii gimp-data 2.8.20-1 all Data files for GIMP
ii gnome-session 3.26.1-0ubun amd64 GNOME Session Manager - GNOME 3 s

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
Kentaro Hayashi (kenhys) wrote :

I'm also hit this bug. captured image is black on wayland.

~$ env | grep wayland
WAYLAND_DISPLAY=wayland-0
XDG_SESSION_TYPE=wayland

$ dpkg -l gimp gimp-data
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii gimp 2.8.20-1 amd64 GNU Image Manipulation Program
ii gimp-data 2.8.20-1 all Data files for GIMP

Kentaro Hayashi (kenhys) wrote :
Kentaro Hayashi (kenhys) wrote :

FYI:

There are related bugs.
It may be fixed in Gimp 2.10.

gimp: screenshot does not work with wayland
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=880186

Bug 757687 - Screenshot functionality broken under Wayland
https://bugzilla.gnome.org/show_bug.cgi?id=757687

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.10.0-3

---------------
gimp (2.10.0-3) unstable; urgency=medium

  * Fix dh_python2 override
  * Bump gimp-python's Breaks/Replaces: gimp because of mistake in 2.10.0-2
    (Closes: #897167)
  * Have libgimp-dev depend on libgegl-dev (Closes: #897160)
  * Cherry-pick 0002-gimp.pc-Fix-reference-to-gegl-0.3.patch:
    - Update gimp.pc for gegl soname bump

 -- Jeremy Bicha <email address hidden> Sun, 29 Apr 2018 08:16:57 -0400

Changed in gimp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.