Gimp tooltip text color is white on white

Bug #1515829 reported by Daniel Barrett on 2015-11-13
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Undecided
Unassigned

Bug Description

In the gimp toolbox, when I hover my mouse over a tool, the tooltip that pops up has white text on a white background.
See screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: gimp 2.8.14-1ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Nov 12 20:18:16 2015
InstallationDate: Installed on 2013-08-31 (803 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
SourcePackage: gimp
UpgradeStatus: Upgraded to wily on 2015-11-08 (4 days ago)

Daniel Barrett (dbarrett-m) wrote :
pascal (pascal-ortiz) wrote :

I have the same problem under Kubuntu 15.10 freshly installed. Text tooltip is undiscernible.

antonio (antonio-cortes-public) wrote :

A work around to this problem is explained in the following link:
http://www.iwillfolo.com/how-to-change-gtk-apps-tooltips-text-and-background-color/

The problem seems to be some incompatibility as explained in that page, as per quote below:
"When utilizing a desktop environment other than GNOME, or when using a non-default theme in GNOME-shell itself, you may often encounter incompatibilities which are mostly reflected through native GTK apps such as GIMP, Nautilus, Totem, etc…"

The solution explained there about modifying file "~/.gtkrc-2.0" worked for me.

Daniel Barrett (dbarrett-m) wrote :

Thank you, antonio -- your workaround in comment #3 fixed the problem for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
Tiedemate (bjoerntiedemann) wrote :

As the link of comment 3 is no longer available, I searched for e new workaround. For me deactivating "Apply colours to non-QT applications" in System settings -> Colour -> Options fixes the issue in KDE plasma 5.7.5. Maybe this should be deactivated by default?

Marcin Kos (kosmo76) wrote :

Method described in comment #6 works for me (Kubuntu 16.04.1 LTS)

Christine Anderson (cdanderson) wrote :

Confirmed that method described in comment #6 works for me too (Kubuntu 16.04.1 LTS). Thank you for the workaround.

Scott Deagan (scott-deagan) wrote :

Can confirm that method describe in comment #6 works for me on Kubuntu 17.10. Thank you!

Scott Wells (scottwww81) wrote :

The solution in comment # 6 was key to me fixing this annoying problem on my openSUSE Leap 42.1 KDE install.

The checkbox was found by searching "Desktop", selecting Configure Desktop. In the Appearance section, select Color. Select the Options tab. Remove the checkmark from "Apply colors to non-Qt applications". Apply. Close any Inkscape items, and open Inkscape.

Icon descriptions changed to white text on a black field, rather than white on white. Now, I can more easily learn how to use Inkscape.

Jari Laamanen (yartsa) wrote :

Thank you #6 for posting the solution to this thread! It solved my problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers