package gimp 2.4.0~rc3-1ubuntu4 failed to install/upgrade: trying to overwrite `/usr/share/doc/libgimp2.0/README', which is also in package libgimp2.0

Bug #148985 reported by Chad Waters on 2007-10-04
306
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Medium
Unassigned
Declined for Feisty by Sebastien Bacher
Nominated for Gutsy by Progress Nerd

Bug Description

Binary package hint: gimp

File conflict...

Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_i386.deb (--unpack):
 trying to overwrite `/usr/share/doc/libgimp2.0/README', which is also in package libgimp2.0
dpkg-deb: subprocess paste killed by signal (Broken pipe)

Thanks
-Chad

ProblemType: Package
Architecture: i386
Date: Thu Oct 4 10:55:26 2007
DistroRelease: Ubuntu 7.10
ErrorMessage: trying to overwrite `/usr/share/doc/libgimp2.0/README', which is also in package libgimp2.0
Package: gimp 2.4.0~rc3-1ubuntu4
PackageArchitecture: i386
SourcePackage: gimp
Title: package gimp 2.4.0~rc3-1ubuntu4 failed to install/upgrade: trying to overwrite `/usr/share/doc/libgimp2.0/README', which is also in package libgimp2.0
Uname: Linux ccw-ubuntu 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Related branches

Chad Waters (chad) wrote :
aldebx (aldebx) wrote :

same here

relik (dkennedy) wrote :

same here..

aldebx (aldebx) wrote :

a temporary workaround to get rid of the broken dependency is going to /var/cache/apt/archives and issuing command sudo dpkg -i gimp-python_2.4.0~rc3-1ubuntu4_i386.deb which will downgrade gimp-python to previous version (if available in cache).

This will prevent "broken packages" message to appear, as far as you do not update gimp and gimp-python packages again to this broken revision.

Matthias Klose (doko) wrote :

gimp (2.4.0~rc3-1ubuntu6) gutsy; urgency=low

  * debian/gimp.docs: Remove duplicate doc files. LP: #148985.

 -- Matthias Klose <email address hidden> Thu, 04 Oct 2007 17:11:12 +0200

Changed in gimp:
status: New → Fix Released
Saitoh (awbailey001) wrote :

Same here, the workaround does not work for me as I don't have an that archive.

Amit Kumar Sharma (amit.9b) wrote :

-- Temporary Fix --

STEP 1: Run
 # dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_i386.deb

this will overwrite the conflicting file and then give unmet dependencies error.

STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
Run :
  # apt-get -f install

10nix (10nix) wrote :

I get the same on amd64 architecture

This also worked for me.

Thanks

On 10/4/07, amit_9b <email address hidden> wrote:
> -- Temporary Fix --
>
> STEP 1: Run
> # dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_i386.deb
>
> this will overwrite the conflicting file and then give unmet
> dependencies error.
>
> STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
> Run :
> # apt-get -f install
>
> ** Attachment added: "log of issuing the above commands"
> http://launchpadlibrarian.net/9727412/log.txt
>
> --
> package gimp 2.4.0~rc3-1ubuntu4 failed to install/upgrade: trying to overwrite `/usr/share/doc/libgimp2.0/README', which is also in package libgimp2.0
> https://bugs.launchpad.net/bugs/148985
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
------------------------------------------------
Pedro Albarran
Departamento de Economia
Universidad Carlos III de Madrid
C./ Madrid, 126
28903 Getafe (Madrid)
SPAIN

Phone: +34 91 624 5738
Fax: +34 91 624 9875
Email: <email address hidden>
------------------------------------------------

re: amit9b's fix.

worked for me too. thanks.

Paul820 (p-dale820) wrote :

Same here on amd64, gutsy beta.

Savvas Radevic (medigeek) wrote :

amd64:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_amd64.deb
sudo apt-get -f install
sudo apt-get update

The workaround is successful here as well.

Works for me. Thanks!

-Markku

On 10/4/07, amit_9b <email address hidden> wrote:
>
> -- Temporary Fix --
>
> STEP 1: Run
> # dpkg -i --force-overwrite
> /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_i386.deb
>
> this will overwrite the conflicting file and then give unmet
> dependencies error.
>
> STEP 2: Since conflict has already been resolved (forcefully), proceed
> with normal installation
> Run :
> # apt-get -f install
>
> ** Attachment added: "log of issuing the above commands"
> http://launchpadlibrarian.net/9727412/log.txt
>
> --
> package gimp 2.4.0~rc3-1ubuntu4 failed to install/upgrade: trying to
> overwrite `/usr/share/doc/libgimp2.0/README', which is also in package
> libgimp2.0
> https://bugs.launchpad.net/bugs/148985
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

lux (koji-shaw) wrote :

Worked for me (amit_9b's fix)
Please note that you will need to update the deb, to your applicable version (i.e. i386, amd64, etc.)

-- Temporary Fix --

STEP 1: Run
 # dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_<b>i386</b>.deb

this will overwrite the conflicting file and then give unmet dependencies error.

STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
Run :
  # apt-get -f install

LiFeleSs (lifeless85) wrote :

on gutsy for amd64 do:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_amd64.deb

then do:
sudo apt-get upgrade

quazar (stebra1) wrote :

amit_9b's fix is confirmed on gutsy 32bits

rdamji27 (rdamji27) wrote :

Thanks for the fix much appreciated!

Gelke (gbroersma-orange) wrote :

amit_9b's fix worked on gutsy 32bits

Howard (vibs) wrote :

On gusty, amd64

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_amd64.deb
sudo apt-get upgrade

worked, thank you.

alexbevi (alexbevi) wrote :

lux's fix worked for me

Yves Labat (labat-y) wrote :

The fix worked for me too. Thanks.

STEP 1: Run
 # dpkg -i --force-overwrite /var/cache/apt/archives/gimp_2.4.0~rc3-1ubuntu5_i386.deb

this will overwrite the conflicting file and then give unmet dependencies error.

STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
Run :
  # apt-get -f install

Mirzet Kadic (caracal-enl) wrote :

same here

Pedro Villavicencio (pedro) wrote :

There's no need to use the workaround, Matthias already uploaded a new package containing the fix.

Changed in gimp:
importance: Undecided → Medium
Juraj Lukac (hrasko) wrote :

Possible the new packege is not updated on all mirrors yet. I have just experienced this error too.

Jim White (jim-white) wrote :

for users of update manager, the gimp is fixed, but a nearly identical error now exists in cups, and when update manager hits the cups error it quits, so the gimp update doesn't happen. Deselecting the cups update solves that.

Amit Kumar Sharma (amit.9b) wrote :

@Jim White

No Jim, no point cancelling the update for a credits file (correct me if I am wrong),
again for a 32 bit system, use the following command and it will get though (as shown below)

-- Temporary Fix --

STEP 1: Run
 # dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu4_i386.deb

STEP 2: Since conflict has already been resolved (forcefully), proceed with normal installation
Run :
  # apt-get -f install

- Cheers,
Amit Kumar Sharma

jamieR (jamie12) wrote :

confirming its happened to me as well at about 19:00 gmt

UKThom (ukthom) wrote :

I'm not able to run the fix, as the package I have is: /var/cache/apt/archives/cupsys_1.3.2-1ubuntu3_i386.deb

When I did the fix on this file, I got errors regarding other packages:

hraefn@worker-ant:~$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/cupsys_1.3.2-1ubuntu3_i386.deb
(Reading database ... 89348 files and directories currently installed.)
Preparing to replace cupsys 1.3.2-1ubuntu3 (using .../cupsys_1.3.2-1ubuntu3_i386.deb) ...
 * Stopping Common Unix Printing System: cupsd [ OK ]
Unpacking replacement cupsys ...
dpkg: dependency problems prevent configuration of cupsys:
 cupsys depends on libavahi-compat-libdnssd1 (>= 0.6.13); however:
  Package libavahi-compat-libdnssd1 is not configured yet.
dpkg: error processing cupsys (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cupsys

Perhaps I'll just wait a few days and try to update again.

Thanks!

Jim White (jim-white) wrote :

Thanks, Amit. Exactly right, worked like a charm.

Shirish Agarwal (shirishag75) wrote :

concuring with Juraj Lukac, the same issue seems to be here too :(

Shirish Agarwal (shirishag75) wrote :

shirish@Mugglewille:~$ sudo aptitude safe-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages have unmet dependencies:
  gimp-gnomevfs: Depends: gimp (= 2.4.0~rc3-1ubuntu5) but 2.4.0~rc3-1ubuntu4 is installed and it is kept back.
  gimp-helpbrowser: Depends: gimp (= 2.4.0~rc3-1ubuntu5) but 2.4.0~rc3-1ubuntu4 is installed and it is kept back.
  gimp-python: Depends: gimp (= 2.4.0~rc3-1ubuntu5) but 2.4.0~rc3-1ubuntu4 is installed and it is kept back.

using the main mirror , any help would be appreciated. I can't use the workaround as my apt-cache archive is empty.

UKThom (ukthom) wrote :

The workaround I did was to remove cupsys via apt:

$ sudo apt-get remove cupsys

This removes cupsys and it's dependant packages

Then, if you run an update on your package lists:

$ sudo apt-get update

and follow this up with

$ sudo apt-get install

You should have the updated cupsys packages

Alternatively, after removing cupsys with the command line interface, you can use Update Manager to obtain the packages you're missing, including the updated GIMP and loads of other stuff that became updated at 2200 GMT +1 on the UK servers.

Hope this is helpful.

rik (rikkroondijk) wrote :

thank you much !

On 10/5/07, UKThom <email address hidden> wrote:
>
> The workaround I did was to remove cupsys via apt:
>
> $ sudo apt-get remove cupsys
>
> This removes cupsys and it's dependant packages
>
> Then, if you run an update on your package lists:
>
> $ sudo apt-get update
>
> and follow this up with
>
> $ sudo apt-get install
>
> You should have the updated cupsys packages
>
> Alternatively, after removing cupsys with the command line interface,
> you can use Update Manager to obtain the packages you're missing,
> including the updated GIMP and loads of other stuff that became updated
> at 2200 GMT +1 on the UK servers.
>
> Hope this is helpful.
>
> --
> package gimp 2.4.0~rc3-1ubuntu4 failed to install/upgrade: trying to
> overwrite `/usr/share/doc/libgimp2.0/README', which is also in package
> libgimp2.0
> https://bugs.launchpad.net/bugs/148985
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers