[apport] sphere.py crashed with ImportError in <module>()

Bug #145376 reported by oscarin on 2007-09-26
24
Affects Status Importance Assigned to Milestone
cinepaint (Ubuntu)
Medium
Unassigned
Feisty
Undecided
Scott Kitterman
gimp (Ubuntu)
Medium
Unassigned
Feisty
Undecided
Unassigned

Bug Description

Binary package hint: cinepaint

[apport] sphere.py crashed with ImportError in <module>()

ProblemType: Crash
Architecture: i386
Date: Wed Sep 26 16:04:32 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/lib/cinepaint/0.21-2/plug-ins/sphere.py
InterpreterPath: /usr/bin/python2.5
Package: cinepaint 0.21-2-0ubuntu3
PackageArchitecture: i386
ProcCmdline: python /usr/lib/cinepaint/0.21-2/plug-ins/sphere.py -gimp 10 9 -query
ProcCwd: /home/oscar
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/lib/cinepaint/0.21-2/plug-ins/sphere.py', '-gimp', '10', '9', '-query']
SourcePackage: cinepaint
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/cinepaint/0.21-2/plug-ins/sphere.py", line 24, in <module>
     from gimpfu import *
 ImportError: No module named gimpfu
Uname: Linux KUBUNTU 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

oscarin (oscarin-ch) wrote :
Scott Kitterman (kitterman) wrote :

Open a python shell and try:

from gimpfu import *

produces the same error. usr/lib/gimp/2.0/python/gimpfu.py is not in the Python Path.

Changed in cinepaint:
importance: Undecided → High
status: New → Triaged
Scott Kitterman (kitterman) wrote :

Dropping to Medium since cinepaint is the only rdepends in the archive for gimp-python.

Changed in gimp:
importance: High → Medium
Scott Kitterman (kitterman) wrote :

Gimp-python is wrong in this case, but it would be an invasive change late in the development cycle to fix it there. For Gutsy, we'll work around it in cinepaint and fix it properly in Hardy.

Changed in cinepaint:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
Scott Kitterman (kitterman) wrote :

After further investigation, it turns out this is already patched around in the Gutsy cinepaint version.

Changed in cinepaint:
assignee: kitterman → nobody
status: In Progress → Fix Released
assignee: nobody → kitterman
status: New → In Progress
Changed in gimp:
status: New → Won't Fix

Besides, 0.21-2-0ubuntu4.1 in feisty-updates and 0.22-1-0ubuntu1~feisty1 in
feisty-backports also fix this issue for feisty.
Cheers

On Tue, Oct 02, 2007 at 02:56:59AM -0000, Scott Kitterman wrote :
> After further investigation, it turns out this is already patched around
> in the Gutsy cinepaint version.
>
> ** Changed in: cinepaint (Ubuntu)
> Assignee: Scott Kitterman (kitterman) => (unassigned)
> Status: In Progress => Fix Released
>
> ** Changed in: cinepaint (Ubuntu Feisty)
> Assignee: (unassigned) => Scott Kitterman (kitterman)
> Status: New => In Progress
>
> ** Changed in: gimp (Ubuntu Feisty)
> Status: New => Won't Fix
>
> --
> [apport] sphere.py crashed with ImportError in <module>()
> https://bugs.launchpad.net/bugs/145376
> You received this bug notification because you are a bug contact for
> cinepaint in ubuntu.

--
Albin Tonnerre, aka Lutin
 - Search a little longer, travel a little further

Scott Kitterman (kitterman) wrote :

Yes. I agree. ubuntu4.1 has the fix already. For the original reporter, you were using an obsolete version. Check and make sure feisty-updates for universe is enabled. That should solve your problem.

Changed in cinepaint:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

Thanks for the report oscarin , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in gimp (Ubuntu):
status: Triaged → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gimp (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers