Merge gimp 2.8.14-1 (main) from Debian unstable (main)

Bug #1366560 reported by Thomas Hotz on 2014-09-07
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Wishlist
Unassigned

Bug Description

This is a bug-fix update that fixes many bugs.

From the changelog:

Overview of Changes from GIMP 2.8.12 to GIMP 2.8.14
===================================================

General:

 - Fix libtool versioning (forgot to bump gimp_interface_age)

Overview of Changes from GIMP 2.8.10 to GIMP 2.8.12
===================================================

Core:

 - OSX: Fix migration code for old GIMP directories
 - Fix brush sizes when used from plug-ins
 - Windows: Allow to Explorer-open files with UTF-8 characters in the filename
 - Make XCF loading more robust against broken files

GUI:

 - Make sure the widget direction matches the GUI language
 - Remove the option to disable the warning when closing a modified image
 - Fix canvas overlay widgets (like the text options) for tablets
 - Make DND work between images in one dockable

Libgimp:

 - Make gimp_image_get_name() return the string used for the image title

Plug-ins:

 - Make script-fu-server more secure by listening to 127.0.0.1 by
   default and add a warning about changing that IP. This breaks the
   procedure's API, but for security reasons.
 - Bring back proper script-fu translations

General:

 - Massively clean up and fix the OSX build and bundle
 - Add Jenkins tutorial
 - Documentation updates
 - Bug fixes
 - Translation updates

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gimp 2.8.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-13.19-generic 3.16.1
Uname: Linux 3.16.0-13-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
Date: Sun Sep 7 17:29:51 2014
InstallationDate: Installed on 2014-08-07 (31 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140806)
ProcEnviron:
 LANGUAGE=de_AT:de
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: gimp
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: upgrade-software-version
summary: - FFe: Please upgrade GIMP to version 2.8.14
+ Please upgrade GIMP to version 2.8.14
Artur Rona (ari-tczew) wrote :

Since debdiff ubuntu-to-ubuntu is a bit enormous (~ 30 MB), I cut only /debian/ directory and I'm attaching that.

Changed in gimp (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Artur Rona (ari-tczew) on 2014-11-12
summary: - Please upgrade GIMP to version 2.8.14
+ Merge gimp 2.8.14-1 (main) from Debian unstable (main)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.8.14-1ubuntu1

---------------
gimp (2.8.14-1ubuntu1) vivid; urgency=low

  * Merge from Debian unstable. (LP: #1366560) Remaining changes:
    - debian/patches/02_help-message.patch,
      debian/patches/03_gimp.desktop.in.in.patch:
      + Update some strings for Ubuntu.
    - debian/rules:
      + Set gettext domain and update translation templates.
  * Drop following patches, fixed upstream:
    - CVE-2013-1913.patch
    - CVE-2013-1978.patch
    - freetype-251.patch

gimp (2.8.14-1) unstable; urgency=medium

  * Imported Upstream version 2.8.14
    * Fixes segfault when removing tag from palette (Closes: #736625)
  * Bump standards version to 3.9.6

gimp (2.8.10-3) unstable; urgency=low

  * Fix missing backslash in debian/rules (Closes: #743596)

gimp (2.8.10-2) unstable; urgency=low

  * Always build with lcms2 even if lcms1 is present (Closes: #743596)
  * Enable parallel building (Closes: #750654)
  * Add dh-autoreconf (Closes: #746713)

gimp (2.8.10-1) unstable; urgency=low

  * Upgrade to lcms2 (Closes: #743596)
  * Remove helpbrowser plugin; gimp will fall back to an external web
    browser if present (Closes: #639761)

gimp (2.8.10-0.1) unstable; urgency=high

  * Imported Upstream version 2.8.10
  * Build-depend on libtiff-dev instead of libtiff4-dev (Closes: #736006)

  [ Hideki Yamane ]
  * debian/patches
    - add adjust_freetype_header.patch to fix FTBFS (Closes: #732010)
    - add CVE-2013-1913_and_gimp_CVE-2013-1978.patch to fix xwd security
      vulnerabilities CVE-2013-1913 and CVE-2013-1978
      (Closes: #731305)
 -- Artur Rona <email address hidden> Tue, 11 Nov 2014 22:03:15 +0100

Changed in gimp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers