GIMP in 64bit Feisty corrupts PSD files

Bug #132143 reported by fyo on 2007-08-13
4
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Medium
Unassigned
Feisty
Medium
Sebastien Bacher

Bug Description

Binary package hint: gimp

Summary says it all really.

This is a serious data loss bug. Anyone saving their work in Photoshop format (PSD) on 64bit Feisty will LOSE their work. The file written is corrupt and cannot be loaded, but the saving appears to work (even the preview image works), so the bug is only discovered when the user tries to open the file again.

That the user can continue to work on the file exacerbates the problem, since the potential loss of work is much greater than if Gimp simply crashed.

The current Ubuntu-repository version of GIMP, 2.2.13, exhibits the bug. The bug was identified and fixed long ago:

http://bugzilla.gnome.org/show_bug.cgi?id=335130
http://bugzilla.gnome.org/show_bug.cgi?id=384762

From the latter, it appears that 2.2.14+ contains the fix.

Seeing as how Gimp is (the only graphics editor) installed by default, this potentially affects every single Ubuntu user out there.

Changed in gimp:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Looks like the bug should be fixed in gutsy

Changed in gimp:
importance: Undecided → Medium
status: Confirmed → Fix Released
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Subscribing ubuntu-sru, do you think we should do a stable update there?

Martin Pitt (pitti) wrote :

The patch looks plausible and sane, and this falls under "data corruption". Approved for SRU, that would be most welcome.

Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Thanks Seb, looks good. Please go ahead and upload.

Changed in gimp:
assignee: nobody → seb128
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

I've uploaded it already

Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please go ahead with testing. Thank you!

Changed in gimp:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

fyo, ping: can you please test the provided version in -proposed and give feedback here? thanks!

Brian Murray (brian-murray) wrote :

Using gimp version 2.2.13-1ubuntu4.3 I was able to reproduce the bug. After I installed the version 2.2.13-1ubuntu4.4 in -proposed I was able to save non-corrupt PSD files.

Martin Pitt (pitti) wrote :

Copied to -updates.

Changed in gimp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers