Gimp Memory Usage is high when many gradients and brushes are imported

Bug #1196655 reported by Devyn Collier Johnson on 2013-07-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Gimp
Confirmed
High
gimp (Ubuntu)
Undecided
Unassigned

Bug Description

collier@Nacho-Laptop:~$ lpbug gimp
Description: Ubuntu 13.04
Release: 13.04
gimp:
  Installed: 2.8.6~raring~NoobsLab.com
  Candidate: 2.8.6~raring~NoobsLab.com
  Version table:
 *** 2.8.6~raring~NoobsLab.com 0
        500 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     2.8.4-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
unity 7.0.0
Compiz 0.9.9.0
metacity 2.34.13
Mutter is not installed

I downloaded a few hunded gradients and I placed them in the gradient folder and many brushes in the brush folder. I do not always use gradients or brushes, but they load up anyway when Gimp starts. Is there a way to design Gimp to make only place them on RAM when they are in use? It seems like Gimp is starting to develop a memory issue.

summary: - [IDEA]Gimp Memory Usage is high when many gradients and brushes are
+ [IDEA] Gimp Memory Usage is high when many gradients and brushes are
imported

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed

Thank you for your bug report! I have reported it upstream as enhancement.

Changed in gimp:
importance: Unknown → Wishlist
status: Unknown → New
Changed in gimp:
status: New → Invalid
Changed in gimp:
importance: Wishlist → Unknown
status: Invalid → Unknown
summary: - [IDEA] Gimp Memory Usage is high when many gradients and brushes are
- imported
+ Gimp Memory Usage is high when many gradients and brushes are imported
Changed in gimp:
importance: Unknown → Critical
status: Unknown → Confirmed
Changed in gimp:
importance: Critical → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.