No support for German language gimp kubuntu 12.04 LTS

Bug #1101402 reported by Mirco Helg
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Invalid
Undecided
Unassigned
gimp (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

No support for German language gimp kubuntu 12.04 LTS

I have installed the German language pack and it is still in English.
I have reinstalled and gimp is in German.
Later I installed Kubuntu 12.04 LTS and it is back in English even though I have installed all of the language packs.

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gimp 2.6.12-1ubuntu1.2
ProcVersionSignature: Ubuntu 3.2.0-36.57-generic 3.2.35
Uname: Linux 3.2.0-36-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Fri Jan 18 22:04:29 2013
ExecutablePath: /usr/bin/gimp-2.6
InstallationMedia: Kubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120820.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=de_CH
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: gimp
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors: (process:3563): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Revision history for this message
Mirco Helg (mircohelg) wrote :
Debra Virden (teddydlv)
description: updated
description: updated
tags: added: saucy
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

I can confirm this bug on Kubuntu saucy 13.10. I installed GIMP and installed full German language support. GIMP version 2.8.4 is in English, the help is in German.

Thank you for reporting this bug!

Changed in gimp (Ubuntu):
status: New → Confirmed
Changed in gimp (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
no longer affects: gimp
Changed in ubuntu-translations:
status: New → Triaged
Revision history for this message
Cyril Chaboisseau (cyril-chaboisseau) wrote :

I confirm that the gimp package in Ubuntu doesn't ship with *ANY* localisation (it's not only a problem with German translations) while the Debian package has it

as a consequence, in Debian there are several files in /usr/share/locale/fr/LC_MESSAGES :
ls -l /usr/share/locale/fr/LC_MESSAGES/gimp20*
-rw-r--r-- 1 root root 31857 oct. 16 16:00 /usr/share/locale/fr/LC_MESSAGES/gimp20-libgimp.mo
-rw-r--r-- 1 root root 288394 sept. 21 03:28 /usr/share/locale/fr/LC_MESSAGES/gimp20.mo
-rw-r--r-- 1 root root 5915 sept. 21 03:28 /usr/share/locale/fr/LC_MESSAGES/gimp20-python.mo
-rw-r--r-- 1 root root 45770 sept. 21 03:28 /usr/share/locale/fr/LC_MESSAGES/gimp20-script-fu.mo
-rw-r--r-- 1 root root 212059 sept. 21 03:28 /usr/share/locale/fr/LC_MESSAGES/gimp20-std-plug-ins.mo
-rw-r--r-- 1 root root 13902 sept. 21 03:28 /usr/share/locale/fr/LC_MESSAGES/gimp20-tips.mo

and this is not the case in Ubuntu

comparing both packaging (the debian/rules file), in Ubuntu there is a "cleaning" in the common-install-impl:: part (lines 43-49) that seem to delete all the GETTEXT_PACKAGE

conclusion: either Ubuntu should not delete the l10n files, or create some sub-package for each languages
(gimp-l10-de gimp-l10-fr, etc.)

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

There are already subpackages; in Ubuntu the GIMP translations are shipped in the language-pack-gnome-XX-base packages.

On my 14.10:

$ ls -1 /usr/share/locale-langpack/de/LC_MESSAGES/gimp*
/usr/share/locale-langpack/de/LC_MESSAGES/gimp20-libgimp.mo
/usr/share/locale-langpack/de/LC_MESSAGES/gimp20.mo
/usr/share/locale-langpack/de/LC_MESSAGES/gimp20-script-fu.mo
/usr/share/locale-langpack/de/LC_MESSAGES/gimp20-std-plug-ins.mo

So currently there is no bug.

I don't know if there was a bug previously, or if this bug report was based on a misconception all from the start. Doesn't matter much now, I think.

Closing.

Changed in gimp (Ubuntu):
status: Triaged → Invalid
Changed in ubuntu-translations:
status: Triaged → Invalid
Revision history for this message
Cyril Chaboisseau (cyril-chaboisseau) wrote :

that's right, since I'm using Kubuntu (KDE), I (wrongly) assumed that I didn't have to install gnome package but I forgot that Gimp is using gtk libraries

and indeed, after installing language-pack-gnome-fr it works!

as a side note, it is interesting to see the different approaches between Debian who chooses to install all language within each package, and Ubuntu who prefer to have all localisations/translation for all packages but on only the desired languages

thanks

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers