Gimp crashes editing a text label

Bug #1071332 reported by Angel Guzman Maeso on 2012-10-25
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Undecided
Unassigned

Bug Description

I have a crash editing a text label. On terminal I can see:

(gimp-2.8:15536): Gimp-File-CRITICAL **: file_open_image: assertion `progress == NULL || GIMP_IS_PROGRESS (progress)' failed

(gimp-2.8:15536): Gimp-Display-CRITICAL **: render_image_tile_fault: assertion `tile[4] != NULL' failed

(gimp-2.8:15536): Gimp-Display-CRITICAL **: render_image_tile_fault: assertion `tile[4] != NULL' failed

(gimp-2.8:15536): Gimp-Display-CRITICAL **: render_image_tile_fault: assertion `tile[4] != NULL' failed

(gimp-2.8:15536): Gimp-Display-CRITICAL **: render_image_tile_fault: assertion `tile[4] != NULL' failed

(script-fu:15550): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gimp 2.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
Date: Thu Oct 25 16:17:47 2012
InstallationDate: Installed on 2012-02-09 (258 days ago)
InstallationMedia:

MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: gimp
UpgradeStatus: Upgraded to quantal on 2012-06-05 (142 days ago)

Angel Guzman Maeso (shakaran) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
Mona Eberhardt (slutrix) wrote :

I get the same on two machines, one with Ubuntu 12.10 Qantal Qetzal and another with Linux Mint 14 MATE. It's simply impossible to enter text in Gimp 2.8.2. When you try to select a font, the application will immediately crash.

IanG (ian-usts) wrote :

In Ubuntu 12.04, I don't quite get the crash, but the text-editor is buggy. You choose a font, it keeps sans and you have to assign the font again. After copying a text layer (pretty fundamental to any text effect operation), it moves the topmost layer on editing.

Really frustrating.

Will go back to 2.6 and hence why official repositories have kept it there

demch (demch-kwmyf) wrote :

In Ubuntu 14.10 I have to delete ~ /.gimp-2.8 directory, then all seems to work.
Consider making first a backup of your .gimp-2.8 directory.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers