Update GIMP to version 2.8.2

Bug #1050831 reported by Thomas Hotz on 2012-09-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Wishlist
Unassigned

Bug Description

From the release notes:

Overview of Changes from GIMP 2.8.0 to GIMP 2.8.2
=================================================

Core:

 - Make tag matching always case-insensitive
 - Let the tile-cache-size default to half the physical memory

GUI:

 - Mention that the image was exported in the close warning dialog
 - Make sure popup windows appear on top on OSX
 - Allow file opening by dropping to the OSX dock
 - Fix the visibility logic of the export/overwrite menu items
 - Remove all "Use GEGL" menu items, they only add bugs and zero function
 - Improve performance of display filters, especially color management
 - Fix the image window title to comply with the save/export spec
   and use the same image name everywhere, not only in the title
 - Fix positioning of pasted/dropped stuff to be more reasonable

Libgimp:

 - Move gimpdir and thumbnails to proper locations on OSX
 - Implement relocation on OSX
 - Allow to use $(gimp_installation_dir) in config files

Plug-ins:

 - Fix remembering of JPEG load/save defaults
 - Revive the page setup dialog on Windows

Source and build system:

 - Add Windows installer infrastructure
 - Add infrastructure to build GIMP.app on OSX

General:

 - Lots of bug fixes
 - List of translation updates

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gimp 2.8.0-2ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Fri Sep 14 11:20:50 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120913.1)
ProcEnviron:
 LANGUAGE=de_AT:de
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: gimp
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2012-09-15
tags: added: upgrade-software-version
Changed in gimp (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.8.2-1ubuntu1

---------------
gimp (2.8.2-1ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #1050831). Remaining Ubuntu changes:
  * debian/control:
    - Update description
    - Build-depend on libtiff-dev instead of libtiff4-dev.
  * debian/rules:
    - Set gettext domain and update translation templates
  * debian/patches/02_help-message.patch:
  * debian/patches/03_gimp.desktop.in.in.patch:
    - Update some strings for Ubuntu
 -- Robert Ancell <email address hidden> Wed, 19 Sep 2012 17:16:47 +1200

Changed in gimp (Ubuntu):
status: Triaged → Fix Released

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers