Fonts replaced by garbage when printing certain PDFs

Bug #891074 reported by karaluh on 2011-11-16
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
Medium
ghostscript (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

As in summary. See atached test case and printout.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ghostscript 9.04~dfsg-0ubuntu11.1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Nov 16 11:15:01 2011
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
Papersize: a4
ProcEnviron:
 LANGUAGE=pl_PL:pl:en_GB:en
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=d6d9b55b-2a61-4793-a5ba-982b43f9a7f4 ro quiet splash vt.handoff=7
SourcePackage: ghostscript
UpgradeStatus: Upgraded to oneiric on 2011-10-18 (28 days ago)
dmi.bios.date: 06/11/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1002.002
dmi.board.name: P4P800-MX
dmi.board.vendor: ASUSTek Computer Inc.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1002.002:bd06/11/2004:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASUSTekComputerInc.:rnP4P800-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

karaluh (karaluh) wrote :
karaluh (karaluh) wrote :

CUPS error log

karaluh (karaluh) wrote :

Captured print job data

karaluh (karaluh) wrote :

Test case

karaluh (karaluh) wrote :

Scan of the incorrect printout

Till Kamppeter (till-kamppeter) wrote :

Your captured print job data is PostScript and not PDF and as evince emits print jobs in PDF format I am wondering with which program you are printing (If I print with evince, the job comes out correctly). Can you please tell which program (and which options) you have used?

What CUPS does with your print job is to turn it to PDF with Ghostscript then do page management (support for options like N-up, or printing only selected pages) with the pdftopdf filter and afterwards converting it back to PostScript, again with Ghostscript. I can reproduce it by running tyhe two Ghostscript steps separately:

ps2pdf d00043-001
pdf2ps d00043-001.pdf

The file d00043-001.pdf looks OK when displaying on the screen with evince or Ghostscript. The file d00043-001.ps resulting of the second command looks like your broken printout.

So the problem seems to be in Ghostscript, but one can work around it when printing from evince.

Changed in ghostscript (Ubuntu):
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

Reported to Ghostscript upstream as http://bugs.ghostscript.com/show_bug.cgi?id=692687.

karaluh (karaluh) wrote :

Sorry, I've forgoten to add the info. The file was printed in Okular, only default options were used.

Till Kamppeter (till-kamppeter) wrote :

Thanks, Okular has also a bug, it sends the print jobs in PostScript format. This I have reported now as bug 891199.

Changed in ghostscript (Ubuntu):
importance: Undecided → Medium
milestone: none → oneiric-updates
status: Incomplete → Triaged

Bug got fixed upstream and the upstream patch worked. I will provide an SRU soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-2ubuntu3

---------------
ghostscript (9.04~dfsg-2ubuntu3) precise; urgency=low

  * debian/patches/020111122-cd8f397-ps2write-fix-handling-of-format-4-cmap-subtables-in-truetype-fonts.patch:
    ps2write: Fixed handling of format 4 CMAP subtables in TrueType fonte. This
    made several characters coming out as garbage when converting PDF to
    PostScript (LP: #891074).
  * debian/patches/020111122-5cce070-ps2write-postscript-duplex-command-insertion.patch:
    ps2write: Insertion of duplex printing commands from PPD files into
    ps2write-generated PostScript did not have any effect, making duplex
    printing on PostScript printers not work in many cases (LP: #885118).
 -- Till Kamppeter <email address hidden> Tue, 22 Nov 2011 10:46:59 +0100

Changed in ghostscript (Ubuntu):
status: Triaged → Fix Released

Uploaded a fixed Ghostscript package for Oneiric (fixing this bug and bug 885118) to -proposed. As soon as the upload gets approved you will be asked for testing the package by a separate comment. Please test the package then as otherwise it will not make it into the updates for everyone. debdiff of the changes is attached.

Changed in ghostscript (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Medium
milestone: none → oneiric-updates
Changed in ghostscript (Ubuntu):
milestone: oneiric-updates → none

Hello karaluh, or anyone else affected,

Accepted ghostscript into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

The reporter of the duplicate bug 893646 tells that the proposed package solved the problem.

tags: added: verification-done
removed: verification-needed
karaluh (karaluh) wrote :

Works also for me, excellent job. I wish all bugs were handled your way.

Changed in gs-gpl:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-0ubuntu11.2

---------------
ghostscript (9.04~dfsg-0ubuntu11.2) oneiric-proposed; urgency=low

  * debian/patches/020111122-cd8f397-ps2write-fix-handling-of-format-4-cmap-subtables-in-truetype-fonts.patch:
    ps2write: Fixed handling of format 4 CMAP subtables in TrueType fonte. This
    made several characters coming out as garbage when converting PDF to
    PostScript (LP: #891074).
  * debian/patches/020111122-5cce070-ps2write-postscript-duplex-command-insertion.patch:
    ps2write: Insertion of duplex printing commands from PPD files into
    ps2write-generated PostScript did not have any effect, making duplex
    printing on PostScript printers not work in many cases (LP: #885118).
 -- Till Kamppeter <email address hidden> Tue, 22 Nov 2011 12:03:59 +0100

Changed in ghostscript (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.