Ubuntu

Some characters missing on printed document (.odt .doc)

Reported by Gio51 on 2011-10-22
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
Medium
foomatic-filters (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
ghostscript (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

after advancing from 10.04 to 10.10 I've trouble with printing document. I try .pdf and .xls and was OK. I try .odt and .doc and in printout document I see that some character are missing. I follow the procedure of Problem Resolution (from the help menu) and produce the "troubleshoot.txt" file (see attached). I will also attach the printout.
Thanks

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cups 1.5.0-8ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Oct 22 17:43:50 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Lpstat:
 device for HP-LaserJet-1022: smb://CASAMASSARO/W7CASA/HP_LaserJet_1022
 device for HP-Officejet-5600: smb://CASAMASSARO/W7CASA/HP_Officejet_5600_series
MachineType: Hewlett-Packard HP Pavilion dv5 Notebook PC
Papersize: a4
PpdFiles:
 HP-Officejet-5600: HP Officejet 5600 Series, hpcups 3.11.1
 HP-LaserJet-1022: HP LaserJet 1022 Foomatic/foo2zjs-z1 (recommended)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=619085c6-9a0e-48ca-b961-e5b79b2d5748 ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (7 days ago)
dmi.bios.date: 08/20/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.21
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3603
dmi.board.vendor: Quanta
dmi.board.version: 02.26
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.21:bd08/20/2009:svnHewlett-Packard:pnHPPaviliondv5NotebookPC:pvrRev1:rvnQuanta:rn3603:rvr02.26:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv5 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
mtime.conffile..etc.cups.cupsd.conf: 2011-10-22T17:26:35.668553

Gio51 (giovanni-massaro) wrote :
Gio51 (giovanni-massaro) wrote :
Till Kamppeter (till-kamppeter) wrote :

Can you follow the instructions of the sections "CUPS error_log" and "Capturing print job data" in https://wiki.ubuntu.com/DebuggingPrintingProblems for a bad print job? Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete
Gio51 (giovanni-massaro) wrote :

This is the error log

Gio51 (giovanni-massaro) wrote :

This is the original file

Gio51 (giovanni-massaro) wrote :

This is the captured print job data that is PDF format

Gio51 (giovanni-massaro) wrote :

This is the scanned printout

Till Kamppeter (till-kamppeter) wrote :

I have checked your attached "printout" file and the filter path according to your error_log and found out where the problem is. Ghostscript is not able to turn your input file into PostScript.

You can easily reproduce the bug by the following command:

pdf2ps printout printout.ps

If you display printout.ps you also see the missing characters.

This is an upstream bug of Ghostscript, similar to bug 879365, perhaps this bug is even the same problem.

affects: cups (Ubuntu) → ghostscript (Ubuntu)
Changed in ghostscript (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Reported bug to Ghostscript upstream as http://bugs.ghostscript.com/show_bug.cgi?id=692626.

summary: - some character missing on printout document(.odt .doc)
+ Some characters missing on printed document (.odt .doc)
Changed in gs-gpl:
importance: Unknown → Medium
status: Unknown → Confirmed
Age Jan Kuperus (ajk-tt) wrote :

bug 886571, now marked as duplicate of this bug, was solved for me by the foomatic-filters downgrade suggested in bug 879365 (mentioned in till's comment #8)

karaluh (karaluh) wrote :

Downgrading foomatic-filters workarounds the bug also for me.

How to

Downgrading foomatic-filters

??
Pls Help me

*****Giovanni Massaro**
*

www.openideas.it <http://www.openideas.it>

Tel. +39 0261866336
Cell..+39 3358101495
*E-Mail*: <email address hidden>
<mailto:<email address hidden>>

Questo QRCode contiene la vCard, per memorizzarla bisogna utilizzare il
lettore di codici presente su qualsiasi cellulare dotato di fotocamera.
Qualora il software non fosse presente sul proprio cellulare è possibile
scaricarlo, gratuitamente, da i-nigma
<http://www.i-nigma.com/Downloadi-nigmaReader.html>

Il 10/11/2011 09:12, karaluh ha scritto:
> Downgrading foomatic-filters workarounds the bug also for me.
>

Age Jan Kuperus (ajk-tt) wrote :

@Gio51: please read comment #39 on bug 879365

Gio51 (giovanni-massaro) wrote :

OK solved using your suggestion
"please read comment #39 on bug 879365".
Many thanks

I got a fix from Ghostscript upstream now, I will apply it to Precise and also as an SRU for Oneiric.

Changed in ghostscript (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-2ubuntu2

---------------
ghostscript (9.04~dfsg-2ubuntu2) precise; urgency=low

  * debian/patches/020111114-4258227-lzw-encode-filter-fix.patch: In the LZW
    encoder filter increment the code size before writing out EOD when the
    last code reaches the current limit code. Fix incorrect bytes or decoding
    errors at the end of some LZW-encoded streams. Fixes problems of
    ps2write producing PostScript output with spurious extra bytes
    (LP: #890270, upstream bug #692679).
  * debian/patches/029111114-08dc129-ps2write-truetype-fix.patch: Improved
    the TrueType composite glyph handling of the "ps2write" output device.
    This way PDF output of LibreOffice gets correctly converted to PostScript
    for PostScript printers and PostScript-based drivers (LP: #879977, upstream
    bug #879977).
 -- Till Kamppeter <email address hidden> Mon, 14 Nov 2011 12:59:59 +0100

Changed in ghostscript (Ubuntu):
status: In Progress → Fix Released

I have uploaded a fixed Ghostscript package for Oneiric into-proposed which fixes this bug and bug 890270). As soon as it gets approved and available for download, this will get announced by another comment here. Please install adn test the new package then and make sutre that before testing you update foomatic-filters again to the version which ships with Oneiric, for the case you have downgraded to work around this bug.

A debdiff of the changes is attached.

Changed in ghostscript (Ubuntu Oneiric):
milestone: none → oneiric-updates
importance: Undecided → Medium
status: New → Fix Committed

Hello Gio51, or anyone else affected,

Accepted ghostscript into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
karaluh (karaluh) wrote :

Fixed for me.

karaluh, thank you for testing, marking SRU as verified.

tags: added: verification-done
removed: verification-needed
karaluh (karaluh) wrote :

We might be to hasty closing this bug. Attached is the printout generated using ghostscript from proposed and updated foomatic-filters. Again, downgrading the filters workarounds the issue.

karaluh, this looks very similar but is probably a different bug, as the file of the original poster (and probably another file from you) comes out correctly now. Therefore we will close this bug and for your bug it is no problem for us to issue another update as soon as we have a fix. To get the fix as quickly as possible, please report a new bug for the ghostscript package and attch the original file which you have tried to print and also the file which you have attached to this bug. Tell also how you have printed the original file (which application, which options). Can you also follow the instructions of the sections "CUPS error_log" and "Capturing print job data" in https://wiki.ubuntu.com/DebuggingPrintingProblems for this print job and attach the files to the new bug report? Thanks.

I have checked and bug 891074 is NOT a regression caused by this SRU. It occurs also without the SRU. So the SRU can get passed to -updates and bug 891074 can be handled with a separate SRU.

Also the reporter of the duplicate bug 891140 tells that the proposed fix solves the problem for him.

Age Jan Kuperus (ajk-tt) wrote :

I can confirm that the proposed fix solves the problem for me. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-0ubuntu11.1

---------------
ghostscript (9.04~dfsg-0ubuntu11.1) oneiric-proposed; urgency=low

  * debian/patches/020111114-4258227-lzw-encode-filter-fix.patch: In the LZW
    encoder filter increment the code size before writing out EOD when the
    last code reaches the current limit code. Fix incorrect bytes or decoding
    errors at the end of some LZW-encoded streams. Fixes problems of
    ps2write producing PostScript output with spurious extra bytes
    (LP: #890270, upstream bug #692679).
  * debian/patches/029111114-08dc129-ps2write-truetype-fix.patch: Improved
    the TrueType composite glyph handling of the "ps2write" output device.
    This way PDF output of LibreOffice gets correctly converted to PostScript
    for PostScript printers and PostScript-based drivers (LP: #879977, upstream
    bug #879977).
 -- Till Kamppeter <email address hidden> Mon, 14 Nov 2011 17:27:59 +0100

Changed in ghostscript (Ubuntu Oneiric):
status: Fix Committed → Fix Released
LStranger (andrej-rep) wrote :

Works for me now. Thank you.

Gio51 (giovanni-massaro) wrote :

Sorry but I'm not so technician to understand what to do.
According to my comment #14 I've solved the problem.
Now you say, in your comment #17 i must come back to previous situation applying the debdiff (how to do that?)
because I usually install the proposed I suppose that my system will be automatically updated!
Pls let me know what to do and in which way?
Thanks

Gio51, now the fix made it into the official updates. Simply do the usual system update (with update-manager) and you get the fixed package automatically.

Changed in gs-gpl:
status: Confirmed → Fix Released
LStranger (andrej-rep) wrote :

Unfortunately bug is more rare but still there. Look at attachment - it's printed well with foomatic-filters 4.0.7-0ubuntu1.1 but does not with foomatic-filters 4.0.9-1ubuntu2 - some characters are replaced with random (in my case it was 'к' replaced with 'а' when printed).

LStranger (andrej-rep) wrote :

Ah, forgot to mention - all ghostscript* packages are 9.04~dfsg-0ubuntu11.1. Haven't tried last update 9.04~dfsg-0ubuntu11.2 yet, will try and report.

LStranger (andrej-rep) wrote :

Upgraded ghostscript* to 9.04~dfsg-0ubuntu11.2 and still no luck with foomatic-filters 4.0.9-1ubuntu2 (as no updates for it were found). Downgraded to foomatic-filters 4.0.7-0ubuntu1.1 and hope you'll fix it at last sometime.

affects: gs-gpl → foomatic-filters
affects: foomatic-filters → gs-gpl

LStranger, as your problem is not covered by the fix for this bug (I can also reproduce it) I have opened a new bug: bug 898532.

LStranger (andrej-rep) wrote :

OK. Thank you!

We will not revert the change on foomatic-filters but fix the real cause of the bug in Ghostscript upstream.

Changed in foomatic-filters (Ubuntu):
status: New → Won't Fix
Changed in foomatic-filters (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.