background printed instead of the text

Bug #864509 reported by dino99 on 2011-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
High
ghostscript (Ubuntu)
High
Unassigned

Bug Description

Oneiric i386 b2

wanted to print a page (without background color: only text on white page) from the net and get a full page background printed in black and no text visible. Then i first ptint the same page into a pascript (.ps) file, and finally try to print this file: and the result is as expected via this ps file. Sadly Oneiric System Settings Printer dont give printing options, that heavily missing.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: hplip-cups 3.11.7-1ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sun Oct 2 10:26:51 2011
Lpstat: device for Photosmart-C4500-series: hp:/usb/Photosmart_C4500_series?serial=CN87JD4109057K
MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
Papersize: a4
PpdFiles: Photosmart-C4500-series: HP Photosmart c4500 Series, hpcups 3.11.7
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic-pae root=UUID=9e61e83e-bca9-43cf-aa90-5a68892213fa ro vga=791 splash quiet crashkernel=384M-2G:64M,2G-:128M acpi_osi=Linux
SourcePackage: hplip
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/22/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5W DH Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3001:bd10/22/2009:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5W DH Deluxe
dmi.product.version: System Version
dmi.sys.vendor: ASUSTEK COMPUTER INC

dino99 (9d9) wrote :
Till Kamppeter (till-kamppeter) wrote :

Which browser did you use? Which web site did you visit? Can you post the URL here? Can you follow the instructions of the sections "CUPS error_log" and "Capturing print job data" for such a broken job? Can you "Print to File" and choose PDF as output format? Try to display the PDF file with evince and try to print it, does this work?

Till Kamppeter (till-kamppeter) wrote :

Sorry, I meant, Can you follow the instructions of the sections "CUPS error_log" and "Capturing print job data" of https://wiki.ubuntu.com/DebuggingPrintingProblems#preview for such a broken job?

Changed in hplip (Ubuntu):
status: New → Incomplete
dino99 (9d9) wrote :

browser used: Firefox 7.0.1+build1 (genuine oneiric)
url: http://www.ednes.com/gaz/index.php?option=com_content&task=view&id=29&Itemid=47

/var/log/cups/error_log:
E [03/Oct/2011:08:55:17 +0200] Filter "hpgltops" not found.
E [03/Oct/2011:08:55:17 +0200] Filter "pstoraster" not found.
W [03/Oct/2011:08:55:17 +0200] failed to AddProfile: org.freedesktop.ColorManager.Failed:profile object path '/org/freedesktop/ColorManager/profiles/Photosmart_C4500_series_Gray__' has already been added
W [03/Oct/2011:08:55:17 +0200] failed to AddProfile: org.freedesktop.ColorManager.Failed:profile object path '/org/freedesktop/ColorManager/profiles/Photosmart_C4500_series_RGB__' has already been added

other errors already joined: CupsErrorLog.txt

Changed in hplip (Ubuntu):
status: Incomplete → New
Till Kamppeter (till-kamppeter) wrote :

Thank you very much for the URL.

dino99, for me the page prints perfectly on a completely updated Oneiric 64 bit if I use "File"/"Print" and not the small printer icon on the page. So use this as a workaround.

If I use the printer icon and click it again in the preview which pops up, I can reproduce the problem on my HP OfficeJet Pro 8500 A+ (which uses the same driver as yours). The problem is Ghostscript erroring out on the print data. Moving to Ghostscript ...

Changed in hplip (Ubuntu):
status: New → Confirmed
affects: hplip (Ubuntu) → ghostscript (Ubuntu)
Changed in ghostscript (Ubuntu):
importance: Undecided → High
milestone: none → oneiric-updates
dino99 (9d9) wrote :

Thanks Till,
confirm that i got that issue via the printer icon on the page, but have not tested the print file menu

Changed in gs-gpl:
importance: Unknown → High
status: Unknown → Confirmed
Till Kamppeter (till-kamppeter) wrote :

Another possible workaround is to let CUPS allow more memory to be used by Ghostscript. Run the command

cupsctl RIPCache=1024m

and your job should print.

Note that you should have at least 4G of RAM to try this.

Changed in ghostscript (Ubuntu):
status: Confirmed → In Progress
Till Kamppeter (till-kamppeter) wrote :

The upstream developers have fixed the problem in GIT revision d5f1e72 and I have tested the patch in the Ubuntu package and it actually works.

Changed in ghostscript (Ubuntu):
status: In Progress → Fix Committed
milestone: oneiric-updates → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.04~dfsg-0ubuntu11

---------------
ghostscript (9.04~dfsg-0ubuntu11) oneiric; urgency=low

  * debian/patches/020111005-d5f1e72-clist-fix-for-rgbw-color-mode.patch:
    Fixed color handling in clist (banding) mode to correctly support RGBW
    color space (LP: #864509, Upstream bug 692568).
 -- Till Kamppeter <email address hidden> Thu, 6 Oct 2011 09:00:00 +0200

Changed in ghostscript (Ubuntu):
status: Fix Committed → Fix Released
Changed in gs-gpl:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.