PostScript produced with particular eps file when using graphicx-psmin gives error in ghostscript

Bug #306125 reported by J. Scott Berg on 2008-12-08
6
Affects Status Importance Assigned to Milestone
ghostscript (Ubuntu)
Undecided
Till Kamppeter
Intrepid
Undecided
Unassigned

Bug Description

graphicx-psmin is a latex package for reducing file sizes when you have a repetitive graphic appearing on every page. However, with intrepid, running ghostscript on the postscript produced with dvips from a document including a particular eps file (attached) produces an error:

Error: /undefined in --.execform1--
Operand stack:
   --nostringval--
Execution stack:
   %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1905 1 3 %oparray_pop 1904 1 3 %oparray_pop 1888 1 3 %oparray_pop 1771 1 3 %oparray_pop --nostringval-- %errorexec_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- 1853 2 5 %oparray_pop --nostringval-- false 1 %stopped_push 1852 2 5 %oparray_pop --nostringval--
Dictionary stack:
   --dict:1151/1684(ro)(G)-- --dict:0/20(G)-- --dict:81/200(L)-- --dict:101/300(L)-- --dict:44/200(L)-- --dict:3/53(L)-- --dict:26/41(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 132706
GPL Ghostscript 8.63: Unrecoverable error, exit code 1

It seems to be fine with other eps files, so you might think to blame this eps file, except I've been using this eps file with latex (with and without graphicx-psmin, and Microsoft products as well) for at least three years now, without incident. I would blame ghostscript except that I found one other report with a similar symptom that blamed the postscript producer for the problem. No problem with a straight includegraphics, the problem only arises when using graphicx-psmin.

Package versions:
Ubuntu 8.10
texlive-latex-extra: 2007.dfsg.2-1ubuntu1
texlive-base-bin: 2007.dfsg.2-3ubuntu1
ghostsciprt: 8.63.dfsg.1-0ubuntu6

Related branches

J. Scott Berg (jsberg) wrote :
J. Scott Berg (jsberg) wrote :

Command line is

latex 081207.ltx && dvips -j0 081207

J. Scott Berg (jsberg) wrote :

On Mon, 08 Dec 2008, J. Scott Berg wrote:
> latex 081207.ltx && dvips -j0 081207

Not reproducible. Are you sure? I guess that is a gs bug, here on
Debian/sid with gs 8.62 it works.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
UTTOXETER (n.)
A small but immensely complex mechanical device which is essentially
the 'brain' of a modern coffee vending machine, and which enables the
machine to take its own decisions.
   --- Douglas Adams, The Meaning of Liff

J. Scott Berg (jsberg) wrote :

I had no problems under hardy (looks like it used gs 8.61), it's intrepid (gs 8.63) that is giving me trouble. I'm assuming you tested the attached postscript ("Postscript produced by dvips") directly with ghostscript (as opposed to running the LaTeX example).

J. Scott Berg (jsberg) wrote :

Built and tried upstream ghostscript 8.62 and 8.63. No problem with the postscript file using 8.62, crashes in the same way with 8.63. I guess I'll convert it to a ghostscript bug, though I suppose it is possible that ghostscript just got fussier about invalid PostScript...

Norbert Preining (preining) wrote :

On Mon, 08 Dec 2008, J. Scott Berg wrote:
> intrepid (gs 8.63) that is giving me trouble. I'm assuming you tested
> the attached postscript ("Postscript produced by dvips") directly with
> ghostscript (as opposed to running the LaTeX example).

That should be irrelevant since the eps didn't change.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
HOFF (vb.)
To deny indignantly something which is palpably true.
   --- Douglas Adams, The Meaning of Liff

This problem is caused by a bug in reusable stream implementation.
The bug has been fixed in the current development version. See Ghostscript bug tracker for details.
http://bugs.ghostscript.com/show_bug.cgi?id=690090

J. Scott Berg (jsberg) wrote :

The patch in ghostscript bug fixes the problem.

Changed in ghostscript:
assignee: nobody → till-kamppeter
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 8.63.dfsg.1-0ubuntu13

---------------
ghostscript (8.63.dfsg.1-0ubuntu13) jaunty; urgency=low

  * debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
    Certain files lead to a Ghostscript error due to wrong handling of the
    stream buffer (LP: #306125, upstream bug #690090).

  * debian/patches/67_too-big-temp-files-2.dpatch: Complete fix for the too big
    temporary files. Now the bug is completely fixed. Temp files are not much
    bigger than the jobs themselves now (LP: #288570, upstream bug #690133).

 -- Till Kamppeter <email address hidden> Sun, 14 Dec 2008 15:37:45 +0100

Changed in ghostscript:
status: New → Fix Released
Martin Pitt (pitti) wrote :
Changed in ghostscript:
status: New → Confirmed
Changed in ghostscript:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

J. Scott Berg (jsberg) wrote :

Installed 8.63.dfsg.1-0ubuntu6.1 into intrepid, works fine now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 8.63.dfsg.1-0ubuntu6.1

---------------
ghostscript (8.63.dfsg.1-0ubuntu6.1) intrepid-proposed; urgency=low

  * debian/patches/70_take-into-account-data-in-stream-buffer-before-refill.dpatch:
    Certain files lead to a Ghostscript error due to wrong handling of the
    stream buffer (LP: #306125, upstream bug #690090).

  * debian/patches/65_too-big-temp-files-1.dpatch,
    debian/patches/67_too-big-temp-files-2.dpatch: Ghostscript produced much too
    big temporary files (> 10 GB) when printing photos from GNOME apps in
    1200 dpi (LP: #288570, upstream bug #690133).

  * debian/patches/62_onebitcmyk-pdf.dpatch: Check the whole Decode array to
    detect special cases of identity and inverse decoding in PDF files
    (Upstream bug #690178).

  * debian/patches/50_lips4-floating-point-exception: Fixed floating-point
    exception in "lips4" and other drivers (Upstream bug #690122).

 -- Till Kamppeter <email address hidden> Mon, 15 Dec 2008 09:01:22 +0100

Changed in ghostscript:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.