libgs9-common not upgraded when libgs9 upgraded

Bug #1802958 reported by Ioanna Alifieraki on 2018-11-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ghostscript (Ubuntu)
Medium
Ioanna Alifieraki
Trusty
Medium
Ioanna Alifieraki
Xenial
Medium
Ioanna Alifieraki

Bug Description

[Impact]

ps2pdf stops working after upgrade of ghostscript to 9.25~dfsg+1-0ubuntu0.14.04.2 .
ghostscript and libgs9 are upgrated to 9.25~dfsg+1-0ubuntu0.14.04.2,
but not libgs9-common which reamins at 9.25~dfsg+1-0ubuntu0.14.04.1 version.

[Test Case]

To reproduce the bug:
Install 9.25~dfsg+1-0ubuntu0.14.04.1 version of ghostscript, libgs9 and libgs9-common.
At this point ps2pdf should be working fine.
Then sudo apt install ghostscript.
ghostscript and libgs9 are upgraded but not libgs9-common.
ps2pdf stops working :
$ ps2pdf ascii.ps
Unrecoverable error: typecheck in .bind
Operand stack:
    --nostringval-- typecheck --nostringval-- scheck .gcheck

[Regression Potential]

Might cause problems when upgrading or installing ghostscript or libgs9

[Other Info]

This bug affects trusty and xenial.
It is already fixed in bionic and later.

Changed in ghostscript (Ubuntu):
assignee: nobody → Ioanna Alifieraki (joalif)
Dan Streetman (ddstreet) on 2018-11-12
Changed in ghostscript (Ubuntu):
importance: Undecided → Medium
Changed in ghostscript (Ubuntu):
status: New → In Progress
Dan Streetman (ddstreet) on 2018-11-12
Changed in ghostscript (Ubuntu Trusty):
importance: Undecided → Medium
Changed in ghostscript (Ubuntu Xenial):
importance: Undecided → Medium
Changed in ghostscript (Ubuntu Trusty):
status: New → In Progress
Changed in ghostscript (Ubuntu Xenial):
status: New → In Progress
Changed in ghostscript (Ubuntu):
status: In Progress → Fix Released
Changed in ghostscript (Ubuntu Trusty):
assignee: nobody → Ioanna Alifieraki (joalif)
Changed in ghostscript (Ubuntu Xenial):
assignee: nobody → Ioanna Alifieraki (joalif)
Ioanna Alifieraki (joalif) wrote :

This fixes the libgs9-common dependency in trusty.

description: updated
Ioanna Alifieraki (joalif) wrote :

This fixes the libgs9-common dependency in xenial.

Dan Streetman (ddstreet) wrote :

uploaded to trusty and xenial queues, thanks!

Hello Ioanna, or anyone else affected,

Accepted ghostscript into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ghostscript/9.25~dfsg+1-0ubuntu0.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ghostscript (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Ioanna Alifieraki (joalif) wrote :

On Xenial :

When ghostscript, libgs9 and libgs9-common at 9.25~dfsg+1-0ubuntu0.16.04.1, ps2pdf works ok :

jo@xenial-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.16.04.1 amd64 interpreter for the PostScript language and for PDF
jo@xenial-build:~$ dpkg -l | grep libgs9
ii libgs9:amd64 9.25~dfsg+1-0ubuntu0.16.04.1 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.16.04.1 all interpreter for the PostScript language and for PDF - common files
jo@xenial-build:~$ ps2pdf ascii.ps

When apt install ghostscript, ps2pdf breaks (libgs9-common not upgraded to 9.25~dfsg+1-0ubuntu0.16.04.2) :

jo@xenial-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.16.04.2 amd64 interpreter for the PostScript language and for PDF
jo@xenial-build:~$ dpkg -l | grep libgs9
ii libgs9:amd64 9.25~dfsg+1-0ubuntu0.16.04.2 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.16.04.1 all interpreter for the PostScript language and for PDF - common files
jo@xenial-build:~$ ps2pdf ascii.ps
Unrecoverable error: typecheck in .bind
Operand stack:
    --nostringval-- typecheck --nostringval-- scheck .gcheck

Upgrade ghostscript from -proposed, ps2pdf works again :

jo@xenial-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.16.04.3 amd64 interpreter for the PostScript language and for PDF
jo@xenial-build:~$ dpkg -l | grep libgs9
ii libgs9:amd64 9.25~dfsg+1-0ubuntu0.16.04.3 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.16.04.3 all interpreter for the PostScript language and for PDF - common files
jo@xenial-build:~$ ps2pdf ascii.ps
jo@xenial-build:~$

tags: added: verification-done-xenial
removed: verification-needed-xenial
Ioanna Alifieraki (joalif) wrote :
Download full text (4.8 KiB)

Clarification to comment #5 :

- apt install ghostscript, upgrades only ghostscript and libgs9 but NOT libgs9-common :

jo@xenial-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.16.04.1 amd64 interpreter for the PostScript language and for PDF
jo@xenial-build:~$ dpkg -l | grep libgs9
ii libgs9:amd64 9.25~dfsg+1-0ubuntu0.16.04.1 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.16.04.1 all interpreter for the PostScript language and for PDF - common files
jo@xenial-build:~$ sudo apt install ghostscript
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libgs9
Suggested packages:
  ghostscript-x hpijs
The following packages will be upgraded:
  ghostscript libgs9
2 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/2,311 kB of archives.
After this operation, 2,048 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 35659 files and directories currently installed.)
Preparing to unpack .../ghostscript_9.25~dfsg+1-0ubuntu0.16.04.2_amd64.deb ...
Unpacking ghostscript (9.25~dfsg+1-0ubuntu0.16.04.2) over (9.25~dfsg+1-0ubuntu0.16.04.1) ...
Preparing to unpack .../libgs9_9.25~dfsg+1-0ubuntu0.16.04.2_amd64.deb ...
Unpacking libgs9:amd64 (9.25~dfsg+1-0ubuntu0.16.04.2) over (9.25~dfsg+1-0ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up libgs9:amd64 (9.25~dfsg+1-0ubuntu0.16.04.2) ...
Setting up ghostscript (9.25~dfsg+1-0ubuntu0.16.04.2) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
jo@xenial-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.16.04.2 amd64 interpreter for the PostScript language and for PDF
jo@xenial-build:~$ dpkg -l | grep libgs-9
jo@xenial-build:~$ dpkg -l | grep libgs9
ii libgs9:amd64 9.25~dfsg+1-0ubuntu0.16.04.2 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.16.04.1 all interpreter for the PostScript language and for PDF - common files

-After upgrade ghostscript from -proposed :

jo@xenial-build:~$ sudo apt-get install ghostscript/xenial-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '9.25~dfsg+1-0ubuntu0.16.04.3' (Ubuntu:16.04/xenial-proposed [amd64]) for 'ghostscript'
Selected version '9.25~dfsg+1-0ubuntu0.16.04.3' (Ubuntu:16.04/xenial-proposed [amd64]) for 'libgs9' because of 'ghostscript'
Selected version '9.25~dfsg+1-0ubuntu0.16.04.3' (Ubuntu:16.04/xenial-proposed [all]) for 'libgs9-common' because of 'libgs9'
The following additional packages will be installed:
  libgs9 libgs9-common
Suggested packages:
  ghostscript-x hpijs fonts-droid texlive-lang-cjk
The following packages will be upgr...

Read more...

Brian Murray (brian-murray) wrote :

Hello Ioanna, or anyone else affected,

Accepted ghostscript into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ghostscript/9.25~dfsg+1-0ubuntu0.14.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ghostscript (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Ioanna Alifieraki (joalif) wrote :
Download full text (5.1 KiB)

On trusty :

- apt install ghostscript, upgrades only ghostscript and libgs9 but NOT libgs9-common :

jo@trusty-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.14.04.1 amd64 interpreter for the PostScript language and for PDF
jo@trusty-build:~$ dpkg -l | grep libgs9
ii libgs9 9.25~dfsg+1-0ubuntu0.14.04.1 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.14.04.1 all interpreter for the PostScript language and for PDF - common files
jo@trusty-build:~$ sudo apt install ghostscript
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libgs9
Suggested packages:
  ghostscript-x hpijs
The following packages will be upgraded:
  ghostscript libgs9
2 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
Need to get 0 B/2,392 kB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 31580 files and directories currently installed.)
Preparing to unpack .../ghostscript_9.25~dfsg+1-0ubuntu0.14.04.2_amd64.deb ...
Unpacking ghostscript (9.25~dfsg+1-0ubuntu0.14.04.2) over (9.25~dfsg+1-0ubuntu0.14.04.1) ...
Preparing to unpack .../libgs9_9.25~dfsg+1-0ubuntu0.14.04.2_amd64.deb ...
Unpacking libgs9 (9.25~dfsg+1-0ubuntu0.14.04.2) over (9.25~dfsg+1-0ubuntu0.14.04.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libgs9 (9.25~dfsg+1-0ubuntu0.14.04.2) ...
Setting up ghostscript (9.25~dfsg+1-0ubuntu0.14.04.2) ...
Processing triggers for libc-bin (2.19-0ubuntu6.14) ...
jo@trusty-build:~$ dpkg -l | grep ghostscript
ii ghostscript 9.25~dfsg+1-0ubuntu0.14.04.2 amd64 interpreter for the PostScript language and for PDF
jo@trusty-build:~$ dpkg -l | grep libgs9
ii libgs9 9.25~dfsg+1-0ubuntu0.14.04.2 amd64 interpreter for the PostScript language and for PDF - Library
ii libgs9-common 9.25~dfsg+1-0ubuntu0.14.04.1 all interpreter for the PostScript language and for PDF - common files

- After upgrade ghostscript from -proposed, ghostscript, libgs9 and libgs9-common at right version :

jo@trusty-build:~$ sudo apt-get install ghostscript/trusty-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '9.25~dfsg+1-0ubuntu0.14.04.3' (Ubuntu:14.04/trusty-proposed [amd64]) for 'ghostscript'
Selected version '9.25~dfsg+1-0ubuntu0.14.04.3' (Ubuntu:14.04/trusty-proposed [amd64]) for 'libgs9' because of 'ghostscript'
Selected version '9.25~dfsg+1-0ubuntu0.14.04.3' (Ubuntu:14.04/trusty-proposed [all]) for 'libgs9-common' because of 'libgs9'
The following extra packages will be installed:
  libgs9 libgs9-common
Suggested packages:
  ghostscript-x hpijs fonts-droid
The following packages will be upgraded:
  ghostscript libgs9 libgs9-common
3 upgraded, 0 newly installed, 0 to remove...

Read more...

tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.25~dfsg+1-0ubuntu0.16.04.3

---------------
ghostscript (9.25~dfsg+1-0ubuntu0.16.04.3) xenial; urgency=medium

  * Fix dependency for libgs9-common (LP: #1802958)

 -- Ioanna Alifieraki <email address hidden> Mon, 12 Nov 2018 18:05:22 +0000

Changed in ghostscript (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ghostscript has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 9.25~dfsg+1-0ubuntu0.14.04.3

---------------
ghostscript (9.25~dfsg+1-0ubuntu0.14.04.3) trusty; urgency=medium

  * Fix dependency for libgs9-common (LP: #1802958)

 -- Ioanna Alifieraki <email address hidden> Mon, 12 Nov 2018 18:09:10 +0000

Changed in ghostscript (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers