Activity log for bug #172264

Date Who What changed Old value New value Message
2007-11-27 09:04:12 Neha Seth bug added bug
2007-11-27 19:06:26 Till Kamppeter ghostscript: importance Undecided Medium
2007-11-27 19:06:26 Till Kamppeter ghostscript: status New Incomplete
2007-11-28 11:18:30 Till Kamppeter ghostscript: importance Medium High
2007-11-28 11:18:30 Till Kamppeter ghostscript: status Incomplete Confirmed
2007-11-28 11:19:06 Till Kamppeter bug assigned to gs-gpl
2007-11-28 12:17:49 Till Kamppeter title Ubuntu 7.10 provides Ghostscript 8.61 pre-release version Ghostscript in Gutsy and Hardy is not able to print encrypted PDFs out of Adobe Reader 8.1.1
2007-11-29 09:36:17 Bug Watch Updater gs-gpl: status Unknown Confirmed
2007-12-04 22:12:31 Till Kamppeter bug assigned to foomatic-filters (Ubuntu)
2007-12-04 22:12:57 Till Kamppeter foomatic-filters: importance Undecided High
2007-12-04 22:12:57 Till Kamppeter foomatic-filters: assignee till-kamppeter
2007-12-04 22:12:57 Till Kamppeter foomatic-filters: status New In Progress
2007-12-04 22:13:26 Till Kamppeter ghostscript: status Confirmed In Progress
2007-12-04 22:13:26 Till Kamppeter ghostscript: assignee till-kamppeter
2007-12-04 22:13:54 Till Kamppeter bug assigned to foo2zjs (Ubuntu)
2007-12-04 22:14:33 Till Kamppeter foo2zjs: importance Undecided High
2007-12-04 22:14:33 Till Kamppeter foo2zjs: assignee till-kamppeter
2007-12-04 22:14:33 Till Kamppeter foo2zjs: status New In Progress
2007-12-05 12:38:53 Till Kamppeter foomatic-filters: status In Progress Fix Committed
2007-12-05 14:57:34 Till Kamppeter ghostscript: status In Progress Fix Committed
2007-12-05 16:55:54 Till Kamppeter foo2zjs: status In Progress Fix Committed
2007-12-06 08:25:05 Till Kamppeter foomatic-filters: status Fix Committed Fix Released
2007-12-06 08:30:09 Till Kamppeter ghostscript: status Fix Committed Fix Released
2007-12-06 08:30:25 Till Kamppeter foo2zjs: status Fix Committed Fix Released
2007-12-06 16:58:51 Till Kamppeter bug added attachment 'encrpdf.ps' (PostScript file for testing, created by printing an encrypted PDF file into a file with Adobe Reader 8.1.1)
2007-12-07 23:58:02 lunomad bug added attachment 'x-IMM1344EA Application and Undertaking.pdf' (Canada Immigration PDF won't print on my system)
2007-12-09 10:07:10 Bug Watch Updater gs-gpl: status Confirmed Fix Released
2007-12-09 16:08:35 Till Kamppeter ghostscript: status Fix Released In Progress
2007-12-10 13:16:48 Till Kamppeter ghostscript: status In Progress Fix Committed
2007-12-10 13:50:29 Till Kamppeter ghostscript: status Fix Committed Fix Released
2007-12-10 17:48:51 Till Kamppeter description Binary package hint: ghostscript There is a problem with printing secured PDFs from Abode Reader 8.1.1 to non PostScript printers. This problem is observed with Ubuntu Gutsy Gibbon (7.10), more specifically where the version of GhostScript on the machine is "8.61 pre-release". The CUPS error logs show "GPL Ghostscript SVN PRE-RELEASE 8.61: Unrecoverable error, exit code 1". This issue is mentioned in bug# 145772 (https://bugs.launchpad.net/ubuntu/+source/acroread/+bug/145772) as well. Since the issue is not observed with the official stable release of Ghostscript 8.61 (http://pages.cs.wisc.edu/~ghost/doc/GPL/gpl861.htm), that should be the one available at the Ubuntu Gutsy repository. Binary package hint: ghostscript There is a problem with printing secured PDFs from Abode Reader 8.1.1 to non PostScript printers. This problem is observed with Ubuntu Gutsy Gibbon (7.10), more specifically where the version of GhostScript on the machine is "8.61 pre-release". The CUPS error logs show "GPL Ghostscript SVN PRE-RELEASE 8.61: Unrecoverable error, exit code 1". This issue is mentioned in bug# 145772 (https://bugs.launchpad.net/ubuntu/+source/acroread/+bug/145772) as well. Since the issue is not observed with the official stable release of Ghostscript 8.61 (http://pages.cs.wisc.edu/~ghost/doc/GPL/gpl861.htm), that should be the one available at the Ubuntu Gutsy repository. TEST CASE: 1. Take the PostScript file attached to this bug (first attachment) and let Ghostscript render it, passing the file in via standard input but without buffered reading: cat encrpdf.gs | gs -sDEVICE=x11 - 2. Open the second attachment with Adobe Reader 8.1.1 (acroread) and try to print it on a non-PostScript printer and on a system where you did not manually apply the workarounds which I have shown in this bug report. Or print it into a file and then do the test case (1) with this file. 3. Do test case (2) with any encrypted/usage-restricted PDF file.
2007-12-10 17:48:51 Till Kamppeter title Ghostscript in Gutsy and Hardy is not able to print encrypted PDFs out of Adobe Reader 8.1.1 [Gutsy SRU Request] Ghostscript in Gutsy and Hardy is not able to print encrypted PDFs out of Adobe Reader 8.1.1
2007-12-10 17:57:38 Till Kamppeter bug added subscriber Ubuntu Stable Release Updates Team
2007-12-10 18:04:07 Till Kamppeter description Binary package hint: ghostscript There is a problem with printing secured PDFs from Abode Reader 8.1.1 to non PostScript printers. This problem is observed with Ubuntu Gutsy Gibbon (7.10), more specifically where the version of GhostScript on the machine is "8.61 pre-release". The CUPS error logs show "GPL Ghostscript SVN PRE-RELEASE 8.61: Unrecoverable error, exit code 1". This issue is mentioned in bug# 145772 (https://bugs.launchpad.net/ubuntu/+source/acroread/+bug/145772) as well. Since the issue is not observed with the official stable release of Ghostscript 8.61 (http://pages.cs.wisc.edu/~ghost/doc/GPL/gpl861.htm), that should be the one available at the Ubuntu Gutsy repository. TEST CASE: 1. Take the PostScript file attached to this bug (first attachment) and let Ghostscript render it, passing the file in via standard input but without buffered reading: cat encrpdf.gs | gs -sDEVICE=x11 - 2. Open the second attachment with Adobe Reader 8.1.1 (acroread) and try to print it on a non-PostScript printer and on a system where you did not manually apply the workarounds which I have shown in this bug report. Or print it into a file and then do the test case (1) with this file. 3. Do test case (2) with any encrypted/usage-restricted PDF file. Binary package hint: ghostscript There is a problem with printing secured PDFs from Abode Reader 8.1.1 to non PostScript printers. This problem is observed with Ubuntu Gutsy Gibbon (7.10), more specifically where the version of GhostScript on the machine is "8.61 pre-release". The CUPS error logs show "GPL Ghostscript SVN PRE-RELEASE 8.61: Unrecoverable error, exit code 1". This issue is mentioned in bug# 145772 (https://bugs.launchpad.net/ubuntu/+source/acroread/+bug/145772) as well. Since the issue is not observed with the official stable release of Ghostscript 8.61 (http://pages.cs.wisc.edu/~ghost/doc/GPL/gpl861.htm), that should be the one available at the Ubuntu Gutsy repository. TEST CASE: 1. Take the PostScript file attached to this bug (first attachment) and let Ghostscript render it, passing the file in via standard input but without buffered reading: cat encrpdf.ps | gs -sDEVICE=x11 - 2. Open the second attachment with Adobe Reader 8.1.1 (acroread) and try to print it on a non-PostScript printer and on a system where you did not manually apply the workarounds which I have shown in this bug report. Or print it into a file and then do the test case (1) with this file. 3. Do test case (2) with any encrypted/usage-restricted PDF file.
2007-12-11 09:03:20 Martin Pitt foo2zjs: status New Invalid
2007-12-11 09:03:27 Martin Pitt foomatic-filters: status New Invalid
2007-12-11 09:05:18 Martin Pitt ghostscript: status New Incomplete
2008-01-08 20:28:56 Martin Pitt bug added subscriber SRU Verification
2008-01-08 20:29:02 Martin Pitt ghostscript: status Incomplete Fix Committed
2008-01-22 09:01:55 Martin Pitt ghostscript: status Fix Committed Fix Released
2008-06-22 10:23:14 Holger Koch bug added attachment 'close-evk.pdf' (close-evk.pdf)
2009-07-05 04:05:14 Launchpad Janitor branch linked lp:ubuntu/karmic/foo2zjs
2009-07-08 22:07:10 Launchpad Janitor branch linked lp:ubuntu/karmic/ghostscript
2009-12-02 08:13:10 Launchpad Janitor branch linked lp:ubuntu/foomatic-filters
2011-02-04 08:05:54 Bug Watch Updater gs-gpl: importance Unknown Critical
2011-02-06 04:44:19 Holger Koch removed subscriber atarax