CJK Installation fails with error: poppler-data : Breaks: cmap-adobe-gb1 (<= 0+20090930-2)

Bug #1009052 reported by Nicholas Skaggs on 2012-06-05
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ghostscript (Ubuntu)
High
Mathieu Trudel-Lapierre
Quantal
High
Mathieu Trudel-Lapierre
language-selector (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Using simplied chinese testcase, the installation fails halfway through with the attached error in the screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.4
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic i686
ApportVersion: 2.1.1-0ubuntu2
Architecture: i386
CasperVersion: 1.317
Date: Tue Jun 5 10:57:47 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120604.3)
ProcEnviron:
 LANGUAGE=zh_CN.UTF-8
 TERM=linux
 PATH=(custom, no user)
 LANG=zh_CN.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Nicholas Skaggs (nskaggs) wrote :
Nicholas Skaggs (nskaggs) wrote :
Nicholas Skaggs (nskaggs) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1009052

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

I reproduced the problem with Chinese.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Could be caused by the following dependency resolution with ubuntu-default-zh-cn installs on the target system:
Removing cmap-adobe-japan2 ...
dpkg: gs-cjk-resource: dependency problems, but removing anyway as you requested:
 libgs9 depends on gs-cjk-resource.
Removing gs-cjk-resource ...

Changed in ubuntu-defaults-zh-cn (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → High
tags: added: qa-manual-testing rls-mgr-q-tracking
Changed in ubuntu-defaults-zh-cn (Ubuntu Quantal):
status: Confirmed → Invalid
Jean-Baptiste Lallement (jibel) wrote :

The following packages are installed during a Chinese installation:
hyphen-en-us
myspell-en-au
myspell-en-gb
myspell-en-za
mythes-en-us
openoffice.org-hyphenation
poppler-data
thunderbird-locale-en
thunderbird-locale-en-us
wbritish
cmap-adobe-gb1
fonts-arphic-uming
ibus-sunpinyin
ibus-table-wubi
libreoffice-help-zh-cn
libreoffice-l10n-zh-cn
poppler-data

Which causes the following dependency issue:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 poppler-data : Breaks: cmap-adobe-gb1 (<= 0+20090930-2)
E: Unable to correct problems, you have held broken packages.

Moving to poppler

affects: ubiquity (Ubuntu Quantal) → poppler-data (Ubuntu Quantal)
summary: - CJK Installation fails with error
+ CJK Installation fails with error: poppler-data : Breaks: cmap-adobe-gb1
+ (<= 0+20090930-2)
affects: poppler-data (Ubuntu Quantal) → language-selector (Ubuntu Quantal)
Changed in language-selector (Ubuntu Quantal):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

That's a ghostscript issue, that merge from Debian is required:

ghostscript (9.05~dfsg-6) unstable; urgency=low

   * Fix symlink to DroidSans.
     Closes: bug#661764. Thanks to Ian Zimmerman.
   * Have libgs9 depend on recent poppler-data favored over
     gs-cjk-resource.

affects: language-selector (Ubuntu Quantal) → ghostscript (Ubuntu Quantal)
Changed in ghostscript (Ubuntu Quantal):
assignee: Canonical Desktop Team (canonical-desktop-team) → Mathieu Trudel-Lapierre (mathieu-tl)
Sebastien Bacher (seb128) wrote :

ghostscript (9.05~dfsg-0ubuntu5) quantal; urgency=low

  * debian/rules: Have libgs9 depend on recent poppler-data favored over
    gs-cjk-resource.

Changed in ghostscript (Ubuntu Quantal):
status: Confirmed → Fix Released
affects: ubuntu-defaults-zh-cn (Ubuntu Quantal) → language-selector (Ubuntu Quantal)
Changed in language-selector (Ubuntu Quantal):
status: Invalid → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.81

---------------
language-selector (0.81) quantal; urgency=low

  * data/pkg_depends: replace cmap-adobe- depends by poppler-data
    (lp: #1009052)
 -- Sebastien Bacher <email address hidden> Thu, 07 Jun 2012 12:45:28 +0200

Changed in language-selector (Ubuntu Quantal):
status: In Progress → Fix Released
Victor Zhou (victor.zhou) wrote :

Verified the bug with the latest i386-desktop daily build, no this problem any more.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers