Please merge ghc6 6.8.2-7 (universe) from Debian unstable (main).

Bug #297989 reported by Alessio Treglia on 2008-11-14
2
Affects Status Importance Assigned to Milestone
ghc6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ghc6

Please sync ghc6 6.8.2-7 (universe) from Debian unstable (main).

Changelog since current jaunty version 6.8.2-6ubuntu2:

ghc6 (6.8.2-7) unstable; urgency=medium

  * Build-Depend on hurd as an alternative to procps. (Closes: #481343)
  * Added AC_SYS_LARGEFILE to libraries/unix/configure.ac and ran
    autoreconf. (Closes: #500407)

 -- Kari Pahula <email address hidden> Sun, 28 Sep 2008 10:32:20 +0300

Related branches

Changed in ghc6:
status: New → Confirmed
StefanPotyra (sistpoty) wrote :

Marking as invalid, c.f. the delta in debian/rules.
Please be careful to not accidantely drop Ubuntu changes (a good way I've found for myself is to actually give a detailed lists in a bug report instead of a generic statement).

Thanks,
    Stefan.

Changed in ghc6:
status: Confirmed → Invalid
Alessio Treglia (quadrispro) wrote :

Sorry, you're right, it's a merge.

I'm working on it.

Changed in ghc6:
assignee: nobody → quadrispro
status: Invalid → In Progress
Alessio Treglia (quadrispro) wrote :

Please usubscrive u-u-s, I will re-subscribe sponsors' team later.

description: updated
Alessio Treglia (quadrispro) wrote :

attaching debdiff

Changed in ghc6:
assignee: quadrispro → nobody
status: In Progress → Confirmed
StefanPotyra (sistpoty) wrote :

Hi again,

from a glimpse at the debdiff, the runghc manpage seems to be missing... is it really part of the unstable package now?

Also, I'm sorry if the comment on dad wasn't clear enough: the debian version (-7) doesn't have any changes applicable to ubuntu, that aren't part of the current package (the only missing change is the b-d on hurd, which we don't have). So I'm not 100% sure if merging is worth the effort at this time (well, I don't mind if s.o. uploads it, I just try to seek for an excuse to avoid the lengthy build myself *g*).

I guess s.th. that would be worth to pick up would be bug #288601.

Cheers,
    Stefan.

Alessio Treglia (quadrispro) wrote :

darcs 2.1.0-1 depends on new debian version, so I think merging could be useful.

i'm working on new debdiff (man page must be added)

Changed in ghc6:
assignee: nobody → quadrispro
status: Confirmed → In Progress
Alessio Treglia (quadrispro) wrote :
Changed in ghc6:
assignee: quadrispro → nobody
status: In Progress → Confirmed
StefanPotyra (sistpoty) wrote :

ok, looks good, test-building right now.

Oh, I beautified the changelog entry a bit (in regards to indentation, not to content). Hope you don't mind that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghc6 - 6.8.2-7ubuntu1

---------------
ghc6 (6.8.2-7ubuntu1) jaunty; urgency=low

  * Merge from Debian unstable (LP: #297989), Ubuntu remaining changes:
    + debian/rules:
      - Make lpia similar to i386.
      - Add lpia to debian/ghc6_vars.
    + Add manpage for runghc.

ghc6 (6.8.2-7) unstable; urgency=medium

  * Build-Depend on hurd as an alternative to procps. (Closes: #481343)
  * Added AC_SYS_LARGEFILE to libraries/unix/configure.ac and ran
    autoreconf. (Closes: #500407)

 -- Alessio Treglia <email address hidden> Fri, 14 Nov 2008 17:53:58 +0100

Changed in ghc6:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers