Ubuntu

Loading stripped libHSghc fails

Reported by Alejandro Serrano on 2011-08-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ghc (Ubuntu)
Medium
Unassigned

Bug Description

As discussed in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622731, there is a bug in the Debian version of ghc 7.0.3-1, which results in the following error when using Template Haskell:

ghc: panic! (the 'impossible' happened)
 (GHC version 7.0.3 for x86_64-unknown-linux):
       loadArchive "/usr/lib/ghc-7.0.3/ghc-7.0.3/libHSghc-7.0.3.a": failed

This means that packages using the 'ghc' library have a difficult time compiling. The bug was solved in version 7.0.4-1, so I request to reimport it from Debian.

Related branches

Iain Lane (laney) wrote :

We really can't go through another Haskell transition (which is what uploading the new version of GHC would entail). If someone wants to apply the patch from the upstream bug to our GHC and verify it works, that would be fine though.

summary: - Please sync ghc from debian unstable
+ Loading stripped libHSghc fails
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Loading stripped libHSghc fails
+ [needs-packaging] Loading stripped libHSghc fails
Changed in ghc (Ubuntu):
importance: Undecided → Wishlist
Iain Lane (laney) on 2011-08-05
tags: removed: needs-packaging
summary: - [needs-packaging] Loading stripped libHSghc fails
+ Loading stripped libHSghc fails
Changed in ghc (Ubuntu):
importance: Wishlist → Undecided
importance: Undecided → Medium
status: New → Triaged
Alejandro Serrano (serras) wrote :

I've built GHC 7.04-4 from Debian unstable and the rest of the packages of which haskell-platform depends in a PPA: https://launchpad.net/~serras/+archive/ghc-from-debian-unstable This makes impossible to use the rest of libghc-* libraries already packaged in Ubuntu, but the developer may use "cabal install" to get them in the system.

Iain Lane (laney) wrote :

It would be nice(r) if you would take that specific patch and post a patch to this bug for an updated /Ubuntu/ package for us.

I could then sponsor it into Oneiric.

Otherwise I will hopefully get round to this in the next couple of weeks.

Alejandro Serrano (serras) wrote :

The only thing I did was taking the package from Debian unstable and rebuilding all the things that depended on it.
So the best idea, I think, would be unfreezing the packages ghc, haskell-platform, cabal, alex, happy, cpphs and all the libghc- ones and reimport it from Debian unstable.
I'm willing to help to get this solved :D

On Tue, Aug 09, 2011 at 09:04:03PM -0000, Alejandro Serrano wrote:
> The only thing I did was taking the package from Debian unstable and rebuilding all the things that depended on it.
> So the best idea, I think, would be unfreezing the packages ghc, haskell-platform, cabal, alex, happy, cpphs and all the libghc- ones and reimport it from Debian unstable.
> I'm willing to help to get this solved :D

That will mean rebuilding /all/ 200+ Haskell packages in the correct order,
something which I've already done twice this cycle and don't really want
to do it again, I'm afraid.

Alejandro Serrano (serras) wrote :

I know. It was horrible to just get built the packages for the PPA. I don't want to imagine how that would be with the entire set of packages.

Iain Lane (laney) wrote :

I am building an updated package now.

Changed in ghc (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Triaged → In Progress
Iain Lane (laney) wrote :

Fixed. Upload coming up.

  (oneiric-amd64)root@raleigh:/srv/home/laney/temp# ghci
  GHCi, version 7.0.3: http://www.haskell.org/ghc/ :? for help
  Loading package ghc-prim ... linking ... done.
  Loading package integer-gmp ... linking ... done.
  Loading package base ... linking ... done.
  Prelude> :set -package ghc
  package flags have changed, resetting and loading new packages...
  Loading package array-0.3.0.2 ... linking ... done.
  Loading package containers-0.4.0.0 ... linking ... done.
  Loading package filepath-1.2.0.0 ... linking ... done.
  Loading package old-locale-1.0.0.2 ... linking ... done.
  Loading package old-time-1.0.0.6 ... linking ... done.
  Loading package unix-2.4.2.0 ... linking ... done.
  Loading package directory-1.1.0.0 ... linking ... done.
  Loading package pretty-1.0.1.2 ... linking ... done.
  Loading package process-1.0.1.5 ... linking ... done.
  Loading package Cabal-1.10.1.0 ... linking ... done.
  Loading package bytestring-0.9.1.10 ... linking ... done.
  Loading package ghc-binary-0.5.0.2 ... linking ... done.
  Loading package bin-package-db-0.0.0.0 ... linking ... done.
  Loading package hpc-0.5.0.6 ... linking ... done.
  Loading package template-haskell ... linking ... done.
  Loading package ghc-7.0.3 ... linking ... done.
  Prelude>
  Leaving GHCi.

Iain Lane (laney) wrote :

Uploaded to Oneiric now.

Changed in ghc (Ubuntu):
assignee: Iain Lane (laney) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers