progress bar totally pointless

Bug #45664 reported by Andrea Garbarini
6
Affects Status Importance Assigned to Milestone
gfxboot-theme-ubuntu (Ubuntu)
Medium
Colin Watson

Bug Description

I wonder what that progress is meant to represent. It should get filled up when both the kernel and the initrd have been uncompressed, but actually, it gets filled almost instantly. Most of all, I think we should get rid of those HORRIBLE dots trailing across the screen when the kernel and the initrd image are getting uncompressed, I really can't understand why an average user should be bothered with that techie stuff at all.

Revision history for this message
Colin Watson (cjwatson) wrote :

The dots are bug 29394. I didn't just put them there to irritate you :-) - they're only still there because I can't quite face the assembly hacking necessary to work out how to get RID of them.

Revision history for this message
Andrea Garbarini (garba) wrote :

Wow, that's good news, I am glad to know that wasn't intentional! I wish you happy hacking then Colin! ;) regards, andre

Changed in gfxboot-theme-ubuntu:
status: New → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

I'm not sure this will deal with the stray dots, but I've removed the progress bar for my next upload.

Changed in gfxboot-theme-ubuntu:
assignee: nobody → kamion
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gfxboot-theme-ubuntu - 0.6.3

---------------
gfxboot-theme-ubuntu (0.6.3) intrepid; urgency=low

  * Update language names from localechooser 2.03ubuntu1, adding Amharic and
    Marathi, adjusting the default locale for Esperanto, and fixing the
    localised name for Hungarian (LP: #233229).
  * Update keymaps from console-setup 1.25ubuntu1. Drop the braille keymap,
    which is not very useful here; stop excluding the cs keymap since it no
    longer exists (replaced by rs, which is fine).
  * Remove progress bar. It generally takes very little time so is just
    another UI flicker, and removing it avoids some UI (LP: #45664) and
    translation (LP: #221550) cans of worms.

 -- Colin Watson <email address hidden> Mon, 30 Jun 2008 16:11:23 +0100

Changed in gfxboot-theme-ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers