gfxboot fails to pass full kernel command line on some systems

Bug #31974 reported by DominikBodi
34
Affects Status Importance Assigned to Milestone
gfxboot-theme-ubuntu (Ubuntu)
Fix Released
Medium
Colin Watson

Bug Description

The GUI-based boot menu boots into a kernel panic.

Hardware: Targa Traveller 826 (see https://wiki.ubuntu.com/LaptopTestingTeam/TargaTraveller826 ).

S/W: Kubuntu Dapper Flight 4 i386 Install CD

The install CD menu comes up ok, but when booting the actuall installer kernel I get a kernel panic with following error messages (time tags omitted):

"VFS: Cannot open root device "<NULL>" or unknown-block(8,1)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs un unknown-block(8,1)"

The standard kernel command line reads:
"preseed/file=/cdrom/preseed/kubuntu.seed initrd:/install/initrd.gz ramdisk_size=16384 root=/dev/ram rq quiet --"

It does not matter if I add other options to the kernel boot command or not. Likewise, selecting "Install in OEM mode" or "Install a server" end up having the same kernel panic.

I'll try this with the amd64 flavour and the LiveCDs next, then with the Ubuntu Dapper Flight 4 disks.

I never had this problem with earlier Dapper Flight version, nor with breezy.

Revision history for this message
DominikBodi (dominik-bodi) wrote :

I've completed trying all kubuntu df4 install and live cds. All have the same problem.

The livecd's kernel command line looks like this:
"boot=casper initrd=/install/initrd.gz ramdisk_size=1048576 root=/dev/ram rw quit splash --"

I found a way to work around this problem. In the CDs boot menu, I press the Escape key to start the text-base interface. Booting the installer kernel from there works.

summary: + The GUI-base boot menu boots into a kernel panic.
summary: - The GUI-base boot menu boots into a kernel panic.
+ The GUI-based boot menu boots into a kernel panic.
Revision history for this message
DominikBodi (dominik-bodi) wrote : Re: Kubuntu Dapper Flight 4 - Boot menu boots into a kernel panic

sorry, wrong package.

Changed in syslinux:
assignee: nobody → kamion
Revision history for this message
Luka Renko (lure) wrote :

I have the same problem: installing Kubuntu Dapper Fligh4 (i386) fails with above message on HP Compaq nw8240.
(Flight 2 and Flight 3 worked without problems on this machine)

Revision history for this message
Luka Renko (lure) wrote :

Looks to be HW specific issue: it works without any problem on my desktop (noname P4 2.4GHz, ATI-9100)

Revision history for this message
Tolstoy (keith-irwin) wrote :

I can sort-of confirm this. Booting the Live-CD (Dapper F4) causes a dialog to appear saying that it can't find the ramdisk /install, or something like that.

Hardware: HP/Compaq nw8240.

Revision history for this message
Luka Renko (lure) wrote :

see also bug 32622: also reported on other HW

Luka Renko (lure)
Changed in gfxboot-theme-ubuntu:
status: Unconfirmed → Confirmed
Revision history for this message
fangorious (fangorious-deactivatedaccount) wrote :

This bug is gone for me with a dapper i386 daily install image from 03/03.

Revision history for this message
DominikBodi (dominik-bodi) wrote :

I can confirm that daily kubuntu i386 install of 2006-03-05 doesn't show the bug anymore. Seems this has been fixed.

Regards,
Dominik

Changed in gfxboot-theme-ubuntu:
status: Confirmed → Fix Released
Revision history for this message
Paul Sladen (sladen) wrote :

Okay, so to make this clear.

If the gfxboot menu is /exited/ (by starting the kernel) in text-mode then everything works.

But if the gfxboot menu is /exited/ (by starting the kernel) in graphics-mode then the initramfs RAM disk will be corrupt or not loaded.

Could people confirm if this is a good synopsis?

Revision history for this message
Luka Renko (lure) wrote :

In my case (HP nw8240) it was like this: if I selected any install option (install, install OEM) from boot menu, I got the VFS error.
I can only install Flight 4 by pressing "Esc", which exits gfxboot and then pressing Enter which starts installation in text mode - then I can install it w/o problems.

I cannot confirm if this was fixed, as I cannot install Flight 5 or daily build as it hangs when "kubuntu" spalsh is shown for gfxboot (no menu shown yet) - see bug 34586

Revision history for this message
DominikBodi (dominik-bodi) wrote :

> Could people confirm if this is a good synopsis?

That's exactly what I've seen, Paul. Btw, I suffer from https://launchpad.net/distros/ubuntu/+source/gfxboot-theme-ubuntu/+bug/34592/ as well.

Revision history for this message
Luka Renko (lure) wrote :

I am reopening this bug as I still have this problem on HP nw8240 with today's daily build:
http://cdimage.ubuntu.com/daily/20060408/dapper-install-i386.iso

I could not test recent CD images (after Flight 4) due to bug 34592, but now that that bug is fixed I can confirm that this bug is still alive. I would like to point out that similar machines are involved in both bugs and that this might be related.

Changed in gfxboot-theme-ubuntu:
status: Fix Released → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

gfxboot-theme-ubuntu 0.1.19 fixes up some debug code so that we can take a better look at this.

With tomorrow's daily CD build (check the timestamp first), press Shift-F10 three times to increase the debug level to 3, and then press Enter to boot. This should then print what gfxboot-theme-ubuntu thinks the kernel command line is at the top of the screen (it's possible it will wrap off the right-hand side of the screen, but with any luck only the "<< (press ESC)" bit will wrap; I suggest using an install CD for this test since its kernel command line is shorter). Please transcribe this as accurately as you can into this bug. Thanks in advance.

Revision history for this message
Luka Renko (lure) wrote :

I have tested this with this CD image:
http://cdimage.ubuntu.com/daily/20060410/dapper-install-i386.iso

I just get the following text in upper left corner:
Install on (<< press ESC)

Revision history for this message
Luka Renko (lure) wrote :

mistake in my previous post (as I did it from my head) - this time I did collect it for all three install modes (to hard disk, OEM and server):

1. to hard disk
install in<< (press ESC)

2. OEM
oem initrd<< (press ESC)

3. server
server ini<< (press ESC)

Revision history for this message
Matt Zimmerman (mdz) wrote :

Odd, it's truncated at 11 characters in every case

Revision history for this message
Luka Renko (lure) wrote :

Colin: did you change anything recently in this regard? I have just tested with Ubuntu Beta Install CD and it works!

I will now test again with Kubuntu Beta Install CD (as I have always tested Kubuntu CDs only)...

Revision history for this message
Luka Renko (lure) wrote :

Also works for Kubuntu Dapper Beta install CD!
I am closing this.

Dominik: if you can still reproduce it on your system with Dapper Beta CD (or newer) feel free to reopen this bug.

Changed in gfxboot-theme-ubuntu:
status: Confirmed → Fix Released
Revision history for this message
DominikBodi (dominik-bodi) wrote :

Works with Dapper Beta. Thank you :-)

Regards,
Dominik

Revision history for this message
Kraemer (tommy-goober) wrote :

I'm having this exact same issue with the exact same details as listed above.

I'm running an HP Omnibook xe3 and the workaround listed above does not work. I'm attepmting to install the most recent build (downloaded today) to a system with no pre-existing linux partitions.

Any further ideas?

Thanks.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers