Unable to install from text mode interface

Bug #1505839 reported by Andrew Starr-Bochicchio on 2015-10-13
76
This bug affects 11 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
gfxboot-theme-ubuntu (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
syslinux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

I use packer (https://www.packer.io) to automate the creation of Ubuntu virtual machine images. It's "boot_command" allows you to pass key presses to the installer. For 15.04, I use something like this:

-----

            "boot_command": [
                "<esc><esc><enter><wait>",
                "/install/vmlinuz auto url=http://{{ .HTTPIP }}:{{ .HTTPPort }}/ubuntu-15-04.cfg ",
                "debian-installer=en_US locale=en_US kbd-chooser/method=us ",
                "hostname={{ .Name }} ",

                "keyboard-configuration/modelcode=SKIP ",
                "keyboard-configuration/layout=USA ",
                "keyboard-configuration/variant=USA ",

                "initrd=/install/initrd.gz -- <enter>"
            ],

----

Pressing escape twice and then enter brings you to the text mode interface and then it boots the installer with a preseed file served over HTTP:

    /install/vmlinuz auto url=http://10.0.2.2:8081/ubuntu-15-04.cfg debian-installer=en_US locale=en_US kbd-chooser/method=us hostname=myhostname keyboard-configuration/modelcode=SKIP keyboard-configuration/layout=USA keyboard-configuration/variant=USA initrd=/install/initrd.gz --

This successfully boots and installs on 15.04. On 15.10 it displays:

----

Loading bootlogo...

Initializing gfx code...

----

And then returns to the to the language selection screen. Manually booting the iso and entering the text mode interface, the same thing happens. I've tried with both the 10/13 daily and Beta-2 images.

I see others are running into this as well https://github.com/boxcutter/ubuntu/issues/22

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
tags: added: wily

The workaround from https://github.com/boxcutter/ubuntu/issues/22 works.

Instead of pressing escape twice and enter to enter text mode do select your language and push F6, enter and escape to enable expert mode and then remove everything from Boot Options and then add the above line:

  /install/vmlinuz auto url=http://10.0.2.2:8081/ubuntu-15-04.cfg debian-installer=en_US locale=en_US kbd-chooser/method=us hostname=myhostname keyboard-configuration/modelcode=SKIP keyboard-configuration/layout=USA keyboard-configuration/variant=USA initrd=/install/initrd.gz --

tags: added: regression-release
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Diogo Matsubara (matsubara) wrote :

This is still an issue on Xenial, I'm setting this to high and targeting to 16.04 milestone as per Robie's triage of the dupe (bug 1537252)

Changed in debian-installer (Ubuntu):
milestone: none → ubuntu-16.04
importance: Medium → High
Thiago Martins (martinx) wrote :

Hope to see this fixed for 16.04! Happy hacking guys! :-D

Seth Thomas (seth-g-thomas) wrote :

Just confirmed that this bug is still present in xenial-server-* builds as of March 2.

Thiago Martins (martinx) wrote :

And it is not even assigned, no one is working on this?

Ian Chilton (ian-ichilton) wrote :

Just tried building http://cdimage.ubuntu.com/ubuntu-server/daily/current/xenial-server-amd64.iso (dated 14th March) and it still has this bug.

The workaround posted by "andrewsomething" at: https://github.com/boxcutter/ubuntu/issues/22 still works.

Ian

Thiago Martins (martinx) wrote :

It will be a shame to release Xenial with this bug opened... =/

Dave Chiluk (chiluk) wrote :

This really seems to be an issue with packer, and not the Ubuntu installer.

May I suggest a better alternative. Instead of using packer why not use the ubuntu cloud images available
http://cloud-images.ubuntu.com/

or use virt-install and the netboot installers a.la.
virt-install \
        --connect qemu:///system \
        --virt-type kvm \
        --name demo \
        --ram 2048 \
        --disk size=10 \
        --graphics vnc \
        -l ftp://ftp.utexas.edu/pub/ubuntu/dists/trusty/main/installer-amd64/ \
       --os-variant ubuntutrusty

The ubuntu text mode installer is a pretty pristine fork from debian, and as such I don't think we should be fixing this in Ubuntu.

Ubuntu has version 20101020ubuntu445 of debian-installer while Debian has 20160106. That seems to imply that it it was forked years ago without re-syncing on Debian.

Yes, it hits Packer users but it certainly isn't limited to Packer. As I mention in the original report, I can reproduce it booting the ISO manually as well.

I can confirm this is a bug with Ubuntu and is perfectly reproducible without Packer.

Thiago Martins (martinx) wrote :

Dave Chiluk, you're wrong, this problem is perfectly reproducible without Packer.

This is an Ubuntu BUG, for sure. Might be present on Debian as well but, I didn't tested it on Debian.

What I know is that "install from text mode interface" does not work anymore on Ubuntu, with or without Packer.

Steve Langasek (vorlon) wrote :

It may be true that this represents a bug in the syslinux package. But from an Ubuntu user experience POV, this is undocumented behavior - I didn't know that hitting 'esc' at that screen did anything, and we have never had a 'text mode interface' as part of the supported UI. The supported interface is the F6 "extra boot options" interface which is being described here as a "workaround".

Scott Moser (smoser) wrote :

A quick bit of testing shows that this regressed between ubuntu-15.04-server-amd64.iso and ubuntu-15.10-server-amd64.iso .
So:

WORKS: ubuntu-14.04.4-server-amd64.iso
WORKS: ubuntu-15.04-server-amd64.iso
FAILS: ubuntu-15.10-server-amd64.iso
FAILS: xenial-server-amd64-daily-20160411.2.iso

Thats good, because it means if the regression was in syslinux, then it was between 3:6.03+dfsg-5ubuntu1 and 3:6.03+dfsg-8ubuntu2 (there was a major version bump in syslinux between trusty and but it still seems to work in vivid. so that is good):

$ rmadison syslinux
 syslinux | 2:4.05+dfsg-2 | precise | source, amd64, i386
 syslinux | 3:4.05+dfsg-6+deb8u1 | trusty | source, amd64, i386
 syslinux | 3:6.03+dfsg-5ubuntu1 | vivid | source, amd64, i386
 syslinux | 3:6.03+dfsg-8ubuntu2 | wily | source, amd64, i386
 syslinux | 3:6.03+dfsg-11ubuntu1 | xenial | source, amd64, i386

Scott Moser (smoser) wrote :

There was some conversation on irc yesterday.
 http://irclogs.ubuntu.com/2016/04/11/%23ubuntu-devel.html#t20:18
cjwatson suggested likely gfxboot-theme-ubuntu as the bug component.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gfxboot-theme-ubuntu (Ubuntu):
status: New → Confirmed
Scott Moser (smoser) on 2016-04-12
affects: gfxboot (Ubuntu) → gfxboot-theme-ubuntu (Ubuntu)
Scott Moser (smoser) wrote :

just for some more info, I asked for clarification from cjwatson.
 $ rmadison gfx-boot-theme-ubuntu
 gfxboot-theme-ubuntu | 0.13.2 | precise | source, amd64, i386
 gfxboot-theme-ubuntu | 0.13.3 | precise-updates | source, amd64, i386
 gfxboot-theme-ubuntu | 0.16.1 | trusty | source, amd64, i386
 gfxboot-theme-ubuntu | 0.18.0 | vivid | source, amd64, i386
 gfxboot-theme-ubuntu | 0.18.0 | wily | source, amd64, i386
 gfxboot-theme-ubuntu | 0.20.0 | xenial | source, amd64, i386

Even though gfx-boot-theme-ubuntu did nto change from vivid to wily where the regression occurred, cjwatson suggests that it still may be the cause of the issue as gfxboot-theme-ubuntu and syslinux are very tightly related.

16.10 this works as expected.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gfxboot-theme-ubuntu (Ubuntu):
status: New → Confirmed
Changed in syslinux (Ubuntu):
status: New → Confirmed
Changed in syslinux (Ubuntu):
status: Confirmed → Fix Released

Per former comment by Rickard we can consider Dev fixed, yet one might want to look into Xenial.

tags: added: bot-stop-nagging
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers