No boot screen starting from 20140602.1

Bug #1327831 reported by Jean-Baptiste Lallement on 2014-06-08
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Critical
Colin Watson
gfxboot-theme-ubuntu (Ubuntu)
Critical
Ubuntu Installer Team

Bug Description

Last know good image: Ubuntu Desktop 20140529.1

Starting from Ubuntu Desktop 20140602.1 there is no boot screen when Ubuntu is booted from an ISO (all black with a grey rectangle in the bottom left corner cf screenshot)

Manifest files for 20140529.1 and 20140602.1 attached. In particular it corresponds to the upload of syslinux.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: syslinux 3:6.03~pre1+dfsg-4
ProcVersionSignature: Ubuntu 3.15.0-5.10-generic 3.15.0-rc8
Uname: Linux 3.15.0-5-generic x86_64
ApportVersion: 2.14.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jun 8 21:23:48 2014
SourcePackage: syslinux
UpgradeStatus: Upgraded to utopic on 2012-01-31 (858 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Changed in syslinux (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
summary: - No boot screen
+ No boot screen starting from 20140602.1
Jean-Baptiste Lallement (jibel) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in syslinux (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1327831

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

http://www.syslinux.org/archives/2013-July/020398.html

It appears that accesing files outside of bootlogo is no longer supported, thus repacking bootlogo like so:

cpio -ivd < bootlogo
ls -1 init *.tr *.hlp *.pcx back.jpg gfxboot.cfg langlist | cpio -o --quiet > bootlogo

Results in gfxboot being displayed. I'm not sure if I'm missing more files to be included in bootlogo, or in fact if the whole isolinux/* should be included in the bootlogo archive. (E.g. from above bootlogo language selection table didn't print any names, as if the font was missing)

But at least I did boot into maybe-ubiquity mode.

Colin Watson (cjwatson) wrote :

gfxboot-theme-ubuntu needs a slight tweak to how it finds isolinux.cfg, but most of the rest is in debian-cd. I've also asked upstream if they'll consider reintroducing the old behaviour somehow.

affects: syslinux (Ubuntu) → gfxboot-theme-ubuntu (Ubuntu)
Changed in gfxboot-theme-ubuntu (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-cdimage:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I think this should do the job for now, although it isn't ideal for customisers:

revno: 1890
fixes bug: https://launchpad.net/bugs/1327831
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Fri 2014-06-20 15:59:18 +0100
message:
  Add a number of extra files to the bootlogo archive to work around a change in syslinux 5.

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gfxboot-theme-ubuntu - 0.17.0

---------------
gfxboot-theme-ubuntu (0.17.0) utopic; urgency=medium

  * Look up syslinux.cfg and isolinux.cfg in the bootlogo archive as well
    (LP: #1327831).
 -- Colin Watson <email address hidden> Fri, 20 Jun 2014 15:49:37 +0100

Changed in gfxboot-theme-ubuntu (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers