gftp crashes while deleting many files

Bug #82101 reported by Justin Hartman
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gftp (Ubuntu)
Fix Released
Medium
Ubuntu GNOME

Bug Description

Binary package hint: gftp-gtk

gftp 2.0.18
ubuntu 6.10

Reproduce problem:

1. Navigate into a folder with more than 600 files
2. Select all 600 files
3. Delete files

Expected results:

1. gftp will delete about 150 files before hanging
2. After some time hanging gftp simply crashes.

Will attach crash log file after submitting this bug.

Revision history for this message
Justin Hartman (jjhartman) wrote :
Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for reporting this bug. I tried to reproduce this bug and failed both on Edgy (gftp 2.0.18-14ubuntu1) and Feisty (gftp 2.0.18-16ubuntu1).

Please try to reproduce this bug with debug packages (follow
https://wiki.ubuntu.com/DebuggingProgramCrash). Thanks in advance.

Changed in gftp:
assignee: nobody → asisak
status: Unconfirmed → Needs Info
Revision history for this message
Justin Hartman (jjhartman) wrote :

Hi Aron

I am going to install the debug packages and see if I can get more information for you guys.

Regards
Justin

Revision history for this message
Justin Hartman (jjhartman) wrote :

OK I've tried to do a backtrace without much luck. As expected gftp crashed after deleting about 150 odd files but here is the output once I tried the backtrace from when it crashed:-

Continuing.
[New Thread -1249481808 (LWP 21672)]
[Thread -1249481808 (LWP 21672) exited]
[New Thread -1249481808 (LWP 21677)]
[Thread -1249481808 (LWP 21677) exited]
[New Thread -1249481808 (LWP 21689)]
[Thread -1249481808 (LWP 21689) exited]
[New Thread -1249481808 (LWP 25026)]
[Thread -1249481808 (LWP 25026) exited]
[New Thread -1249481808 (LWP 25652)]
[Thread -1249481808 (LWP 25652) exited]
[New Thread -1249481808 (LWP 28070)]
[Thread -1249481808 (LWP 28070) exited]
[New Thread -1249481808 (LWP 28079)]
[Thread -1249481808 (LWP 28079) exited]
[New Thread -1249481808 (LWP 28116)]
[Thread -1249481808 (LWP 28116) exited]
[New Thread -1249481808 (LWP 28121)]
Couldn't get registers: No such process.
(gdb) backtrace
Cannot fetch general-purpose registers for thread -1218373440: generic error
Cannot fetch general-purpose registers for thread -1218373440: generic error

Revision history for this message
Justin Hartman (jjhartman) wrote :

I'm attaching all 750+ files that were used to simulate the crash. I uploaded all these files to the FTP server and then selected them all and tried to delete them. After deleting about 150+ files gftp hangs and crashes.

See if these files help you in trying to debug the problem.

Revision history for this message
Justin Hartman (jjhartman) wrote :

Attached is the backtrace file which I had a little more success with. The backtrace seemed to work fine until the application crashed.

Let me know if you need anything further.

Revision history for this message
jhellen (jukka-hellen) wrote :

I can confirm this. I tried to delete all my Joomla.org php-files from a server (about 4Mb).
It crashes every time!

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks, everyone working on "the case". Please try to obtain a backtrace <http://wiki.ubuntu.com/DebuggingProgramCrash> and attach the file to the bug report. This will greatly help us in tracking down your problem.

Áron Sisak (asisak)
Changed in gftp:
importance: Undecided → Low
Revision history for this message
Dafatfab (fabien-ja) wrote :

gftp 2.0.18
ubuntu 6.10

I confirm the problem.
I try to delete one of my egroupware's folder (about 500 sub-folder + 2000 files) :
-> Gftp try to "list" all the files to delete (command LIST -L on the ftp log window) : It crashes everytime (shutdown)

I try to setup the cache memory or something like this but nothing solve the problem

Revision history for this message
Diego Foglino (biker84) wrote :

it's the same for me.
This is my log.

Revision history for this message
Olivier Prieur (mumbly) wrote :

same here : here is the log file ...

Revision history for this message
james cacolac (chaudmail) wrote :

same thing while deleting some directory with many files on remote ftp

Revision history for this message
valtech (valtech) wrote :

Discovered this using SFTP to delete a complete Joomla! folder. gftp window closed wiht no errors or warnings. Not sure of the amount of files processed prior to the crash. Timewise - about 30-40sec.

Revision history for this message
ryanmbruce (ryanmbruce) wrote :

I had the exact same situation as valtech. I was deleting a large number of images with gftp (1,500 or so), and got tired of gftp doing it so slowly, so I sshed in and deleted the folder recursively. Gftp closed immediately with no errors or warnings. I could probably recreate it if you need more information. Let me know if you want me to.

Cheers,
-Ryan

Revision history for this message
Kurt Kraut (kurtkraut) wrote : Same problem in Gutsy

Hi,

i'm getting this segfault when deleting too many files/directories in Gutsy, gtfp 2.0.18-16ubuntu3. This bug is open for a long time, envolves Edgy, Feisty and Gutsy. I think this deserve a better look at it.

Revision history for this message
Áron Sisak (asisak) wrote :

Thanks for raising this again. We need some gftp-expert to fix this.

Changed in gftp:
assignee: asisak → nobody
importance: Low → Medium
status: Incomplete → Confirmed
Revision history for this message
ZequeZ (zequez) wrote :

Hi, my gFTP close itself, when i try to delete directories who have other directories inside...

Sorry for my english =P

Revision history for this message
François (lozach29) wrote :

Exactly the same problem for me with Hardy Heron. Gftp crashes with no error while deleting many files. Does anybody has an issue ?

Revision history for this message
Jignesh Borad (jigneshborad) wrote :

I am unable to recreate this bug. gftp is working just fine on my system. I am able to connect to ftp site, navigate to a folder containing more than 600 files, and able to delete them without any problems.

I am using Hardy - Ubuntu 8.04.1 to check this.

Revision history for this message
Ben Andersen (ben72) wrote :

>Crashed while deleting large amount of files

Same problem here! Segfault when deleting a wordpress installation.

Ubuntu 8.10
gFTP 2.0.18

I'm using bluehost.com and my connection there is not very fast..

Revision history for this message
Daniel James (daniel-64studio) wrote :

Definitely a regression, I'm seeing the problem here, and gFTP has always been able to do this in the past.

Revision history for this message
George DeKatt (georgedekatt) wrote :

Confirmed on Ubuntu Jaunty 9.04, gFTP 2.0.18
Deleting multiple files causes gFTP to hang and eventually exit.

Oct 9 08:51:30 sandbox kernel: [ 1934.864515] gftp-gtk[6411]: segfault at 3c ip 0000003c sp b6ca805c error 4 in gftp-gtk[8048000+44000]

Revision history for this message
Kurt Kraut (kurtkraut) wrote :

This bug is present in Ubuntu since 2007! What can we done to get a fix sooner?

Changed in gftp (Ubuntu):
assignee: nobody → CHRISTYALBY (christyalby)
assignee: CHRISTYALBY (christyalby) → nobody
assignee: nobody → Ubuntu GNOME (ubuntu-gnome)
Revision history for this message
Bruce Pieterse (octoquad) wrote :

Thank you for taking the time to report this bug.

I can confirm that this problem no longer exists on Ubuntu Gnome 14.10 with GFTP 2.0.19. This problem was fixed upstream and the project is now also looking for a maintainer.

Changes from 2.0.18 to 2.0.19

* Fixed several segfaults.
* And more...

See http://gftp.seul.org/changelog.html for more information.

Changed in gftp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers