package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1210525 reported by Fila Kolodny
162
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Gforth
Fix Released
Unknown
gforth (Ubuntu)
Undecided
Unassigned

Bug Description

Initial install

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: gforth 0.7.0+ds2-0.1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Fri Aug 9 09:33:57 2013
DuplicateSignature: package:gforth:0.7.0+ds2-0.1:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-05-23 (77 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: gforth
Title: package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.emacs.site.start.d.50gforth.el:
 (autoload 'forth-mode "gforth" "Mode to edit gforth files" t)
 (autoload 'forth-block-mode "gforth" "major mode for editing Forth block source files." t)
 (autoload 'run-forth "gforth" "Run an inferior Forth process, input and output via buffer *forth*." t)
mtime.conffile..etc.emacs.site.start.d.50gforth.el: 2013-08-08T17:35:13.749193

Revision history for this message
Fila Kolodny (fila) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gforth (Ubuntu):
status: New → Confirmed
Changed in gforth:
status: Unknown → Fix Released
Revision history for this message
deejoe (nyloco) wrote :

There is a Debian bug about this, also:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=689136

and as best I can tell, the fix is to have 02-skip-install-patch skip over building the emacs byte code for gforth.el as per

https://sources.debian.net/src/gforth/0.7.2%2Bdfsg1-1.1/debian/patches/02-skip-install.patch/

Revision history for this message
Peter Schüller (schueller-p) wrote :

Uninstalling gforth helped me to solve the problem - now emacs24 installs without problems.

Revision history for this message
Cesar Quiroz (cesar-quiroz-u) wrote : Re: [Bug 1210525] Re: package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Thanks!

Sent from my iPhone

> On Sep 9, 2015, at 12:13, Peter Schüller <email address hidden> wrote:
>
> Uninstalling gforth helped me to solve the problem - now emacs24
> installs without problems.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1242150).
> https://bugs.launchpad.net/bugs/1210525
>
> Title:
> package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in Gforth:
> Fix Released
> Status in gforth package in Ubuntu:
> Confirmed
>
> Bug description:
> Initial install
>
> ProblemType: Package
> DistroRelease: Ubuntu 13.10
> Package: gforth 0.7.0+ds2-0.1
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic x86_64
> ApportVersion: 2.12-0ubuntu3
> Architecture: amd64
> Date: Fri Aug 9 09:33:57 2013
> DuplicateSignature: package:gforth:0.7.0+ds2-0.1:subprocess installed post-installation script returned error exit status 1
> ErrorMessage: subprocess installed post-installation script returned error exit status 1
> InstallationDate: Installed on 2013-05-23 (77 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
> MarkForUpload: True
> SourcePackage: gforth
> Title: package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
> modified.conffile..etc.emacs.site.start.d.50gforth.el:
> (autoload 'forth-mode "gforth" "Mode to edit gforth files" t)
> (autoload 'forth-block-mode "gforth" "major mode for editing Forth block source files." t)
> (autoload 'run-forth "gforth" "Run an inferior Forth process, input and output via buffer *forth*." t)
> mtime.conffile..etc.emacs.site.start.d.50gforth.el: 2013-08-08T17:35:13.749193
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gforth/+bug/1210525/+subscriptions

Revision history for this message
Remy Dyer (remydyer) wrote :

Still broken in Ubuntu 14.04.3 LTS, but fixed in 15.10 because it's been fixed by upstream, and the newer upstream version doesn't suffer this.

Is this the right place to ask why LTS still hasn't updated to resolve this issue?

Revision history for this message
Cesar Quiroz (cesar-quiroz-u) wrote :

No idea (I am an innocent bystander). On the other hand, I understand LTS
as long-term stagnation. I upgrade my machines every six months, and
update them every day... I assume LTS will remain broken for five years,
so your best bet is to upgrade as soon as 16.04 is out.

--César

On Wed, Feb 3, 2016 at 4:24 PM, Remy Dyer <email address hidden> wrote:

> Still broken in Ubuntu 14.04.3 LTS, but fixed in 15.10 because it's been
> fixed by upstream, and the newer upstream version doesn't suffer this.
>
> Is this the right place to ask why LTS still hasn't updated to resolve
> this issue?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1242150).
> https://bugs.launchpad.net/bugs/1210525
>
> Title:
> package gforth 0.7.0+ds2-0.1 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in Gforth:
> Fix Released
> Status in gforth package in Ubuntu:
> Confirmed
>
> Bug description:
> Initial install
>
> ProblemType: Package
> DistroRelease: Ubuntu 13.10
> Package: gforth 0.7.0+ds2-0.1
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic x86_64
> ApportVersion: 2.12-0ubuntu3
> Architecture: amd64
> Date: Fri Aug 9 09:33:57 2013
> DuplicateSignature: package:gforth:0.7.0+ds2-0.1:subprocess installed
> post-installation script returned error exit status 1
> ErrorMessage: subprocess installed post-installation script returned
> error exit status 1
> InstallationDate: Installed on 2013-05-23 (77 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64
> (20130424)
> MarkForUpload: True
> SourcePackage: gforth
> Title: package gforth 0.7.0+ds2-0.1 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
> modified.conffile..etc.emacs.site.start.d.50gforth.el:
> (autoload 'forth-mode "gforth" "Mode to edit gforth files" t)
> (autoload 'forth-block-mode "gforth" "major mode for editing Forth
> block source files." t)
> (autoload 'run-forth "gforth" "Run an inferior Forth process, input and
> output via buffer *forth*." t)
> mtime.conffile..etc.emacs.site.start.d.50gforth.el:
> 2013-08-08T17:35:13.749193
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gforth/+bug/1210525/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.