getmail4 uses deprecated pyhton module

Bug #350161 reported by Thomas Neumann on 2009-03-28
88
This bug affects 13 people
Affects Status Importance Assigned to Milestone
getmail4 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Katherine Rossiter
Nominated for Karmic by Katherine Rossiter
Nominated for Lucid by Alvin

Bug Description

Binary package hint: getmail4

getmail4 uses the deprecated "sets" module, which triggers a warning in jaunty. Executing getmail produces the warning

/usr/share/getmail4/getmailcore/baseclasses.py:26: DeprecationWarning: the sets module is deprecated
  import sets

which is quite inconvenient when calling getmail from a cron job.

This issues has been discussed here

http://news.gmane.org/find-root.php?message_id=%3c20090307024237.GB25606%40kuro%2ddesktop%3e

together with a proposed patch.that preserves compatibility with older Python versions. A 2.6 only patch is proposed here

http://www.oldspeak.org/2008/11/02/getmail-484-with-python-26-deprecated-imports

Katherine Rossiter (signe) wrote :

This can also be fixed by updating to the latest getmail package, 4.9. It specifically corrects this problem.

http://pyropus.ca/software/getmail/
http://pyropus.ca/software/getmail/CHANGELOG

Todd Bradshaw (snooptodd) wrote :

fix released upstream, that confirms it

Changed in getmail4 (Ubuntu):
status: New → Confirmed
Shahar Or (mightyiam) wrote :

Dear friends,

Will this be fixed in jaunty, please?

Many blessings.

cpthk (cpthk) wrote :

Hi:

I am also encounter this problem, I am waiting for like almost two years for ubuntu to upgrade it.
Is there anyone actually working on upgrading getmail package to a newer version? The version ubuntu has is really really old already. And I found that ubuntu has not upgrade getmail for like passing three versions. I don't understand why it takes that long.

Matthias Rosenkranz (rose) wrote :

Hello,

I have uploaded the current upstream version of getmail4 to my PPA at https://launchpad.net/~rose/+archive/ppa. This version fixes the deprecated module message and I would encourage people to try it out. Please let me know if there are any problems with the packaging since this is my first PPA upload. I am still trying to figure out how to get the package built for karmic on the PPA system (currently it's jaunty only).

Install the PPA:
  echo "deb http://ppa.launchpad.net/rose/ppa/ubuntu jaunty main" | sudo tee -a /etc/apt/sources.list
Install PPA key:
  sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 4F4F6E4D
Update packages:
  sudo apt-get update
Install updated getmail4:
  sudo apt-get install getmail4

yknip (spam-highway15) wrote :

Installed flawlessly and appears to work as advertised. Thank you!

Jalfrock (jalfrock) wrote :

FYI, I still get this installing from universe in Karmic. Anyone have any idea if/when getmail might be moved from universe to main? Thanks for all your work, guys!

dah bien-hwa (dahbien-hwa) wrote :

I just stumbled about these messages too; it obviously isn't really life-threatening, but is there any chance this is getting fixed in the near future?

dah bien-hwa (dahbien-hwa) wrote :

Oh, forgot to mention, I'm on karmic too.

randall (randall-redigital) wrote :

this worked great on 8.04-LTS

osamu (osamu) wrote :

This bug was fixed upstream with a fix which upstream thought better than the patch mentioned above at Version 4.9.0 on 5 April 2009.
  -eliminate deprecation warning for sets module with Python 2.6 by using a compatibility wrapper module.

Thus Lucid or newer are not affected. I am not quite sure if I should close this bug like Debian or we need to wait for some one upload backported packages. But karmic is old...

(I do not know when Ubuntu did python2.6 transition which triggered this. )

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers