Can't find mbrola voices in standard install path

Bug #919577 reported by aleritty on 2012-01-21
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gespeaker (Ubuntu)
Undecided
Muflone

Bug Description

I installed gespeaker and mbrola voices (en1, it3, it4).
Mbrola voices are installed with default path in /usr/share/mbrola/[en1|it3|it4]

From Gespeaker options the default location in the menu is "/usr/share" and from that the program can't find voices.
If I change the location in "/usr/share/mbrola" it's still impossible to find the voices.

Gespeaker need to be pre-setted in oneiric with the right value to find mbrola voices

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gespeaker (Ubuntu):
status: New → Confirmed
Jeffrey Tees (jeff-tees) wrote :

This is still an issue in 13.04.
Installed mbola along wiith gespeaker, then en1, us1, us2.

Path to mbrola voices not correctly set in gespeaker, corrected to /usr/share/mbrola, path does not show in box and even after clicking refresh, gespeaker fails to pick up the voices.

Hanky (hankschwie) wrote :

stilll true in 14.04

Muflone (il-muflone) wrote :

Here's the Gespeaker author.

The default path for mbrola voices in Gespeaker 0.8 is /usr/share/mbrola which defaults to /usr/share if no mbrola voices were found. It could happen that you open the preferences dialog and save them before you install any mbrola voice, in such case the path is saved under /usr/share instead of /usr/share/mbrola.

Please open an issue on the official github tracker: https://github.com/muflone/gespeaker/issues
and include:
a) your OS and its version
b) the package version used
c) the place where the mbrola voices can be found
d) the vesion of mbrola
e) the version of espeak

Muflone (il-muflone) wrote :
maksim (kaszynski) wrote :

Hi everyone,
I realise that this is not a forum, however this is the first link that google gives when searching for this problem.

The version from Ubuntu 14.04 repo (0.8.2-1) does not load mbrola voices because it needs additional espeak data folder to be present. That is, /usr/share/espeak-data.
The actual location of this folder is however different: /usr/lib/x86_64-linux-gnu/espeak-data or /usr/lib/i386-linux-gnu/espeak-data, depending on your arch.

This issue can be fixed either by installing the latest (0.8.4+) Gespeaker from source code, or by creating a symlink to usr/share/espeak-data to point to one of the aforementioned directories, i.e.
sudo ln -s /usr/lib/x86_64-linux-gnu/espeak-data /usr/share/espeak-data

Hope this helps,
Maksim

^^This is why people are reluctant to switch to Linux. @il-muflone, this bug has been persistent since 11.04. I'm on 14.04 and no fix has been in the official Canonical repos YET??? I'm a girl Ubuntu evangelist, I tell people how great Linux is over Windows or Mac, yet minor problems like this, I am the one who gets blamed. </rant>

If I would, this status would have been set to Critical...

There needs to be an easier workaround. None of these fixes are working.

Muflone (il-muflone) wrote :

<rant reply>
This is the reason because developers abandon bad distributions like Ubuntu with extreme long times for package updates and bad support for new available versions of the applications. As an evangelist you should always tell people the truth, including the various reasons to avoid Ubuntu.
Oh and always remember to your friends that Linux is not Ubuntu.
</rant reply>

This issue was fixed long time ago in Debian with Gespeaker 0.8.2-2, unfortunately the Ubuntu repositories still have the 0.8.2-1 version which suffers the issue. The latest available version of Gespeaker is 0.8.5-1.

I'm not familiar with the Ubuntu packaging world, the fix was already released on Debian, who could/should and how such fix could be included in Ubuntu package?

Muflone (il-muflone) wrote :

Fixed in version 0.8.6

Changed in gespeaker (Ubuntu):
assignee: nobody → Muflone (il-muflone)
status: Confirmed → Fix Released
vishal (prajapatishiva007) wrote :

I have successfully run text to speech java program but cannot listen voice of given string(text input).
 can any one help me please..

Anthony (danthonyd) wrote :

Fixed!!!

Thanks to Maksim for posting the above fix with the symlink:
sudo ln -s /usr/lib/x86_64-linux-gnu/espeak-data /usr/share/espeak-data

I can now access the variant voices, found in tab {Preferences->Mbrola Voices}. I searched all over the internet, and attempted several installation varieties, and finally (FINALLY!!!) this solved the problem.

I am running version 0.8.2 and yes, I tried to install 0.8.6 but ran into errors. Perhaps I missed some step in the installation instructions.... I don't know, and frankly I don't care because it was compounding my problems.

Thank you Maksim!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers