Doesn't support relative paths

Bug #1010186 reported by Sjoerd Simons on 2012-06-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
germinate (Ubuntu)
Wishlist
Colin Watson

Bug Description

Germinate handles bzr urls and normal urls, but not relative filesystem paths which can be a bit inconvenient at times. Attached patch makes it assume the seed path is a normal path if there is no scheme name.

Patch is against the bzr version of germinate.

Sjoerd Simons (sjoerd) wrote :
Sjoerd Simons (sjoerd) wrote :

Updated patch. the previous one breaks the test :/

The attachment "Proposed patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Colin Watson (cjwatson) wrote :

Thanks for the patch! I cleaned up some style issues (PEP-8 is worth following, in general), made it use urlparse rather than the undocumented splittype, and added a test. This will be in germinate 2.11.

Changed in germinate (Ubuntu):
status: New → Fix Committed
importance: Undecided → Wishlist
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package germinate - 2.11

---------------
germinate (2.11) unstable; urgency=low

  * Use collections.defaultdict instead of manually initialising elements.
  * Simplify some sorted() calls, relying on the default iterator for
    mappings being .keys().
  * Simplify code to clean up bzr cache, removing an unnecessary helper
    function.
  * Add support for reading seeds from relative filesystem paths (thanks,
    Sjoerd Simons; LP: #1010186).
  * Only allow dh_python2 to operate on python-germinate, to avoid chaos
    caused by shebang rewriting.

 -- Colin Watson <email address hidden> Tue, 18 Sep 2012 10:12:41 +0100

Changed in germinate (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers