Default setting of zh_CN locale incorrect

Bug #517621 reported by Aron Xu on 2010-02-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GeoIP
Unknown
Unknown
geoip (Ubuntu)
Medium
Unassigned
pkgsel (Ubuntu)
Undecided
Colin Watson
ubiquity (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: ubiquity

Default time zone should be Asia/Shanghai but now Asia/Chongqing, and default keyboard layout is China - China but now USA.

By default, when a user choosing zh_CN locale, he will get both zh-hans and zh-hant language packs installed, but since they are separated, I think we can make a change on this and let users of zh_CN locale only have zh-hans set and zh_TW locale zh-hant.

Colin Watson (cjwatson) wrote :

The timezone is probably detected by GeoIP; is Chongqing reasonably close to where you live?

The keyboard layout is intentional, as XKB does not have a Chinese layout defined anyway.

The only thing here I see as an actual bug is the language pack handling; I agree it would be nice to refine this.

Aron Xu (happyaron) wrote :

For zh_CN users, the only timezone be used by defaut (I mean which is not set by the user on his/her purpose) should be Asia/Shanghai as it is set by the government to its national standard time (the governmental definition is Beijing, but it looks the same as Asia/Shanghai, I am not sure whether Asia/Chongqing has the same timezone setting, UTC +0800).

Colin Watson (cjwatson) on 2010-02-10
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Changed in pkgsel (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkgsel - 0.25ubuntu5

---------------
pkgsel (0.25ubuntu5) lucid; urgency=low

  [ Evan Dandrea ]
  * Provide a way to avoid warning the end user when the language packs
    could not be installed (LP: #471553).

  [ Colin Watson ]
  * Install zh-hans language packs for zh_CN, and zh-hant language packs for
    zh_TW (LP: #517621).
 -- Colin Watson <email address hidden> Wed, 10 Feb 2010 09:56:22 +0000

Changed in pkgsel (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

They're the same timezone anyway so this is largely cosmetic, but I've asked the people who run our GeoIP server to look into this.

However, if Asia/Chongqing shouldn't be used, then why is it listed in /usr/share/zoneinfo/zone.tab? As far as I know, that file is only supposed to list timezones that are currently in use; for instance, it lists Europe/London but not Europe/Belfast. If you think everyone should be using Asia/Shanghai for China and preferably can supply a reference, then please contact tzdata upstream (<email address hidden>); they frequently take corrections from local experts, and this is the best way to get fixes deployed in many different operating systems.

Aron Xu (happyaron) wrote :

In worldwide computer technology field, most time Chinese use Asia/Shanghai, but according to the national statement, our time is defined to Asia/Beijing, though they might be in the same timezone.

Colin Watson (cjwatson) wrote :

Please discuss this with the tzdata upstream folks, as I indicated earlier - this isn't something we're going to modify in an Ubuntu-specific way, but this data undergoes frequent revisions upstream. They are much better-qualified to discuss this than we are.

Aron Xu (happyaron) wrote :

anyway thanks!

Colin Watson (cjwatson) wrote :

Oh my. I thought it would come from zone.tab, but I was wrong. Apparently geoip has its own hardcoded list of country->timezone mappings embedded in C code, which includes:

  else if ( strcmp (country, "CN") == 0 ) {
    timezone = "Asia/Chongqing";
  }

I'll open a bug task on geoip to indicate that this should change to Asia/Shanghai. Note that, in order to be effective, somebody will have to coordinate with the Canonical sysadmins to get the patch applied on geoip.ubuntu.com as well; I'm happy to do this if somebody gives me a nudge (e.g. on IRC).

Changed in geoip (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

I've forwarded this upstream.

In answer to your comments about Beijing: Asia/Beijing doesn't exist in the standard tz database. Asia/Shanghai appears to cover this region. I'm not sure there's any need to rename this, since renaming timezones is a somewhat involved process and echoes of the old name tend to stay around nearly forever anyway.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.17

---------------
ubiquity (2.1.17) lucid; urgency=low

  [ Mario Limonciello ]
  * debian/oem-config.postinst:
    - Source debconf to ensure templates are populated in debconf.
  * Drop update-rc.d calls from oem-config scripts as it's only supported
    via upstart now.
  * misc: return True/False from execute_root rather than None.

  [ Evan Dandrea ]
  * Use a GtkSpinner instead of a separate progress window when on the
    manual partitioning page.

  [ Colin Watson ]
  * In cdebconf mode, initialise the templates database if necessary as a
    workaround for cdebconf's packaging not doing this itself.
  * Don't issue PROGRESS REGION command under debconf_ui (LP: #519398).
  * KDE frontend:
    - Don't add partition bar frames for devices we can't find for whatever
      reason (LP: #485450).
  * Pass model, layout, variant, and options to rewrite_xorg_conf
    (LP: #514646).
  * Install zh-hans language packs for zh_CN, and zh-hant language packs for
    zh_TW (LP: #517621).
  * Fix crash on keyboard variant selection (LP: #512953).
  * Enable cancellation of NTP syncing.
  * Correct tuple syntax in copy_debconf, thereby fixing copying of
    console-setup's debconf questions.
  * Fix unmount of /target/dev harder; second and subsequent arguments to
    os.path.join need to not start with a slash.
  * Automatically fall back to vesa if normal X startup fails. This is a
    reduced emulation of bullet-proof-X; using the standard implementation
    is currently tricky.
  * Add a couple of lintian overrides.
  * Explicitly build-depend on xkb-data-i18n. We normally skip
    console-setup's build-dependencies when generating our own, but we need
    this one to run kbdnames-maker.
  * Update translations from Launchpad (LP: #473554, #520905).
  * Automatic update of included source packages: base-installer
    1.103ubuntu3, console-setup 1.34ubuntu9, debian-installer-utils
    1.72ubuntu3, grub-installer 1.49ubuntu4, hw-detect 1.73ubuntu2,
    partman-auto 89ubuntu3, partman-basicfilesystems 63ubuntu3,
    partman-partitioning 72ubuntu3, tzsetup 1:0.26ubuntu5.
 -- Colin Watson <email address hidden> Fri, 12 Feb 2010 21:07:51 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Aron Xu (happyaron) wrote :

Hi, this bug is reproducible in the installer of 12.04.*, 12.10 and current 13.04 daily images.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.