Built in Geogebra update tool should be disabled

Bug #952072 reported by Greg A on 2012-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
geogebra (Debian)
Fix Released
Undecided
Unassigned
geogebra (Ubuntu)
Undecided
Unassigned

Bug Description

"A newer version of Geogebra is available. Would you like to get Geogebra 4.0.24.0 now?"

This message should probably be disabled within the packaged Ubuntu/Devian environment.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: geogebra 4.0.19.0+dfsg1-4
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sun Mar 11 08:41:14 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120112)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: geogebra
UpgradeStatus: Upgraded to precise on 2012-03-10 (0 days ago)

Related branches

Greg A (etulfetulf) wrote :
Giovanni Mascellani (giomasce) wrote :

I agree, but cannot reproduce this dialog (I'm using Debian sid, but the packages should be identical). Under which condition does this dialog appear? Just after you open geogebra?

Giovanni.

Greg A (etulfetulf) wrote :

It was after installing Geogebra and running it for the first time. However I am now unable to reproduce the dialog!

Giovanni Mascellani (giomasce) wrote :

I got it: it asks only the first time opening geogebra. To reproduce, you have to delete the local preferences:

rm -fr .java/.userPrefs/geogebra40/

Disabling this shouldn't be difficult, I'll do ASAP.

Giovanni Mascellani (giomasce) wrote :

This has been fixed in 4.0.19.0+dfsg1-5.

Changed in geogebra (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package geogebra - 4.0.19.0+dfsg1-5

---------------
geogebra (4.0.19.0+dfsg1-5) unstable; urgency=low

  * Do not display a warning if GeoGebra version is old (LP: #952072).

 -- Giovanni Mascellani <email address hidden> Mon, 12 Mar 2012 00:28:32 +0100

Changed in geogebra (Ubuntu):
status: New → Fix Released
Greg A (etulfetulf) wrote :

Thanks Giovanni, you have handled this bug report very impressively!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers