geogebra needs updating to version 5

Bug #1574357 reported by Jakob Lund on 2016-04-24
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
geogebra (Ubuntu)
Wishlist
Unassigned

Bug Description

The version in ubuntu is several years old. Version 5 adds important functionality to the program. Geogebra is open source. GeoGebra is used in education.

Revision history for this message
Giovanni Mascellani (giomasce) wrote :

That would be nice. I am the Debian maintainer for the package, but have been unable to work effectively on it lately. There are also a few problems connected with licensing, freeness and redistribution. In particular, for sure GeoGebra is not free (as in free software) at the moment, since some components (i18n, help files, ...) have a noncommercial clause. It might still be redistributable, and thus finish in Debian contrib/non-free and Ubuntu multiverse, however that requires some careful checking as well. GeoGebra has a lot of dependencies, some of which are very old software or with rather unclear licensing. A lot of it is LGPL or Apache, which probably cause no problems, but there might also be a few things that are under GPL. That might be problematic, because the GPL-ed code would effectively be distributed and used together with the nonfree components I said above.

A list of the dependencies of GeoGebra is here: https://dev.geogebra.org/trac/wiki/SourcesForUsedLibraries. However there are good reasons to believe the list to be both incorrect (OpenGeoProver is considered GPL3, but nothing in the original repository supports this speculation) and incomplete (there is a generic "Others" point at the end). So it must be fixed in order to assess what can be done with GeoGebra at the moment.

tags: added: upgrade-software-version
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in geogebra (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Pollak (robert-pollak) wrote :

I think this bug should be closed as WONTFIX, because now GeoGebra even considers itself non-free:

"""
Please note that GeoGebra as a complete software program would
probably not be considered "free" software according to the
definition of that term which is used by the Free Software
Foundation. This is because the restrictions on commercial use that
apply to the GeoGebra installers, web services and language files
add-ons might be seen to be a restriction on the software as a whole
(thus making it "non-free"), even though the GeoGebra source code is
made available under the GNU General Public License without
restriction.
""" (https://www.geogebra.org/license)

Changed in geogebra (Ubuntu):
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers