package geoclue-2.0 2.4.7-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1784690 reported by anony on 2018-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
geoclue-2.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Crash report generated

ProblemType: Package
DistroRelease: Ubuntu 17.10
Package: geoclue-2.0 2.4.7-1ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-46.51-generic 4.13.16
Uname: Linux 4.13.0-46-generic i686
ApportVersion: 2.20.7-0ubuntu3.9
Architecture: i386
Date: Wed Jul 25 07:45:26 2018
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-10-19 (1016 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu3
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
RelatedPackageVersions:
 dpkg 1.18.24ubuntu1
 apt 1.5.2
SourcePackage: geoclue-2.0
Title: package geoclue-2.0 2.4.7-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

anony (anonyiam) wrote :
Alex Murray (alexmurray) wrote :

It failed to install since there was no available group ID to create:

addgroup: No GID is available in the range 100-999 (FIRST_SYS_GID - LAST_SYS_GID).
addgroup: The group `geoclue' was not created.

Have you got a large number of groups in your system?

information type: Private Security → Public

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

tags: removed: need-duplicate-check

This issue goes back to when you could use guest mode, but guest mode
developed this issue so you have these large number of groups causing this
error message.

Can't you test and package the following solution into the operating system
and de-bug it:

https://askubuntu.com/questions/979467/esoteric-error-logs-in-ubuntu-17-10

On 8/1/18, Alex Murray <email address hidden> wrote:
> It failed to install since there was no available group ID to create:
>
> addgroup: No GID is available in the range 100-999 (FIRST_SYS_GID -
> LAST_SYS_GID).
> addgroup: The group `geoclue' was not created.
>
> Have you got a large number of groups in your system?
>
> ** Information type changed from Private Security to Public
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1784690
>
> Title:
> package geoclue-2.0 2.4.7-1ubuntu1 failed to install/upgrade:
> subprocess installed post-installation script returned error exit
> status 1
>
> Status in geoclue-2.0 package in Ubuntu:
> New
>
> Bug description:
> Crash report generated
>
> ProblemType: Package
> DistroRelease: Ubuntu 17.10
> Package: geoclue-2.0 2.4.7-1ubuntu1
> ProcVersionSignature: Ubuntu 4.13.0-46.51-generic 4.13.16
> Uname: Linux 4.13.0-46-generic i686
> ApportVersion: 2.20.7-0ubuntu3.9
> Architecture: i386
> Date: Wed Jul 25 07:45:26 2018
> ErrorMessage: subprocess installed post-installation script returned
error
> exit status 1
> InstallationDate: Installed on 2015-10-19 (1016 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386
> (20140417)
> Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal,
> 3.6.3-0ubuntu3
> PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal,
> 2.7.14-2ubuntu1
> RelatedPackageVersions:
> dpkg 1.18.24ubuntu1
> apt 1.5.2
> SourcePackage: geoclue-2.0
> Title: package geoclue-2.0 2.4.7-1ubuntu1 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/geoclue-2.0/+bug/1784690/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers