Ubuntu

genshi 0.6-2ubuntu1 FTBFS on amd64 in raring

Reported by Robie Basak on 2013-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
genshi (Ubuntu)
High
Unassigned

Bug Description

Also affects genshi 0.6-3 in sid, which should be able to be synced as the entire Ubuntu delta has been taken up in Debian.

The problem is that raring's python2.7 incorporates changeset http://hg.python.org/cpython/rev/eb7ea51e658e/ which changed the definition of tokenize.PseudoToken which genshi depends on. This causes an infinite loop in genshi's test suite.

Reported upstream at http://genshi.edgewall.org/ticket/540

Workaround: change the definition of PseudoToken in genshi.template.interpolation to be hardcoded to what Python defined it as before (eg. from quantal). This seems to work and I have a patch, but I'd like to hear what upstream think about it or if there is a better fix.

In the meantime, genshi will also FTBFS due to what I think is a Python regression which I'll report separately, so might as well hold off on a fix until that is resolved.

Robie Basak (racb) on 2013-01-09
Changed in genshi (Ubuntu):
status: New → Triaged
importance: Undecided → High
Robie Basak (racb) wrote :

Second cause of this FTBFS is a possible Python regression in bug 1097783.

tags: added: ftbfs raring
Robie Basak (racb) wrote :

Bug 1097783 is now fixed in raring, so just this issue remains. I've updated upstream and am waiting to hear back from them. Unless they have a better suggestion or an objection, hardcoding the old definition of PseudoToken in a patch makes sense to me.

Robie Basak (racb) wrote :

Fix attached. This includes a merge which drops the previous Ubuntu delta since both previous patches have been adopted in Debian and these are Debian's only changes. But this fix introduces a new one.

Robie Basak (racb) wrote :
Robie Basak (racb) wrote :

The attachment "debian_ubuntu.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package genshi - 0.6-3ubuntu1

---------------
genshi (0.6-3ubuntu1) raring; urgency=low

  * Merge from Debian unstable. Remaining changes: none.
  * Dropped, adopted in Debian:
    + debian/rules: build should fail if tests fail.
    + debian/patches/fix_tests_failure_with_python27.patch:
      - Fix tests which used to fail with python < 2.7.3. Thanks to Barry
        Warsaw. Closes: #661441.
  * debian/patches/python_tokenize_upstream_change.patch: fix FTBFS triggered
    by an upstream Python 2.7 hg tip change (LP: #1097776).

genshi (0.6-3) unstable; urgency=low

  * debian/rules: build should fail if tests fail.
  * debian/patches/fix_tests_failure_with_python27.patch:
    + Fix tests which used to fail with python < 2.7.3. Thanks to Barry Warsaw.
      Closes: #661441.
 -- Robie Basak <email address hidden> Mon, 28 Jan 2013 11:32:14 +0000

Changed in genshi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers