gem unable to load library (undefined symbol)

Bug #883534 reported by Sébastien Roy on 2011-10-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
PureData
Unknown
Unknown
gem (Ubuntu)
Undecided
Unassigned

Bug Description

Gem reports undefined symbols on Ubuntu 11.10, after a simple installation of package gem (version 1:0.92.3-2)

Running pd-gem displays:

/usr/lib/pd/extra/Gem/Gem.pd_linux: /usr/lib/pd/extra/Gem/Gem.pd_linux: undefined symbol: _ZN6Magick5ImageC1EmmRKSsN10MagickCore11StorageTypeEPKv
/usr/lib/pd/extra/Gem/Gem: can't load library

I do have the standard packages "libmagickcore3" (8:6.6.0.4-3ubuntu1) and "libmagickcore3-extra" (8:6.6.0.4-3ubuntu1) installed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gem (Ubuntu):
status: New → Confirmed
mihow (mihow) on 2012-02-02
tags: added: gem pd puredata
no longer affects: puredata
mihow (mihow) wrote :

Relevant response from the bug tracker at sourceforge:

is that the ordinary ubuntu packages for "puredata" and "gem"?
you might want to upgrade those packages as wellpackages.
e.g. "precise" has an updated "gem" package (0.92.3-2build1) rebuilt for
libmagickcore4, which will most likely fix your problem.

also, dependency tracking is one thing that distros like debian (and
ubuntu) are about: so this bug is about packaging and should therefore have
been reported at the ubuntu bug-tracker.

http://sourceforge.net/tracker/?func=detail&atid=478070&aid=3481366&group_id=55736

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.