Accidental ABI break in gtkmm 2.18.1

Bug #441453 reported by Miguel Martinez on 2009-10-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gelemental (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
gtkmm2.4 (Ubuntu)
High
Sebastien Bacher
Karmic
High
Sebastien Bacher

Bug Description

Binary package hint: gelemental

This is a clear regression from jaunty. Whenever I click on an element in the periodic table shown by gelemental, instead of seeing the element's various properties gelemental crashes.

The terminal output I get after the crash is the following:

$ gelemental
gelemental: symbol lookup error: gelemental: undefined symbol: _ZNK3Gtk6Widget9can_focusEv

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 3 17:22:41 2009
DistroRelease: Ubuntu 9.10
Package: gelemental 1.2.0-3ubuntu1
ProcEnviron:
 LANGUAGE=es_ES.UTF-8
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: gelemental
Uname: Linux 2.6.31-11-generic x86_64

Miguel Martinez (el-quark) wrote :
Cesare Tirabassi (norsetto) wrote :

Since we will release karmic soon I patched the source to fix this error (there is a new API method to be used for the can_focus property since gtkmm 2.18). I can't guarantee though that there aren't other things like this lurking in the code, so this needs definetively to be passed upstream.

Changed in gelemental (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gelemental - 1.2.0-3ubuntu2

---------------
gelemental (1.2.0-3ubuntu2) karmic; urgency=low

  * debian/patches/fix_gtkmm_2.18.dpatch: Added (LP: #441453).
    - can_focus() has been deprecated for gtkmm >= 2.18 in favour of a
      new get_can_focus() method.
  * debian/patches/00list, debian/control: updated IAW the patch.

 -- Cesare Tirabassi <email address hidden> Sat, 03 Oct 2009 20:54:17 +0200

Changed in gelemental (Ubuntu):
status: Fix Committed → Fix Released
Cesare Tirabassi (norsetto) wrote :

I'm opening an gtkmm2.4 task since this is obviously a bug in there. Nothwistanding the fact that there is a clear api/abi change they haven't bumped the soname. As a matter of fact, they use:

AC_SUBST([LIBGTKMM_SO_VERSION], [1:30:0])

Which was:

LIBGTKMM_SO_VERSION=1:30:0
AC_SUBST(LIBGTKMM_SO_VERSION)

In 2.16.0, so, this is likely to break other applications.

Murray Cumming (murrayc) wrote :

This unintentional ABI brreak was fixed in the latest gtkmm tarball. Sorry.

Miguel Martinez (el-quark) wrote :

I'd like to thank Cesare for his quick efforts. They are very much appreciated. I also suppose we'll see an updated gtkmm package soon, so don't worry too much, Murray.

Cesare Tirabassi (norsetto) wrote :

Thanks Murray, I'm setting this as fix commited then, with reference to this commit:

http://git.gnome.org/cgit/gtkmm/commit/?id=bf601e53904ff543309ae597f32a928776b6d3e7

Changed in gtkmm2.4 (Ubuntu):
status: New → Fix Committed
Daniel Elstner (daniel-elstner) wrote :

So... will Karmic ship with the fixed gtkmm 2.18.2 then?

summary: - [karmic] gelemental crashes after clicking on any element
+ Accidental ABI break in gtkmm 2.18.1
Daniel Elstner (daniel-elstner) wrote :

The problem has been fixed upstream, but I don't think the "Fix committed" status applies to gtkmm2.4 (Ubuntu), yet. This is a serious ABI breakage and the gtkmm2.4 package should be upgraded to 2.18.2 before the final release of Karmic, if at all possible.

Changed in gtkmm2.4 (Ubuntu):
status: Fix Committed → Confirmed

Could someone with the necessary rights please raise this to super-duper-critical?

Murray Cumming (murrayc) wrote :

I think it's normal and correct here to use "Fix committed" when it has just been committed upstream. Yes, I find that weird too.

Changed in gtkmm2.4 (Ubuntu):
status: Confirmed → Fix Committed
Changed in gtkmm2.4 (Ubuntu Karmic):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in gtkmm2.4 (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Sebastien Bacher (seb128) wrote :

2.18.2 has been uploaded to karmic now

Changed in gtkmm2.4 (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers