evince crashed with SIGSEGV in geis_filter_delete()

Bug #1152411 reported by Yan Chakht
134
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Geis
High
Stephen M. Webb
geis (Ubuntu)
Medium
Stephen M. Webb

Bug Description

crashed trying to open a pdf file

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: evince 3.6.1-1ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-10.19-generic 3.8.2
Uname: Linux 3.8.0-10-generic x86_64
ApportVersion: 2.9-0ubuntu2
Architecture: amd64
Date: Thu Mar 7 20:57:24 2013
Disassembly: => 0x3fd9999a: Cannot access memory at address 0x3fd9999a
ExecutablePath: /usr/bin/evince
InstallationDate: Installed on 2012-11-25 (102 days ago)
InstallationMedia: Xubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120817.3)
MarkForUpload: True
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-3.8.0-10-generic root=UUID=0b02427c-d976-4713-b3aa-4ffd6681235e ro recovery nomodeset
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x3fd9999a: Cannot access memory at address 0x3fd9999a
 PC (0x3fd9999a) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: evince
StacktraceTop:
 ?? ()
 geis_filter_delete () from /usr/lib/x86_64-linux-gnu/libgeis.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/libgeis.so.1
 geis_subscription_remove_filter () from /usr/lib/x86_64-linux-gnu/libgeis.so.1
 geis_unsubscribe () from /usr/lib/x86_64-linux-gnu/libgeis.so.1
Title: evince crashed with SIGSEGV in geis_filter_delete()
UpgradeStatus: Upgraded to raring on 2013-01-21 (45 days ago)
UserGroups: adm cdrom dip kismet lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
Yan Chakht (yanc666) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? ()
 geis_filter_delete (filter=0x7f388be41960) at geis_filter.c:367
 geis_filter_delete (filter=0x7f388be41960) at geis_filter.c:360
 geis_filter_bag_remove (bag=0x7f388be2f650, filter=<optimized out>) at geis_filter.c:226
 geis_subscription_remove_filter (sub=0x7f388be2f5f0, filter=<optimized out>) at geis_subscription.c:545

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in evince (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evince (Ubuntu):
status: New → Confirmed
information type: Private → Public
affects: evince (Ubuntu) → geis (Ubuntu)
Stephen M. Webb (bregma)
Changed in geis:
status: New → Triaged
Stephen M. Webb (bregma)
Changed in geis:
assignee: nobody → Stephen M. Webb (bregma)
Changed in geis (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)
Changed in geis:
importance: Undecided → High
Stephen M. Webb (bregma)
Changed in geis:
status: Triaged → In Progress
Changed in geis (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:geis at revision None, scheduled for release in geis, milestone Unknown

Changed in geis:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package geis - 2.2.15daily13.04.01-0ubuntu1

---------------
geis (2.2.15daily13.04.01-0ubuntu1) raring; urgency=low

  [ Stephen M. Webb ]
  * evince crashed with SIGSEGV in geis_filter_delete() (LP: #1152411)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 307
 -- Ubuntu daily release <email address hidden> Mon, 01 Apr 2013 02:01:56 +0000

Changed in geis (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma)
Changed in geis:
milestone: none → 2.2.16
Stephen M. Webb (bregma)
Changed in geis:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers