geeqie-standard crashes on start with SIGSEGV in editor_command_parse() when unity-lens-photos is installed

Bug #1056532 reported by Rocko on 2012-09-26
242
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Photos Lens
High
David Callé
geeqie (Ubuntu)
High
Unassigned
unity-lens-photos (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Geeqie looks into desktop files to search for graphics applications, but crashes when it encounters a desktop file for a graphic app without the "Exec=" line. The Photos lens doesn't have this "Exec=" line because it shoudln't appear (for obvious reasons) as an app in the Applications lens.

[Impact]
Geeqie crashes at startup because of unity-lens-photos.desktop.
Removing the Graphics category from the desktop file allows Geeqie to start.

[Test case]
1. Ensure you have the Photos lens (unity-lens-photos) installed
2. Open Geeqie.
Geeqie should not crash.

[Regression potential]
Minimal (desktop file Categories edition)

[Original description]
geeqie segfaults whenever I run it. In this crashlog, I just ran the command 'geeqie' from gnome-terminal. I had just done a "sudo apt-get --reinstall install geeqie" to see if this would fix it.

Workaround: deinstall the unity-lens-photos package from the system.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: geeqie 1:1.0-10.1build1
Uname: Linux 3.6.0-rc7-git-20120924.1005 x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Wed Sep 26 09:05:37 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/geeqie-standard
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcCmdline: geeqie
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 LANGUAGE=en_AU:en
SegvAnalysis:
 Segfault happened at: 0x44734a: movsbl 0x0(%rbp),%edx
 PC (0x0044734a) ok
 source "0x0(%rbp)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: geeqie
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: geeqie-standard crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm lpadmin sambashare sudo

Related branches

Rocko (rockorequin) wrote :

StacktraceTop:
 editor_command_parse (editor=editor@entry=0x2413800, list=list@entry=0x0, consider_sidecars=consider_sidecars@entry=0, output=output@entry=0x0) at ../../src/editors.c:761
 editor_read_desktop_file (path=0x2156160 "/usr/share/applications/unity-lens-photos.desktop") at ../../src/editors.c:322
 layout_editors_reload_idle_cb (data=<optimized out>) at ../../src/layout_util.c:1955
 g_main_dispatch (context=0x1fbef90) at /build/buildd/glib2.0-2.33.14/./glib/gmain.c:2715
 g_main_context_dispatch (context=context@entry=0x1fbef90) at /build/buildd/glib2.0-2.33.14/./glib/gmain.c:3219

Changed in geeqie (Ubuntu):
importance: Undecided → Medium
summary: - geeqie-standard crashed with SIGSEGV in g_main_context_dispatch()
+ geeqie-standard crashed with SIGSEGV in editor_command_parse()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in geeqie (Ubuntu):
status: New → Confirmed
tags: added: running-unity
visibility: private → public
Changed in geeqie (Ubuntu):
importance: Medium → High

I installed debug symbols for several packages and ran geeqie under valgrind. Here is the log.

Unfortunately there are no debug symbols for package liblcms1.

Till Kamppeter (till-kamppeter) wrote :

Problem can perhaps be that geeqie did not pass from the unmaintained liblcms1 to liblcms2. See bug 885324.

njdove (njdove) wrote :

Looks like Bug #1055673 is a duplicate, wherein comment 4 suggests a work-around: uninstall "unity-lens-photos".

The workaround works for me.

On Fri, Oct 12, 2012 at 4:29 PM, njdove <email address hidden> wrote:

> Looks like Bug #1055673 is a duplicate, wherein comment 4 suggests a
> work-around: uninstall "unity-lens-photos".
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1058829).
> https://bugs.launchpad.net/bugs/1056532
>
> Title:
> geeqie-standard crashed with SIGSEGV in editor_command_parse()
>
> Status in “geeqie” package in Ubuntu:
> Confirmed
>
> Bug description:
> geeqie segfaults whenever I run it. In this crashlog, I just ran the
> command 'geeqie' from gnome-terminal. I had just done a "sudo apt-get
> --reinstall install geeqie" to see if this would fix it.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.10
> Package: geeqie 1:1.0-10.1build1
> Uname: Linux 3.6.0-rc7-git-20120924.1005 x86_64
> ApportVersion: 2.5.2-0ubuntu4
> Architecture: amd64
> Date: Wed Sep 26 09:05:37 2012
> EcryptfsInUse: Yes
> ExecutablePath: /usr/bin/geeqie-standard
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64
> (20120724.2)
> ProcCmdline: geeqie
> ProcEnviron:
> TERM=xterm
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANG=en_AU.UTF-8
> LANGUAGE=en_AU:en
> SegvAnalysis:
> Segfault happened at: 0x44734a: movsbl 0x0(%rbp),%edx
> PC (0x0044734a) ok
> source "0x0(%rbp)" (0x00000000) not located in a known VMA region
> (needed readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: geeqie
> StacktraceTop:
> ?? ()
> ?? ()
> ?? ()
> g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> Title: geeqie-standard crashed with SIGSEGV in g_main_context_dispatch()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm lpadmin sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/geeqie/+bug/1056532/+subscriptions
>

summary: - geeqie-standard crashed with SIGSEGV in editor_command_parse()
+ geeqie-standard crashes on start with SIGSEGV in editor_command_parse()
+ when unity-lens-photos is installed
description: updated
Changed in unity-lens-photos:
status: New → Confirmed
David Callé (davidc3) wrote :

I've found the cause of this:
Geeqie looks into desktop files to search for graphics applications, but crashes when it encounters a desktop file for a graphic app without the "Exec=" line. The Photos lens doesn't have this "Exec=" line because it shoudln't appear (for obvious reasons) as an app in the Applications lens.

Would anyone affected by this bug would be willing to test a fix before I make the change in the Photos lens?

1. Ensure you have the Photos lens (unity-lens-photos) installed
2. Ensure that Geeqie crashes when starting.
2. Open the photos lens desktop file for edition:

$ gksu gedit /usr/share/applications/unity-lens-photos.desktop

3. Remove "Graphics;" from the "Categories" line

Categories=Photography;

4. Save the file and open Geeqie.

David, this fix works perfectly for me. Now I can use geeqie again.

David Callé (davidc3) wrote :

Thanks Till, merging and proposing for SRU.

Changed in unity-lens-photos:
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → David Callé (davidc3)
David Callé (davidc3) on 2012-10-17
description: updated
Changed in unity-lens-photos (Ubuntu):
status: New → Confirmed
Changed in geeqie (Ubuntu):
status: Confirmed → Invalid
David Callé (davidc3) on 2012-10-17
Changed in unity-lens-photos:
milestone: none → 0.9
Didier Roche (didrocks) on 2012-10-19
no longer affects: geeqie (Ubuntu Quantal)
David Callé (davidc3) on 2012-10-19
Changed in unity-lens-photos:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-photos (Ubuntu Quantal):
status: New → Confirmed

Hello Rocko, or anyone else affected,

Accepted unity-lens-photos into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-photos/0.9-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-lens-photos (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: added: verification-needed
Rocko (rockorequin) wrote :

I have unity-photo-lens 0.9-0ubuntu1 and geeqie 1:1.0-10.1build1 installed and geeqie no longer crashes on startup.

tags: added: verification-done
removed: verification-needed

For me the proposed package fixes the bug, too.

Vedran Rodic (vrodic) wrote :

This patch is against 1.1 but should apply to 1.0 too, it fixes the segfault in geeqie itself.

Reactivating the task for the Geequie package as this small patch makes a lot of sense, perhaps we should even apply it as SRU.

tags: added: patch
Changed in geeqie (Ubuntu):
status: Invalid → Triaged
Vedran Rodic (vrodic) wrote :

My fix has been merged in the current official geeqie upstream here:

https://gitorious.org/geeqie/geeqie

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.9-0ubuntu1

---------------
unity-lens-photos (0.9-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - [SRU] Default lenses results should appear above the shopping category
      (LP: #1066957)
    - TypeError:<module>:__init__:__init__:_get_accounts_for_service:constructor
      (LP: #1058061)
    - geeqie-standard crashes on start with SIGSEGV in editor_command_parse()
      when unity-lens-photos is installed (LP: #1056532)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Fri, 19 Oct 2012 10:09:51 +0200

Changed in unity-lens-photos (Ubuntu Quantal):
status: Fix Committed → Fix Released

The attachment "fix segfault" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.9-0ubuntu1

---------------
unity-lens-photos (0.9-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - [SRU] Default lenses results should appear above the shopping category
      (LP: #1066957)
    - TypeError:<module>:__init__:__init__:_get_accounts_for_service:constructor
      (LP: #1058061)
    - geeqie-standard crashes on start with SIGSEGV in editor_command_parse()
      when unity-lens-photos is installed (LP: #1056532)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Fri, 19 Oct 2012 10:09:51 +0200

Changed in unity-lens-photos (Ubuntu):
status: Confirmed → Fix Released
Michal Čihař (nijel) wrote :

Fixed in 1:1.2-1

Changed in geeqie (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers