opening more than one file in gedit causes cursor to spin for a period of time

Bug #792227 reported by Doug McMahon on 2011-06-03
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gedit (Ubuntu)

Bug Description

Binary package hint: gedit

When opening additional files in gedit the cursor will spin on for some time. This occurs because of this line in gedit.desktop

Not sure there is any use of this .desktop option anymore, certainly not in unity

1. Open nautilus (Files launcher)
2. Double-click on a test file to open gedit
3. Move the pointer outside of the edit area of gedit

the 'hourglass' pointer is displayed.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gedit 3.0.4-0ubuntu1 [modified: usr/share/applications/gedit.desktop]
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Jun 3 03:03:09 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
 PATH=(custom, user)
SourcePackage: gedit
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

Please note that the "Package: gedit 3.0.4-0ubuntu1 [modified: usr/share/applications/gedit.desktop]" as seen above reflects me editing that line to stop the cursor spin
The line can either be removed or edited to false

Jean-Baptiste Lallement (jibel) wrote :

Confirmed when opening a file from nautilus

Changed in gedit (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
importance: Medium → Low
description: updated
tags: added: testcase
Doug McMahon (mc3man) wrote :

This bug has been fixed at some point since 06/03, did not actually catch when

Sebastien Bacher (seb128) wrote :

thank you for the update, closing the bug

Changed in gedit (Ubuntu):
status: Triaged → Fix Released
RDSheets (rdsheets) wrote :

Happens when opening a file from Nautilus or Nemo in 12.04. To me so far it just happens with gedit or file viewer (eye of gnome). Changing or removing the StartupNotify line in the .desktop file makes no difference. Cursor will spin for exactly 15 seconds (I have timed it more than once). I've searched all over and no one knows how to fix this problem.

Bib (bybeu) wrote :

I get this issue too, as I described here : :
"Running raring 13.04 I meet a strange behaviour (non-blocking). When I launch a home subfolder (e.g. Music) from the nemo launcher, the windows opens fine but I always get the hourglass pointer for 15s, after which the pointer becomes normal, whether I keep the window opened or I close it before the 15s laptime.
I don't use cinnamon (not installed), just nemo v1.7.2 from synaptic/software center.
When I run nemo Music from a terminal or from the Alt+F2 prompt, I don't get this hourglass. I don't get it neither when I just left-click the nemo parent icon. I don't get this behaviour neither with LibreOffice icon sub-items.
I tried to specify the full path in ~/.local/share/applications/nemo.desktop (Exec=nemo /home/me/Music) with no change in behaviour."
Since this post in askubuntu, I also tried to add StartupNotify=false in each [Desktop Action ActionN] sub-section but this changes nothing.

Bib (bybeu) wrote :

PS: the gedit issue comes back too

Bib (bybeu) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers