gedit crashed with SIGSEGV in g_cancellable_is_cancelled()

Bug #542846 reported by Marat Dyatko
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Critical
gedit (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gedit

I opened the html-document size 150 kilobytes, and press Ctrl+S.
Voila, gedit is crashed!

ProblemType: Crash
Architecture: i386
Date: Sat Mar 20 20:27:03 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gedit
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: gedit 2.29.9-0ubuntu2
ProcCmdline: gedit
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SegvAnalysis:
 Segfault happened at: 0x67682f <g_cancellable_is_cancelled+15>: movzbl (%eax),%eax
 PC (0x0067682f) ok
 source "(%eax)" (0x00094306) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gedit
StacktraceTop:
 g_cancellable_is_cancelled () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
Title: gedit crashed with SIGSEGV in g_cancellable_is_cancelled()
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
Marat Dyatko (marat-dyatko) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_cancellable_is_cancelled () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gedit (Ubuntu):
status: New → Invalid
Revision history for this message
Apport retracing service (apport) wrote : Crash report cannot be processed

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

python2.6: installed version 2.6.5-1ubuntu1, latest version: 2.6.5-1ubuntu2
python2.6-minimal: installed version 2.6.5-1ubuntu1, latest version: 2.6.5-1ubuntu2
libpython2.6: installed version 2.6.5-1ubuntu1, latest version: 2.6.5-1ubuntu2

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

$ python -V
Python 2.6.5

I update system and bug is reproduces.
I can save *.txt file, but when I save a *.html - gedit is crashes.

Changed in gedit (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → New
Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

When I was save a javascript-file to server by SFTP, gedit crashes
Some data was lost!

summary: - gedit crashed with SIGSEGV in g_cancellable_is_cancelled()
+ gedit crashes on file saving
visibility: private → public
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

summary: - gedit crashes on file saving
+ gedit crashed with SIGSEGV in g_cancellable_is_cancelled()
Changed in gedit (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

gotcha!

Revision history for this message
Pedro Villavicencio (pedro) wrote :

the backtrace is empty, please try again.

Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

Sorry, I was bad read wiki instructions :-[

Revision history for this message
Pedro Villavicencio (pedro) wrote :

could you please install the libglib2, libgtk2 and gedit dbgsym packages and get a new one? the one you submitted is missing a few symbols, thanks Marat.

Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

It's first file

Revision history for this message
Marat Dyatko (marat-dyatko) wrote :

and second (contains more information)

Revision history for this message
jpfle (jpfle) wrote :

Maybe it's related to this bug report: https://bugzilla.gnome.org/show_bug.cgi?id=614205

Revision history for this message
Sebastien Bacher (seb128) wrote :

The upstream bug has required informations now

Changed in gedit (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.30.0-0ubuntu1

---------------
gedit (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Fix a crash in the new file saving code (lp: #542846)
    - Misc bugfixes
 -- Sebastien Bacher <email address hidden> Mon, 29 Mar 2010 23:18:50 +0200

Changed in gedit (Ubuntu):
status: Triaged → Fix Released
Changed in gedit:
status: Unknown → Fix Released
Changed in gedit:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.