gedit crashes when opening files by dragging file icon over gedit application

Bug #470383 reported by doughnuts64 on 2009-11-02
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gedit (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

Version of Ububtu: 9.10
Gedit Version: 2.28.0-0ubuntu2

I quite often open files by dragging them over the top of an open application. This can be of great use when opening multiple files in multiple directories. Normally the file would open with no problems. In this case, I had opened about three previous XML files, and upon opening the new one, it showed a blank content (as if the file had no content), and then gedit crashed.

The files were being opened from a Samba share, mounted using smb://<location> (rather than in fstab).

I believe the connection to the Samba file system may have been dropped (as this happens with this specific file system on occasion).

ProblemType: Crash
Architecture: i386
Date: Mon Nov 2 09:26:25 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gedit
NonfreeKernelModules: nvidia
Package: gedit 2.28.0-0ubuntu2
ProcCmdline: gedit /home/username/.gvfs/snook\ on\ lmfdata2.shef.ac.uk/Data/_Final\ Images/Bogotana/Pronuclei\ -\ center\ line\ widest\ point/1\ 4-3-09/#1\ 4-3-09\ bogotana\ pro\ Sperm\ Curve\ Data\ (only\ red)\ -\ 24-4-09.xml
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x7938e4: mov 0x4(%eax),%ecx
 PC (0x007938e4) ok
 source "0x4(%eax)" (0x31223d72) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gedit
StacktraceTop:
 ?? () from /lib/tls/i686/cmov/libc.so.6
 malloc () from /lib/tls/i686/cmov/libc.so.6
 IA__g_malloc (n_bytes=8811480)
 g_input_stream_real_skip_async (stream=0x8a1ac00,
 IA__g_input_stream_skip_async (stream=0x8a1ac00,
Title: gedit crashed with SIGSEGV in malloc()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare vboxusers video

doughnuts64 (duncan-djbp) wrote :

StacktraceTop:_int_malloc (av=<value optimized out>, bytes=<value optimized out>)
*__GI___libc_malloc (bytes=8216) at malloc.c:3638
g_malloc () from /lib/libglib-2.0.so.0
?? () from /usr/lib/libgio-2.0.so.0
g_input_stream_skip_async () from /usr/lib/libgio-2.0.so.0

Changed in gedit (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gedit (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
visibility: private → public
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gedit (Ubuntu):
status: Incomplete → Invalid

I attached a valgrind log of gedit crashing when receiving drag-and-drop.

Changed in gedit (Ubuntu):
status: Invalid → Confirmed
summary: - gedit crashed loading in a small XML file. Opened by dragging file icon
- over gedit application
+ gedit crashes when opening files by dragging file icon over gedit
+ application

I forgot to mention that I experience this bug with the newly release Oneiric Ocelot, while the original report affects an older version of Ubuntu.

A3lyphe (a3lyphe-z) wrote :

Same here, too; but even more drastically:

Systems: Ubuntu (10.04/10.10/11.04/11.10||Gnome2|Gnome3|Unity) AS ALSO Fedora 15/16 AND Debian 6 with Gnome //GEdit 2|3

ANYTIME i drag files it is the same: The whole window crashes, but no crash-report, because the gedit process is running still in the background; only exception: under Fedora 15 with Gnome 2 GEdit hangs and tries to load the file, but by killing the window, the window itself comes back, just stopping the loading, but after ca. 1 minute GEdit crashes, though it was fully functional again the meanwhile; under Gnome 3 in Fedora 15 the window hangs, too but can not be killed; if file(s) have been dragged into a new tab, the whole system halts, otherwise other applications are not part of the problem.
In Ubuntu, all versions independent if Gnome 2 or 3 used, GEdit crashes completely, but process is running. Kill has no effect. Just a full reboot helps.

Another issue under Ubuntu is, that if you use auto-save, the backups become corrupted sometimes and a never before dropped file on GEdit times gets completely corrupted, not restorable.

Due to the fact, that it has none to do with the system or the version, to me it looks like there is a general failure in GEdit relating to some dependency (any library).

What is obvious is, that it has to do in some way with the drag-drop-functionality itself, because under all given systems, you can see, in intervals of ca. 90 to 120 seconds, that the pictograms of the files dropped, are animated moving the way you did with your mouse AND the same issue happens sometimes with latest firefox builds. (Any identical dependencies).

Hope one of you core developers is able to look for the error like a pro. If you just want to response to this bug-addition by giving me tasks like 'give us tech-specs without them we can't do anything' you're just creepers.

Real developers find errors by thinking, not by using coded test-cases; Bugs can not be found if the program does not know the bug.

Sorry, if i was too harsh, but the experience with most self-called developers under launchpad, especially those that handle GNOME and UBUNTU are most worst; Sorry but you guys should make a step-back and get back near perfect applications like GEdit back under full control, not just relying on 'if the system don't report an error, there is no error'-humbug.

Even if you feel yourself attacked, you feel like that because i am right in my statement; You should leave this comment alive, to see if anyone has to propose similar issues and to prove that i am wrong and you are right.

However, thanks for your interest in my writing.

Good luck brothers.

Claudius Raphael Paeth, A3lyphe

every breaking atom llving ...

http://a3lyphe.net

A3lyphe (a3lyphe-z) wrote :

Addition: I do not use SAMBA-shares, nor is SAMBA-handling installed; the bug is given with local files and net-files, independent of location and user/folder-rights or file-system ...

biffta (hopkins81) wrote :

Not sure I fully understand the rant from A3lyphe, but I've noticed this bug too and have attached a core file. Hopefully it will assist.

Jean-Philippe Fleury (jpfle) wrote :

I too have a gedit crash on Oneiric with drag and drop. This bug is reported here: https://bugs.launchpad.net/ubuntu/+source/pygobject/+bug/863773 It occurs if the "Snippets" plugin is enabled. This is fixed in the upcoming gedit version 3.2.3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers