"Text Editor" changed to "gedit Text Editor" in Applications->Accessories

Bug #442417 reported by Connor Imes on 2009-10-04
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gedit (Ubuntu)
Low
Unassigned
ubuntu-docs (Ubuntu)
Medium
Connor Imes

Bug Description

Binary package hint: gedit

The only bug I could find relating to this was bug 421221, but it changed "gedit" to "gedit Text Editor". It seems like there might still be some discussion going on upstream despite the bug being marked as Fixed. Regardless, the naming convention is wrong.

This bug also affects ubuntu-docs. If this is not going to be fixed for Karmic, we may need a String Freeze exception. If it's going to change to something other than back to "Text Editor", the same applies. Either way, I think gedit, ubuntu-docs, or both need to be updated so that they are in sync with each other.

Thanks.

Connor Imes (ckimes) wrote :

This is a simple patch for ubuntu-docs which can be used if it is decided to keep "gedit Text Editor" as the string used in the menu entry.

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Connor Imes (rocket2dmn)
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

there is no gedit bug there

Changed in gedit (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Matthew East (mdke) wrote :

Sebastien,

The current menu entry is quite unpleasant to look at (because it begins with a small letter) and is inconsistent with the other menu entries for core components which don't use the name of the application. Is the desktop team of the view that this menu entry is correct?

If so please close the gedit task again and we'll amend the documentation but it would be helpful to have that express confirmation (NB we are talking about a change which was made after the UI freeze without being notified to the docteam).

Changed in gedit (Ubuntu):
status: Invalid → New
Tormod Volden (tormodvolden) wrote :

For common people just wanting to run a common text editor, "Text Editor" sounds intuitive and reassuring. "gedit Text Editor" sounds like something for special purposes. We can't start with "gcalctool calculator" etc, then we're back in the nineties, IMO.

Björn Nilsson (bni-swe) wrote :

This irritate me too. I dont care I run "gedit". I use the Ubuntu desktop Text Editor.

It is small issues like this that make Ubuntu look bad to new users, and to veteran users also in some cases :-)

Harry (harry33) on 2009-12-07
Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Connor Imes (ckimes) wrote :

I've updated the variable in ubuntu-docs to call it "gedit Text Editor" as it currently appears on systems. If this is fixed in gedit at a later time, we will switch it back.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package ubuntu-docs - 10.04.1

---------------
ubuntu-docs (10.04.1) lucid; urgency=low

  * First upload for lucid
  * General:
    - Refresh pot files
    - Changed 'Text Editor' to 'gedit Text Editor' LP: #442417 (Connor Imes)
  * Advanced-topics:
    - Added link in advanced-topics to a description about Users and Groups in
      Debian systems. LP: #145055 (Connor Imes)
  * Hardware:
    - Added mention of ext4 to hardware.xml and changed the mentioning of the
      default filesystem in Ubuntu from ext3 to ext4 LP #449667 (Connor Imes)
    - Removed subsection in hardware about quirk-checker script - link was
      broken, script is outdated LP: #461158 (Connor Imes)
  * Keeping-safe:
    - Updating instructions for automatic login for new GDM LP: #442676
     (Dean Sas)
    - String adjustment (period inside of a quote tag), Scott Shields,
      LP: #496885
  * Internet:
    - Changes remaining mention of flashplugin-nonfree to flashplugin-installer
      in web-apps.xml LP: #444546 (Connor Imes)
    - Change some <guimenu> tags to <guimenuitem> tags in web-apps.xml to show
      arrows in HTML documentation instead of + signs LP: #453512 (Connor Imes)
    - Removed reference to network-manager radio buttons, as radio buttons
      aren't used in this version of NM for wired networks (Jim Campbell)
    - Aligned similar strings in 'internet' section to benefit translators;
      some small adjustments. LP: #460360 (Connor Imes)
  * Musicvideophotos:
    - Fixed apturl for mtp-tools package in music.xml LP #452262 (Connor Imes)
    - Improve ipod section, patch by Michael Fitzhugh. LP: #370085
  * Printing:
    - Updated printer setup directions in printing section LP: #435510
      (Connor Imes)
    - Fix scanning typo. Patch by Shane Fagan LP: #447250
  * Programming:
    - Removed entire programming section LP: #414035 (Connor Imes)
  * Serverguide:
    - Adjusted wording in serverguide package-management file to more
      clearly describe apticron. LP: #473280 (Connor Imes)
    - Updated LDAP section for changes to the Jaunty package.
      Fixes LP: #475492, LP: #459403, LP: #463684 (Adam Sommer)
    - In OpenSSH section, .ssh/authorized_keys permissions should be
      600, not 644 LP: #491159 (Connor Imes)
    - Replaced description of ebox Log Observer in serverguide with a real
      description of the event's purpose LP: #405926 (Connor Imes)
    - Fixed IP example in serverguide's postfix configuration section
      LP: #495202 (Connor Imes)
    - Include 'auto eth1' in interfaces file for static IP configuration
      LP: #441802 (Connor Imes)
    - Fix for disabling Control-Alt-Delete in serverguide. Scott Shields,
      LP: #496465
    - Typo fix, Scott Shields, LP: #497867
    - PostgreSQL setup fix for config file pg_hba.conf, Scott Shields,
      LP: #492286
    - Misc fixes in windows-networking section. Vikram Dhillon, LP: #462607
    - Changes to RAID installation section LP: #428036, LP: #462719
      (Connor Imes)
    - Fixes and adjustments to web-servers LP: #462621 (Connor Imes)
  * Switching:
    - Replaced Pidgin with Empathy in applications-equivalents
      LP: #490980 (Connor Ime...

Read more...

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
David Futcher (bobbo) wrote :

Is this an actual bug in gedit? Can the gedit bug task be marked as invalid?

Tormod Volden (tormodvolden) wrote :

I believe the bug in gedit is that it calls itself "gedit Text Editor" and not "Text Editor" (in Ubuntu). I don't know if that should be done in bug 421221 (which has the usual amount of blame-gaming) but that bug does not have a "gedit (Ubuntu)" task open.
I understand that upstream as authors of the app would like to use the full name, but it does not belong in the Ubuntu menu.

Nigel Babu (nigelbabu) wrote :

Since this seemed to an informed decision to change the name, I'm closing the gedit task.

Changed in gedit (Ubuntu):
status: New → Invalid

"Seemed" sounds not very definite to me...

I really like a non-cluttered naming scheme/UI philosophy especially for things I see every day. This is important for beginning users, but also very much for the more experienced. I've been using Ubuntu for a long time now (as my primary system, at work and at home), and the main reason to like it (besides the community and open source thing) is that it has (or, apparently, had) a strong vision shared with Gnome that computers should be friendly to humans and that we made them to make our workflows as easy as we can...

How can you defend a choice like this in this perspective? Then we might as well add a config button to the screensaver, no? (for the record: which I would welcome)

I must have missed something important.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers