gedit crashed with SIGSEGV in g_list_last()

Bug #402225 reported by dino99 on 2009-07-21
200
This bug affects 44 people
Affects Status Importance Assigned to Milestone
gedit (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: gedit

karmic testing

cant open .xsession-errors with gedit: try to open then crash, have to use notepad

ProblemType: Crash
Architecture: i386
Date: Tue Jul 21 15:47:15 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gedit
NonfreeKernelModules: nvidia
Package: gedit 2.27.2-1ubuntu1
ProcCmdline: gedit /home/User Name/.xsession-errors
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SegvAnalysis:
 Segfault happened at: 0x34c5c2 <g_list_last+18>: mov 0x4(%eax),%edx
 PC (0x0034c5c2) ok
 source "0x4(%eax)" (0xaaaaaaae) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gedit
StacktraceTop:
 g_list_last () from /usr/lib/libglib-2.0.so.0
 gdk_window_process_updates ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_cclosure_marshal_VOID__VOID ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
Title: gedit crashed with SIGSEGV in g_list_last()
Uname: Linux 2.6.31-3-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

dino99 (9d9) wrote :
dino99 (9d9) wrote :

got this too:
 kernel: [28209.463885] <6>gedit[14908]: segfault at aaaaaaae ip 0034c5c2 sp bfbe93d8 error 4 in libglib-2.0.so.0.2104.0[316000+c3000]

visibility: private → public

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

Changed in gedit (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libpango1.0-common: installed version 1.24.4-1ubuntu1, latest version: 1.24.5-1ubuntu1
libpango1.0-0: installed version 1.24.4-1ubuntu1, latest version: 1.24.5-1ubuntu1

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
tags: added: need-i386-retrace
riva.dani (riva.dani) wrote :

I don't know if what I found is the same bug. If I give "sudo gedit /etc/apt/sources.list" I get this error: "Segmentation fault (core dumped)". I tried to give just "sudo gedit" and then I opened the file manually: it worked perfectly.
I'm sure I have no outdated packages.

Florian Schweikert (kelvan) wrote :

similar problem when opening a djang/python file.
.xsession-errors works :/

problem exists only with the models.py from one django project.

nothing special in this file just defines classes, models.py from other projects works.

Florian Schweikert (kelvan) wrote :

Problem doesn't exists when cd into the dir and open with gedit filename.
From another dir I got Seg fault

In response to your conclusion I tryed opening python files from
openoffice and they all went fine. Strange thing.

2009/8/7 Florian Schweikert <email address hidden>:
> Problem doesn't exists when cd into the dir and open with gedit filename.
> >From another dir I got Seg fault
>
> --
> gedit crashed with SIGSEGV in g_list_last()
> https://bugs.launchpad.net/bugs/402225
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Architecture: amd64
DistroRelease: Ubuntu 9.10
Package: gedit 2.27.3-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in gedit (Ubuntu Karmic):
status: Invalid → Confirmed
importance: Undecided → High
Robbie Williamson (robbiew) wrote :
tags: added: apport-collected
Robbie Williamson (robbiew) wrote :

This is easily reproducible on my box with the latest Karmic updates installed. FWIW, I've attached my .crash file from /var/crash.

Sebastien Bacher (seb128) wrote :

Robbie don't attach .crash files to bugs but use apport to send those

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers