Ubuntu

Can't save changes in VirtualBox Shared Folder. Nano, OOo do it.

Reported by Launch on 2009-03-12
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gedit
New
Medium
gedit (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

I can't edit files in VirtualBox Shared Folders:
sudo mkdir /mnt/share
sudo mount.vboxsf -o uid=1000,gid=1000 vs /mnt/share
or
sudo mount -t vboxsf vs /mnt/share -o rw,exec,uid=1000,gid=1000,dev
$ echo blubb > /mnt/share/New
it works

$ ls -l /mnt/share
$ -rw-rw-rw- 1 usr usr 31 2009-03-11 18:24 New
$ gedit /mnt/share/New - can't save changes.
(But nano, OpenOffice.org do it!)
How to edit files in shared folders with gedit?

But, L try now, gedit can save into file without caps letters, for example,
$ gedit /mnt/share/New
edit and save as 'new ' - gedit do it

Sun xVM VirtualBox 1.6.4, Host Win XP SP3, Guest Ubuntu 7.10,
gedit 2.22.3 :
http://ru.archive.ubuntu.com/ubuntu/pool/main/g/gedit/gedit_2.22.3-0ubuntu2_i386.deb

ProblemType: Bug
Architecture: i386
Date: Thu Mar 12 16:42:25 2009
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gedit
Package: gedit 2.22.3-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/User Name/local/sbin:/User Name/local/bin:/User Name/sbin:/User Name/bin:/sbin:/bin:/User Name/games
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: gedit
Uname: Linux 2.6.24-19-generic i686

Launch (invention) wrote :
Launch (invention) wrote :

Gedit can't save when file name have at least one caps or space symbol.

Launch (invention) wrote :

No, gedit can save as once but next edit and save does not works.

Launch (invention) wrote :

Gedit can save as once into file with any case and spaces.
But then can't save changes in one.

Pedro Villavicencio (pedro) wrote :

thanks for the report, may you please try the same with jaunty or intrepid? gvfs has changed a lot and gedit has a better support for such things there, thanks.

Changed in gedit (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Steve Love (stevelove) wrote :

Seems like this is still an issue with Jaunty. I cannot edit an existing file and save the changes unless I save it with a new file name.

Sebastien Bacher (seb128) wrote :

can you rename files on this filesystem out of gedit?

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gedit (Ubuntu):
status: Incomplete → Invalid
Steve Love (stevelove) wrote :

Sorry, I had forgotten to subscribe to changes on this bug.

I'm not sure I understand what information you're looking for, but it sounds like you want me to try saving changes to file contents with something other than Gedit?

On my Ubuntu virtual machine, I created an empty file called testing.txt inside the shared directory. I opened the file with Nano and added some text. I saved the file with no problems. I opened the file again and verified that the changes were saved.

When I opened the file in Gedit and tried to save changes to the content, I received the message: "Could not save the file ~/Shared/testing.txt. Unexpected error: text file busy."

Then I opened the file with vi and saved content changes with no problems.

I apologize if I'm not providing the correct information. Please let me know if you need other details to investigate. Thanks.

wasim2050 (mukadam-wasim) wrote :

I m running Ubuntu 9.10 inside VirtualBox which is installed inside Windows 7.
I am facing similar problems with Gedit when I try to save files in shared folders while I can save files with leafpad in shared folders.

See here for more detail on my problem and screenshots.

http://ubuntuforums.org/showthread.php?t=1335386

Changed in gedit (Ubuntu):
status: Invalid → Confirmed
Changed in gedit (Ubuntu):
status: Confirmed → Invalid
lietk12 (lietk12) wrote :

> can you rename files on this filesystem out of gedit?

I will assume that, by this, you are asking whether files can be renamed using anything that is not part of gedit, such as nautilus. If so, the answer is yes.

Furthermore, it is possible to rename a file on this filesystem from within the "File Browser" plugin in gedit.

Launch (invention) wrote :

I install VirtualBox-3.1.2-56127-Win.exe.
Today I try to edit and save text in shared folder and have error:
~$ echo blubb > /mnt/share/New_20100208
~$ gedit /mnt/share/New_20100208

** (gedit:1942): WARNING **: Hit unhandled case 0 (Text file busy) in parse_error.
~$ nano /mnt/share/New_20100208

OK

Have to set Status 'confirmedэю

Changed in gedit (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

lietk12 (lietk12) wrote :

I've filed a bug report (although it is probably rather lacking in details) at https://bugzilla.gnome.org/show_bug.cgi?id=609566

Changed in gedit:
status: Unknown → New
Changed in gedit (Ubuntu):
status: Confirmed → Triaged
Changed in gedit:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.