Ubuntu

Gedit ctrl-T does not open new tab

Reported by Peter Lonjers on 2008-11-25
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Wishlist
Papercuts Ninjas
gedit
Confirmed
Low
gedit (Ubuntu)
Wishlist
Unassigned

Bug Description

I am using intrepid with the default gedit.

When I am in gedit and press ctr-t a new tab does not open.
ctr-n works but it took me a long time to find and it is not what I am used to after using firefox for so long.
Perhaps both could be mapped to opening a new tab. Or if some one uses ctr-t a dialog could pop up showing to use ctr-n.

This should be changed to wishlist.

Changed in gedit:
status: New → Invalid
Bernhard (b.a.koenig) wrote :

You could install geany. It's just as fast and user-friendly as gedit, more powerful and you can define your own keyboard shortcuts.

It seems, rather than completely disregarding this, there should be a standard for this kind of thing. All Gnome apps should have unified key settings (ctrl+t opening a new tab, for instance.) Its up for debate.

Mackenzie Morgan (maco.m) wrote :

You can define your own keyboard shortcuts in most GNOME applications. System -> Preferences -> Appearance -> Interface, check "Editable menu shortcut keys". Then mouse-over the item in the menu and hit whatever shortcut you want to remap it to. This should work for most things in GNOME, the notable exception being Evolution.

Peter Lonjers (plonjers) wrote :

Thanks for the help. I know you can remap the keys or use a different editor but I was just thinking about it as default for ubuntu. Anyways changing status to wish list unless there is a reason for this to be invalid.

Peter Lonjers (plonjers) wrote :

Never mind apparently I can not change the status.

I'm discussing making ctrl+t a new standard GNOME keyboard shortcut with
the GNOME Usability team. The thing is, on Gedit it's Ctrl+N as in "New
Document." Someone on the Usability team says before GTK 2, Gedit
opened new files in new windows. So bringing back
new-file-in-new-window on Ctrl+N and making new-file-in-new-tab be Ctrl
+T is also being talked about there.

Assuming I can use LP's email interface properly...

importance wishlist

Changed in gedit:
importance: Undecided → Wishlist
status: Invalid → New
Changed in gedit:
status: New → Confirmed
Changed in gedit:
assignee: nobody → desktop-bugs
Pedro Villavicencio (pedro) wrote :

right, there's a bug on the HIG regarding the new tab shortcuts http://bugzilla.gnome.org/show_bug.cgi?id=416110 ; this reports needs to be send upstream to bugzilla.gnome.org where the software authors can read it, thanks.

Felipe Castillo (fcastillo.ec) wrote :

the reason why ctrl+t doesn't work, it's because it's use for indention. When you activate the plugin you can indent text automatically. I don't think it should be use to open a new tab, because you are not just opening a new tab, you're creating a new document, so ctrl+n makes lots of sense. Maybe there should be another shortcut to open a new document in a new window.
That's why gedit doesn't call it, open a new tab, it's create a new document.
I totally disagree with this bug report.

Johnathon (kirrus) wrote :

Adding to upstream bug report

Changed in gedit:
importance: Undecided → Unknown
status: New → Unknown
Changed in gedit:
status: Confirmed → Triaged
Johnathon (kirrus) wrote :

fcastillo, the problem is, new users, used to using CTRL-T in other applications, will expect it to do the same thing in gedit. It makes logical sense for it to be CTRL-N in gedit, but it does not make as clear a logical sense a for firefox. Its a very complicated usability issue... it's up to the devs to decide what to do.

Changed in gedit:
status: Unknown → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
milestone: none → round-10

Related bug # 389873

Recommends using ctrl-n to open a new document in a new window, not in a new tab.

Michael W. Koehler (mkoehle1) wrote :

I had made a quick debdiff to change the shortcut from CTRL+N to CTRL+T for another bug report. You can decide whether to use it or you can go a different route.

Sebastien Bacher (seb128) wrote :

Thank you for your work there, could you add the patch upstream too?

Michael W. Koehler (mkoehle1) wrote :

Sure. I added it to #416110 in Bugzilla. Also, if you would like to have that file included in the next release of gedit, I'll need someone to help by sponsoring it (I don't have access).

Changed in hundredpapercuts:
milestone: round-10 → r2
alecwh (alecwh) wrote :

Hello, what's the progress on this? Is Michael's patch being used? Has the patch been submitted to the gedit developers?

Johnathon (kirrus) wrote :

The patch has been submitted upstream, but it's waiting for one of their developers to look at it.

The patch has not been applied to ubuntu, it will need a sponsor, but I don't know how to request one :/

Mackenzie Morgan (maco.m) wrote :

 subscribe ubuntu-main-sponsors

Chris Coulson (chrisccoulson) wrote :

I don't think that this can be uploaded without further discussion. Ctrl+T is already used by the indent plugin, so you'd need to reassign that keybinding to something else first.

Sebastien Bacher (seb128) wrote :

thank you for the work there, could you open upstream bugs on gedit though? the one you added your changes too is a hig documentation bug and no gedit hacker will likely read it there. unsubscribing the sponsors for now, as chris said that requires discussions

Anzenketh (anzenketh) on 2010-02-26
tags: added: bitesize
tags: removed: bitesize
Anzenketh (anzenketh) wrote :

If we leave it how it is we do not have to retrain people using the indent
plugin. And people can figure out what the hotkey is by looking at the file
menu.

However if we change it how would we communicate to the users of the plugin
that there plug-in no longer works.

If we want to implement this I say we would need to check to see if the plugin
Indent Lines is enabled.

Vish (vish) on 2010-02-28
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Allan Day (allanday) wrote :

There's another upstream report of this bug here: https://bugzilla.gnome.org/show_bug.cgi?id=588702

Tobias Wolf (towolf) wrote :

Seriously people. I beg to differ. Ctrl-N has been use for »New...« in all programs for ages.

Now Firefox came along and had Ctrl-N for »New Window«, so Ctrl-N was taken and they made Ctrl-T »New Tab«. It turned out people want to open new tabs more often and became trained on Ctrl-T for »New ...«. It’s wrong, Firefox should have made Ctrl-N open a new tab.

Nowadays I even have to patch programs to move Ctrl-T back to Ctrl-N, where it should be and you people want to mess things up further.

Just look at any software: Photoshop, Notepad, anything (but browsers). Ctrl-N is »New ...«

Peter Lonjers (plonjers) wrote :

Ok so I did a little experiment. I went through all the applications in my Ubuntu menu. Firefox, terminal, gedit, and nautilus had tabs. They all used ctr-t for new tab and ctr-n for new window except gedit. Well the terminial used ctr-shift-t for new tab but same idea.

Chris Coulson (chrisccoulson) wrote :

Well, remember that the primary action for the CTRL+N binding in Gedit is to start a new document. It just happens to open the new document in another tab rather than a new window (because it is a tabbed application).

I took a look at Openoffice, Abiword and Gnumeric, and they all use CTRL+N to create a new document, just like Gedit.

This is exactly why we haven't just uploaded a change yet

Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: lucid-round-2 → maverick-round-2-mail+office
tags: added: patch patch-forwarded-upstream
tags: removed: patch
Bilal Akhtar (bilalakhtar) wrote :

The decision is not confirmed yet for this bug, so marking it confirmed rather than triaged.

Changed in hundredpapercuts:
status: Triaged → Confirmed
Changed in gedit (Ubuntu):
status: Triaged → Confirmed
Vish (vish) wrote :

Triaged in gedit, the bug has been sent upstream

Changed in gedit (Ubuntu):
status: Confirmed → Triaged
Changed in gedit:
importance: Unknown → Low
Chris Wilson (notgary) on 2011-01-18
Changed in hundredpapercuts:
milestone: maverick-round-2-office → none
Chris Wilson (notgary) wrote :

This problem has been under discussion on Brainstorm for a while now

http://brainstorm.ubuntu.com/idea/17763/

Chris Wilson (notgary) on 2011-01-28
Changed in hundredpapercuts:
importance: Low → Wishlist
Chris Wilson (notgary) on 2011-01-31
Changed in ayatana-design:
status: New → Invalid
Chris Wilson (notgary) wrote :

Has a decision been reached on what should be done about this issue yet?

Changed in gedit (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
John Lea (johnlea) on 2011-12-14
no longer affects: ayatana-design
Chris Wilson (notgary) wrote :

I think regardless of what decision is made by the Gedit devs and Gnome HIG team, a patch for this should at least be included in 12.04 since Ctrl+T make the most sense for opening a tab, and with the 5 years of support being offered with this LTS, many people, especially corporate users, won't upgrade until the last possible minute in 2017 when that supported expires.

Changed in hundredpapercuts:
milestone: none → precise-3-productivity
status: Confirmed → Triaged
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Chris Wilson (notgary) on 2012-06-10
Changed in hundredpapercuts:
milestone: precise-3-productivity → quantal-2-productivity
Chris Wilson (notgary) on 2012-11-29
Changed in hundredpapercuts:
milestone: quantal-2-productivity → gedit
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: gedit → papercuts-s-gedit
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.