Fails to open a file with colon in filename, from the commandline

Bug #261399 reported by Jani Uusitalo
2
Affects Status Importance Assigned to Milestone
gedit
Fix Released
Critical
gedit (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gedit

In Hardy, with all updates, trying to open a file with a colon in its filename, for editing in gedit, from the command-line:

jani@shuttle-xpc:~/.gnome2/epiphany/extensions/data/greasemonkey$ ls http\:__userscripts.org_scripts_source_7122.user.js
http:__userscripts.org_scripts_source_7122.user.js
jani@shuttle-xpc:~/.gnome2/epiphany/extensions/data/greasemonkey$ LC_ALL=C gedit http\:__userscripts.org_scripts_source_7122.user.js

(gedit:12339): libgnomevfs-WARNING **: trying to read a non-existing handle

What I expected to happen: I expect gedit to open the file I've specified on the command-line.
What happens instead: The file is not loaded into gedit. Gedit opens, but reports that "http:__userscripts.org_scripts_source_7122.user.js is not a valid location. Please check that you typed the location correctly and try again."

Opening the file in question with gedit is possible either by clicking the file in a Nautilus browser window, or by selecting it through gedit's own File > Open.... Also, it works from the commandline if I precede the filename with a "./", as in:

$ gedit ./http\:__userscripts.org_scripts_source_7122.user.js

This may not be gedit-specific, but because I'm not familiar with the underlying mechanics, I'm filing this against gedit which is the only one I've come across the issue with.

ProblemType: Bug
Architecture: i386
Date: Tue Aug 26 10:04:53 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gedit
Package: gedit 2.22.3-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin/post-ocr-correction:/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fi_FI.UTF-8
SourcePackage: gedit
Uname: Linux 2.6.24-19-generic i686

Related branches

Revision history for this message
Jani Uusitalo (uusijani) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

this is not a bug, you need to escape that column or use " instead as: program "http\:__userscripts.org_scripts_source_7122.user.js" but this is not a gedit issue that's how the files are handled on Linux.

Changed in gedit:
status: New → Invalid
Revision history for this message
Pedro Villavicencio (pedro) wrote :

talked too soon, command line fails, but file->open and nautilus works, will look upstream, thanks.

Changed in gedit:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Invalid → Triaged
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=549427

Changed in gedit:
status: Unknown → New
Revision history for this message
Pedro Villavicencio (pedro) wrote :

the bug has been fixed upstream , thanks for reporting.

Changed in gedit:
status: Triaged → Fix Committed
Revision history for this message
Jani Uusitalo (uusijani) wrote :

All right, thank you!

Changed in gedit:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 2.23.91-0ubuntu1

---------------
gedit (2.23.91-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Misc bugfixes (lp: #261399, #263537)

 -- Sebastien Bacher <email address hidden> Mon, 01 Sep 2008 15:59:13 +0200

Changed in gedit:
status: Fix Committed → Fix Released
Changed in gedit:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.